diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-14 21:40:51 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-28 23:26:58 -0300 |
commit | 26fd091e2abfdaaeb5572400f401e752977e6414 (patch) | |
tree | 635c2a6a9e13e17b7032192122aa4beb520e5c86 | |
parent | e9894499d6ebb2e14c26a54fbfb99f7d3efecebb (diff) | |
download | meta-freescale-26fd091e2abfdaaeb5572400f401e752977e6414.tar.gz |
u-boot-fslc: Upgrade to a 2015.07-based fork
This upgrades the FSL Community fork to a 2015.07-based one. The
following patches are applied on top of the original source code:
31851bd wandboard: Drop revision specific DeviceTree support
a31d74b mx6sabresd: Enable video interfaces in bootargs
9aaf17f Revert "embestmx6boards: convert to use config_distro_bootcmd.h"
05c69ef wandboard: Changed mmcroot variable so kernel 3.10.31 boots
3e86dfb iMX6: Change mmcroot to use fixed mmc block index for USDHC
44ffc6d mx6sabresd: Use mmcblk0 for CONFIG_MMCROOT
7767edb embestmx6boards: Change default bootenv configuration
bebd6c7 mx6sabresd: Use LDO dtb file until LDO bypass support is added
8a82d9d mx6slevk: Use LDO dtb file until LDO bypass support is added
6f3f04e thermal: imx_thermal: fix busywait if IMX6 temp <0C
a978050 tools: mkimage: fix imximage header size
8788cb7 i2c: fix vf610 support
a7fd9dd net: fec_mxc: remove useless struct nbuf
823ba31 iMX: adding parsing to hab_status command
0210211 imx: mx6 add i2c4 clock support for i.MX6SX
8e45722 imx: mx6 remove duplicated enable_cspi_clock
bf639dd imx6: standardise OCOTP and fuse config to mx6_common
4d4c88c thermal:imx_thermal: enter busywait cooling loop when over max CPU temp
c23cd60 mx53loco: Use generic 'load' command instead of 'fatload'
Change-Id: I7215c00328e6110fb40effa0514a28d076bbedf0
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc-mxsboot_2015.07.bb (renamed from recipes-bsp/u-boot/u-boot-fslc-mxsboot_2015.04.bb) | 8 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc.inc | 4 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc_2015.04.bb | 6 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc_2015.07.bb | 6 |
4 files changed, 12 insertions, 12 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2015.04.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2015.07.bb index 3981b604..bf71b27d 100644 --- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2015.04.bb +++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2015.07.bb | |||
@@ -1,14 +1,14 @@ | |||
1 | DESCRIPTION = "U-boot bootloader mxsboot tool" | 1 | DESCRIPTION = "U-boot bootloader mxsboot tool" |
2 | LICENSE = "GPLv2+" | 2 | LICENSE = "GPLv2+" |
3 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919" | 3 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95" |
4 | SECTION = "bootloader" | 4 | SECTION = "bootloader" |
5 | DEPENDS = "openssl" | 5 | DEPENDS = "openssl" |
6 | PROVIDES = "u-boot-mxsboot" | 6 | PROVIDES = "u-boot-mxsboot" |
7 | 7 | ||
8 | PV = "v2015.04+git${SRCPV}" | 8 | PV = "v2015.07+git${SRCPV}" |
9 | 9 | ||
10 | SRCREV = "10aced37cecf117e54e71bd700228f57dc34e579" | 10 | SRCREV = "31851bd6bd527b1c9275ea9597594f382779c679" |
11 | SRCBRANCH = "patches-2015.04" | 11 | SRCBRANCH = "2015.07+fslc" |
12 | 12 | ||
13 | SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}" | 13 | SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}" |
14 | 14 | ||
diff --git a/recipes-bsp/u-boot/u-boot-fslc.inc b/recipes-bsp/u-boot/u-boot-fslc.inc index a9b35a64..5f297b95 100644 --- a/recipes-bsp/u-boot/u-boot-fslc.inc +++ b/recipes-bsp/u-boot/u-boot-fslc.inc | |||
@@ -1,4 +1,4 @@ | |||
1 | # Copyright (C) 2012-2014 O.S. Systems Software LTDA. | 1 | # Copyright (C) 2012-2015 O.S. Systems Software LTDA. |
2 | # Released under the MIT license (see COPYING.MIT for the terms) | 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
3 | 3 | ||
4 | require recipes-bsp/u-boot/u-boot.inc | 4 | require recipes-bsp/u-boot/u-boot.inc |
@@ -10,7 +10,7 @@ order to provide support for some backported features and fixes, or because it \ | |||
10 | was submitted for revision and it takes some time to become part of a stable \ | 10 | was submitted for revision and it takes some time to become part of a stable \ |
11 | version, or because it is not applicable for upstreaming." | 11 | version, or because it is not applicable for upstreaming." |
12 | LICENSE = "GPLv2+" | 12 | LICENSE = "GPLv2+" |
13 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919" | 13 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95" |
14 | COMPATIBLE_MACHINE = "(mxs|mx5|mx6|vf)" | 14 | COMPATIBLE_MACHINE = "(mxs|mx5|mx6|vf)" |
15 | 15 | ||
16 | DEPENDS_mxs += "elftosb-native openssl-native" | 16 | DEPENDS_mxs += "elftosb-native openssl-native" |
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2015.04.bb b/recipes-bsp/u-boot/u-boot-fslc_2015.04.bb deleted file mode 100644 index aeefc5a9..00000000 --- a/recipes-bsp/u-boot/u-boot-fslc_2015.04.bb +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | include u-boot-fslc.inc | ||
2 | |||
3 | PV = "v2015.04+git${SRCPV}" | ||
4 | |||
5 | SRCREV = "5d9ffd22149119c0acfd31efb8c4d40afca7ce6f" | ||
6 | SRCBRANCH = "patches-2015.04" | ||
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2015.07.bb b/recipes-bsp/u-boot/u-boot-fslc_2015.07.bb new file mode 100644 index 00000000..b498ba9c --- /dev/null +++ b/recipes-bsp/u-boot/u-boot-fslc_2015.07.bb | |||
@@ -0,0 +1,6 @@ | |||
1 | include u-boot-fslc.inc | ||
2 | |||
3 | PV = "v2015.07+git${SRCPV}" | ||
4 | |||
5 | SRCREV = "31851bd6bd527b1c9275ea9597594f382779c679" | ||
6 | SRCBRANCH = "2015.07+fslc" | ||