diff options
author | Ting Liu <ting.liu@nxp.com> | 2016-08-12 18:43:49 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-08-12 11:43:43 -0300 |
commit | 63c4151083e8bca01607b61089d1e0634809c9fb (patch) | |
tree | 26096f9832fcd03b4f2919c907b38a148e21fa84 | |
parent | 1711129869e58329e30bd40a0aa9cc9c06ffead6 (diff) | |
download | meta-freescale-63c4151083e8bca01607b61089d1e0634809c9fb.tar.gz |
linux-qoriq: fix build path of the dtb
Signed-off-by: Ting Liu <ting.liu@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-kernel/linux/linux-qoriq/powerpc-fsl-Fix-build-of-the-dtb-embedded-kernel-images.patch | 45 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-qoriq_4.1.bb | 1 |
2 files changed, 46 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-qoriq/powerpc-fsl-Fix-build-of-the-dtb-embedded-kernel-images.patch b/recipes-kernel/linux/linux-qoriq/powerpc-fsl-Fix-build-of-the-dtb-embedded-kernel-images.patch new file mode 100644 index 00000000..1103f0c2 --- /dev/null +++ b/recipes-kernel/linux/linux-qoriq/powerpc-fsl-Fix-build-of-the-dtb-embedded-kernel-images.patch | |||
@@ -0,0 +1,45 @@ | |||
1 | From 4680c9d50637f78338e786c920aef6c171c7cc00 Mon Sep 17 00:00:00 2001 | ||
2 | From: Alessio Igor Bogani <alessio.bogani@elettra.eu> | ||
3 | Date: Mon, 18 Apr 2016 08:36:19 +0200 | ||
4 | Subject: powerpc/fsl: Fix build of the dtb embedded kernel images | ||
5 | |||
6 | Commit dc37374b9c833 ("powerpc/fsl: Move Freescale device tree files | ||
7 | into fsl folder") moved a lot of device tree files into fsl directory, | ||
8 | fixing Makefile for cuImage target only. Unfortunately there are other | ||
9 | targets which require embedding a device tree into the kernel image | ||
10 | (e.g. dtbImage.%). So use a more generic approach. | ||
11 | |||
12 | Signed-off-by: Alessio Igor Bogani <alessio.bogani@elettra.eu> | ||
13 | [scottwood: cleaned up commit message] | ||
14 | Signed-off-by: Scott Wood <oss@buserror.net> | ||
15 | --- | ||
16 | arch/powerpc/boot/Makefile | 6 +++--- | ||
17 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
18 | |||
19 | diff --git a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile | ||
20 | index 6116510..8fe78a3 100644 | ||
21 | --- a/arch/powerpc/boot/Makefile | ||
22 | +++ b/arch/powerpc/boot/Makefile | ||
23 | @@ -362,9 +362,6 @@ $(obj)/cuImage.initrd.%: vmlinux $(obj)/%.dtb $(wrapperbits) | ||
24 | $(obj)/cuImage.%: vmlinux $(obj)/%.dtb $(wrapperbits) | ||
25 | $(call if_changed,wrap,cuboot-$*,,$(obj)/$*.dtb) | ||
26 | |||
27 | -$(obj)/cuImage.%: vmlinux $(obj)/fsl/%.dtb $(wrapperbits) | ||
28 | - $(call if_changed,wrap,cuboot-$*,,$(obj)/fsl/$*.dtb) | ||
29 | - | ||
30 | $(obj)/simpleImage.initrd.%: vmlinux $(obj)/%.dtb $(wrapperbits) | ||
31 | $(call if_changed,wrap,simpleboot-$*,,$(obj)/$*.dtb,$(obj)/ramdisk.image.gz) | ||
32 | |||
33 | @@ -381,6 +378,9 @@ $(obj)/treeImage.%: vmlinux $(obj)/%.dtb $(wrapperbits) | ||
34 | $(obj)/%.dtb: $(src)/dts/%.dts FORCE | ||
35 | $(call if_changed_dep,dtc) | ||
36 | |||
37 | +$(obj)/%.dtb: $(src)/dts/fsl/%.dts FORCE | ||
38 | + $(call if_changed_dep,dtc) | ||
39 | + | ||
40 | # If there isn't a platform selected then just strip the vmlinux. | ||
41 | ifeq (,$(image-y)) | ||
42 | image-y := vmlinux.strip | ||
43 | -- | ||
44 | cgit v0.12 | ||
45 | |||
diff --git a/recipes-kernel/linux/linux-qoriq_4.1.bb b/recipes-kernel/linux/linux-qoriq_4.1.bb index 198d1562..5a5693e9 100644 --- a/recipes-kernel/linux/linux-qoriq_4.1.bb +++ b/recipes-kernel/linux/linux-qoriq_4.1.bb | |||
@@ -12,6 +12,7 @@ SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;branch=sdk-v2.0.x \ | |||
12 | file://0003-use-static-inline-in-ARM-lifeboot.h.patch \ | 12 | file://0003-use-static-inline-in-ARM-lifeboot.h.patch \ |
13 | file://fix-the-compile-issue-under-gcc6.patch \ | 13 | file://fix-the-compile-issue-under-gcc6.patch \ |
14 | file://only-set-vmpic_msi_feature-if-CONFIG_EPAPR_PARAVIRT-.patch \ | 14 | file://only-set-vmpic_msi_feature-if-CONFIG_EPAPR_PARAVIRT-.patch \ |
15 | file://powerpc-fsl-Fix-build-of-the-dtb-embedded-kernel-images.patch \ | ||
15 | " | 16 | " |
16 | SRCREV = "bd51baffc04ecc73f933aee1c3a37c8b44b889a7" | 17 | SRCREV = "bd51baffc04ecc73f933aee1c3a37c8b44b889a7" |
17 | 18 | ||