diff options
author | Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | 2020-05-31 21:50:41 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-05-31 20:09:03 -0300 |
commit | fb5ad362adeba61877f7a697db0acc495abddf2b (patch) | |
tree | 3f2b46ce534676cbadf505d70e72f5e5d7ed17aa | |
parent | bc89daba19c0fa10d75da7fe29f8ef9333156b5c (diff) | |
download | meta-freescale-fb5ad362adeba61877f7a697db0acc495abddf2b.tar.gz |
optee-client: fix build architecture for aarch64
Overridden do_compile() task relies on an old DEFAULTTUNE set to
identify if the build should target arm32 or arm64 architecture, and has
a direct comparison to the generic tune. Since aarch64 tune for some
derivatives has been switched to a more specialized types (cortexa53-crypto),
this causes the check to fail and build defaults to arm32, which is not
desired behavior.
Define OPTEE_ARCH to a proper value based on machine overrides, drop the
task override and use standard Yocto mechanisms to provide additional
parameters to make.
Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
-rw-r--r-- | recipes-security/optee-imx/optee-client_3.2.0.imx.bb | 14 |
1 files changed, 5 insertions, 9 deletions
diff --git a/recipes-security/optee-imx/optee-client_3.2.0.imx.bb b/recipes-security/optee-imx/optee-client_3.2.0.imx.bb index 707e82fd..d3607ed4 100644 --- a/recipes-security/optee-imx/optee-client_3.2.0.imx.bb +++ b/recipes-security/optee-imx/optee-client_3.2.0.imx.bb | |||
@@ -13,20 +13,16 @@ SRC_URI = "${OPTEE_CLIENT_SRC};branch=${SRCBRANCH}" | |||
13 | 13 | ||
14 | SRCREV = "71a9bef78fff2d5d4db8a2307d3b91e2aa671dc9" | 14 | SRCREV = "71a9bef78fff2d5d4db8a2307d3b91e2aa671dc9" |
15 | 15 | ||
16 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
17 | |||
18 | SRC_URI_append = " file://tee-supplicant.service" | 16 | SRC_URI_append = " file://tee-supplicant.service" |
19 | 17 | ||
20 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
21 | SYSTEMD_SERVICE_${PN} = "tee-supplicant.service" | 19 | SYSTEMD_SERVICE_${PN} = "tee-supplicant.service" |
22 | 20 | ||
23 | do_compile () { | 21 | OPTEE_ARCH ?= "arm32" |
24 | if [ ${DEFAULTTUNE} = "aarch64" ]; then | 22 | OPTEE_ARCH_armv7a = "arm32" |
25 | oe_runmake -C ${S} ARCH=arm64 | 23 | OPTEE_ARCH_aarch64 = "arm64" |
26 | else | 24 | |
27 | oe_runmake -C ${S} ARCH=arm | 25 | EXTRA_OEMAKE = "ARCH=${OPTEE_ARCH}" |
28 | fi | ||
29 | } | ||
30 | 26 | ||
31 | do_install () { | 27 | do_install () { |
32 | oe_runmake install | 28 | oe_runmake install |