diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2021-08-13 13:34:42 -0300 |
---|---|---|
committer | GitHub <noreply@github.com> | 2021-08-13 13:34:42 -0300 |
commit | 7a928a20d1629fea8814a27442a1817c17296417 (patch) | |
tree | 7b18e1bf1401cb9ebd0ceb5f36767be935229d53 /dynamic-layers | |
parent | 72f59d35816cd2be6159013e4d96d03abf7f1c4b (diff) | |
parent | 229b84b66aa2eebd3947505a49f5711e5ea96466 (diff) | |
download | meta-freescale-7a928a20d1629fea8814a27442a1817c17296417.tar.gz |
Merge pull request #837 from YoeDistro/yoe/mut
Convert to new override syntax
Diffstat (limited to 'dynamic-layers')
14 files changed, 51 insertions, 51 deletions
diff --git a/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston-init.bbappend b/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston-init.bbappend index 10b66c0e..b7bf3298 100644 --- a/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston-init.bbappend +++ b/dynamic-layers/aglprofilegraphical/recipes-graphics/wayland/weston-init.bbappend | |||
@@ -1,3 +1,3 @@ | |||
1 | do_install_append() { | 1 | do_install:append() { |
2 | rm -f ${D}${sysconfdir}/xdg/weston/weston.ini | 2 | rm -f ${D}${sysconfdir}/xdg/weston/weston.ini |
3 | } | 3 | } |
diff --git a/dynamic-layers/chromium-browser-layer/recipes-browser/chromium/chromium-imx.inc b/dynamic-layers/chromium-browser-layer/recipes-browser/chromium/chromium-imx.inc index cdd0f08f..7d8065f9 100644 --- a/dynamic-layers/chromium-browser-layer/recipes-browser/chromium/chromium-imx.inc +++ b/dynamic-layers/chromium-browser-layer/recipes-browser/chromium/chromium-imx.inc | |||
@@ -1,4 +1,4 @@ | |||
1 | DEPENDS_append_imxvpu = " imx-vpuwrap" | 1 | DEPENDS:append:imxvpu = " imx-vpuwrap" |
2 | 2 | ||
3 | # Additional imx code and patches are included in the chromium-imx git repository. | 3 | # Additional imx code and patches are included in the chromium-imx git repository. |
4 | # The code below fetches this repository, copies the extra source over to the main | 4 | # The code below fetches this repository, copies the extra source over to the main |
@@ -26,7 +26,7 @@ do_patch[prefuncs] =+ "add_chromium_imx_patches" | |||
26 | # * Lost context problems are not known to happen with Vivante GPUs, | 26 | # * Lost context problems are not known to happen with Vivante GPUs, |
27 | # so it is safe to use ignore-lost-context | 27 | # so it is safe to use ignore-lost-context |
28 | # * Proprietary codecs need to be enabled for h.264 and MP4 support | 28 | # * Proprietary codecs need to be enabled for h.264 and MP4 support |
29 | PACKAGECONFIG_append = " ignore-lost-context proprietary-codecs" | 29 | PACKAGECONFIG:append = " ignore-lost-context proprietary-codecs" |
30 | 30 | ||
31 | copy_chromium_imx_files() { | 31 | copy_chromium_imx_files() { |
32 | # sources in src/ are already organized in a manner | 32 | # sources in src/ are already organized in a manner |
diff --git a/dynamic-layers/filesystem-layer/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bbappend b/dynamic-layers/filesystem-layer/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bbappend index 1080a9f5..563c9e76 100644 --- a/dynamic-layers/filesystem-layer/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bbappend +++ b/dynamic-layers/filesystem-layer/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bbappend | |||
@@ -4,7 +4,7 @@ PACKAGES += " \ | |||
4 | ${PN}-f2fs \ | 4 | ${PN}-f2fs \ |
5 | " | 5 | " |
6 | 6 | ||
7 | RDEPENDS_${PN}-f2fs = " \ | 7 | RDEPENDS:${PN}-f2fs = " \ |
8 | ${PN}-base \ | 8 | ${PN}-base \ |
9 | f2fs-tools \ | 9 | f2fs-tools \ |
10 | " | 10 | " |
diff --git a/dynamic-layers/gnome-layer/recipes-graphics/clutter/clutter-1.0_%.bbappend b/dynamic-layers/gnome-layer/recipes-graphics/clutter/clutter-1.0_%.bbappend index 0b4c4861..fb90c73e 100644 --- a/dynamic-layers/gnome-layer/recipes-graphics/clutter/clutter-1.0_%.bbappend +++ b/dynamic-layers/gnome-layer/recipes-graphics/clutter/clutter-1.0_%.bbappend | |||
@@ -1,4 +1,4 @@ | |||
1 | PACKAGECONFIG_imxgpu3d ??= " \ | 1 | PACKAGECONFIG:imxgpu3d ??= " \ |
2 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', \ | 2 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', \ |
3 | bb.utils.contains('DISTRO_FEATURES', 'x11', 'glx x11', \ | 3 | bb.utils.contains('DISTRO_FEATURES', 'x11', 'glx x11', \ |
4 | '', d), d)} \ | 4 | '', d), d)} \ |
diff --git a/dynamic-layers/gnome-layer/recipes-graphics/cogl/cogl-1.0_%.bbappend b/dynamic-layers/gnome-layer/recipes-graphics/cogl/cogl-1.0_%.bbappend index afbaee43..e07d0d54 100644 --- a/dynamic-layers/gnome-layer/recipes-graphics/cogl/cogl-1.0_%.bbappend +++ b/dynamic-layers/gnome-layer/recipes-graphics/cogl/cogl-1.0_%.bbappend | |||
@@ -1,4 +1,4 @@ | |||
1 | PACKAGECONFIG_imxgpu3d ??= " \ | 1 | PACKAGECONFIG:imxgpu3d ??= " \ |
2 | cogl-pango gles2 \ | 2 | cogl-pango gles2 \ |
3 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'egl-wayland', \ | 3 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'egl-wayland', \ |
4 | bb.utils.contains('DISTRO_FEATURES', 'x11', 'egl-x11', \ | 4 | bb.utils.contains('DISTRO_FEATURES', 'x11', 'egl-x11', \ |
diff --git a/dynamic-layers/ivi/recipes-graphics/wayland/weston-init.bbappend b/dynamic-layers/ivi/recipes-graphics/wayland/weston-init.bbappend index 72d991c7..4fc41d05 100644 --- a/dynamic-layers/ivi/recipes-graphics/wayland/weston-init.bbappend +++ b/dynamic-layers/ivi/recipes-graphics/wayland/weston-init.bbappend | |||
@@ -1 +1 @@ | |||
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" | ||
diff --git a/dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend b/dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend index 2e648ba3..998d11f7 100644 --- a/dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend +++ b/dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend | |||
@@ -1,4 +1,4 @@ | |||
1 | # Only _mx8 machine do provide virtual/libgbm required for any drm* flavour | 1 | # Only _mx8 machine do provide virtual/libgbm required for any drm* flavour |
2 | DRM-REMOVE_imxgpu = "drm-gl drm-gles2" | 2 | DRM-REMOVE:imxgpu = "drm-gl drm-gles2" |
3 | DRM-REMOVE_imxgpu_mx8 = "" | 3 | DRM-REMOVE:imxgpu:mx8 = "" |
4 | PACKAGECONFIG_remove = "${DRM-REMOVE}" | 4 | PACKAGECONFIG:remove = "${DRM-REMOVE}" |
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit_%.bbappend b/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit_%.bbappend index 8c6138c5..d07f8ae1 100644 --- a/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit_%.bbappend +++ b/dynamic-layers/openembedded-layer/recipes-devtools/luajit/luajit_%.bbappend | |||
@@ -1,4 +1,4 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:" | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:" |
2 | 2 | ||
3 | SRC_URI_append_qoriq-ppc = " file://ppc-fixplt.patch " | 3 | SRC_URI:append:qoriq-ppc = " file://ppc-fixplt.patch " |
4 | 4 | ||
diff --git a/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb b/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb index 1793ec06..9c6be782 100644 --- a/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb +++ b/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb | |||
@@ -19,15 +19,15 @@ EXTRA_OEMAKE_virtclass-native = 'FMCHOSTMODE=1 FMD_USPACE_HEADER_PATH="${STAGING | |||
19 | TCLAP_HEADER_PATH="${STAGING_INCDIR}" ' | 19 | TCLAP_HEADER_PATH="${STAGING_INCDIR}" ' |
20 | 20 | ||
21 | EXTRA_OEMAKE_PLATFORM ?= "" | 21 | EXTRA_OEMAKE_PLATFORM ?= "" |
22 | EXTRA_OEMAKE_PLATFORM_ls1043a = "ls1043" | 22 | EXTRA_OEMAKE_PLATFORM:ls1043a = "ls1043" |
23 | EXTRA_OEMAKE_PLATFORM_ls1046a = "ls1046" | 23 | EXTRA_OEMAKE_PLATFORM:ls1046a = "ls1046" |
24 | EXTRA_OEMAKE_PLATFORM_ls1088a = "ls1088" | 24 | EXTRA_OEMAKE_PLATFORM:ls1088a = "ls1088" |
25 | EXTRA_OEMAKE_PLATFORM_p1020 = "p4080ds" | 25 | EXTRA_OEMAKE_PLATFORM:p1020 = "p4080ds" |
26 | EXTRA_OEMAKE_PLATFORM_p2020 = "p4080ds" | 26 | EXTRA_OEMAKE_PLATFORM:p2020 = "p4080ds" |
27 | EXTRA_OEMAKE_PLATFORM_p2041 = "p4080ds" | 27 | EXTRA_OEMAKE_PLATFORM:p2041 = "p4080ds" |
28 | EXTRA_OEMAKE_PLATFORM_p3041 = "p4080ds" | 28 | EXTRA_OEMAKE_PLATFORM:p3041 = "p4080ds" |
29 | EXTRA_OEMAKE_PLATFORM_p4080 = "p4080ds" | 29 | EXTRA_OEMAKE_PLATFORM:p4080 = "p4080ds" |
30 | EXTRA_OEMAKE_PLATFORM_p5040 = "p4080ds" | 30 | EXTRA_OEMAKE_PLATFORM:p5040 = "p4080ds" |
31 | 31 | ||
32 | 32 | ||
33 | do_compile () { | 33 | do_compile () { |
diff --git a/dynamic-layers/openembedded-layer/recipes-graphics/xserver-common/xserver-common_%.bbappend b/dynamic-layers/openembedded-layer/recipes-graphics/xserver-common/xserver-common_%.bbappend index f4f43504..be694574 100644 --- a/dynamic-layers/openembedded-layer/recipes-graphics/xserver-common/xserver-common_%.bbappend +++ b/dynamic-layers/openembedded-layer/recipes-graphics/xserver-common/xserver-common_%.bbappend | |||
@@ -1,8 +1,8 @@ | |||
1 | # i.MX extra configuration | 1 | # i.MX extra configuration |
2 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 2 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
3 | 3 | ||
4 | SRC_URI_append_imxgpu3d = " \ | 4 | SRC_URI:append:imxgpu3d = " \ |
5 | file://0016-xserver-common-enable-iglx-module.patch \ | 5 | file://0016-xserver-common-enable-iglx-module.patch \ |
6 | " | 6 | " |
7 | 7 | ||
8 | PACKAGE_ARCH_imxgpu3d = "${MACHINE_SOCARCH}" | 8 | PACKAGE_ARCH:imxgpu3d = "${MACHINE_SOCARCH}" |
diff --git a/dynamic-layers/qt4-layer/recipes-qt4/qt4/qt4-imx-support.inc b/dynamic-layers/qt4-layer/recipes-qt4/qt4/qt4-imx-support.inc index 187681a8..8950c151 100644 --- a/dynamic-layers/qt4-layer/recipes-qt4/qt4/qt4-imx-support.inc +++ b/dynamic-layers/qt4-layer/recipes-qt4/qt4/qt4-imx-support.inc | |||
@@ -1,4 +1,4 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/qt4:" | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/qt4:" |
2 | 2 | ||
3 | python __anonymous () { | 3 | python __anonymous () { |
4 | families = ['mx6'] | 4 | families = ['mx6'] |
@@ -8,21 +8,21 @@ python __anonymous () { | |||
8 | d.appendVarFlag('do_configure', 'depends', ' virtual/kernel:do_shared_workdir') | 8 | d.appendVarFlag('do_configure', 'depends', ' virtual/kernel:do_shared_workdir') |
9 | } | 9 | } |
10 | 10 | ||
11 | SRC_URI_append_imxgpu2d += " \ | 11 | SRC_URI:append:imxgpu2d += " \ |
12 | file://0001-Add-support-for-i.MX-codecs-to-phonon.patch \ | 12 | file://0001-Add-support-for-i.MX-codecs-to-phonon.patch \ |
13 | file://0002-i.MX-video-renderer-Allow-v4l-device-from-environmen.patch \ | 13 | file://0002-i.MX-video-renderer-Allow-v4l-device-from-environmen.patch \ |
14 | file://0003-i.MX6-force-egl-visual-ID-33.patch \ | 14 | file://0003-i.MX6-force-egl-visual-ID-33.patch \ |
15 | " | 15 | " |
16 | 16 | ||
17 | DEPENDS_append_imxgpu2d = " virtual/kernel virtual/libgles2" | 17 | DEPENDS:append:imxgpu2d = " virtual/kernel virtual/libgles2" |
18 | QT_GLFLAGS_imxgpu2d = "-opengl es2 -openvg" | 18 | QT_GLFLAGS:imxgpu2d = "-opengl es2 -openvg" |
19 | QT_CONFIG_FLAGS_append_imxgpu2d = " -I${STAGING_KERNEL_DIR}/include/uapi \ | 19 | QT_CONFIG_FLAGS:append:imxgpu2d = " -I${STAGING_KERNEL_DIR}/include/uapi \ |
20 | -I${STAGING_KERNEL_DIR}/include/ \ | 20 | -I${STAGING_KERNEL_DIR}/include/ \ |
21 | -DLINUX=1 -DEGL_API_FB=1 \ | 21 | -DLINUX=1 -DEGL_API_FB=1 \ |
22 | -DQT_QPA_EXPERIMENTAL_TOUCHEVENT=1" | 22 | -DQT_QPA_EXPERIMENTAL_TOUCHEVENT=1" |
23 | 23 | ||
24 | # The QT_CONFIG_FLAGS can pollute *.la files with -Dxxx | 24 | # The QT_CONFIG_FLAGS can pollute *.la files with -Dxxx |
25 | do_compile_append_mx6 () { | 25 | do_compile:append:mx6 () { |
26 | find lib -name "*.la" | xargs -n1 sed -i 's/-D.*=1//g' | 26 | find lib -name "*.la" | xargs -n1 sed -i 's/-D.*=1//g' |
27 | } | 27 | } |
28 | 28 | ||
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend index bf3fb66e..0d5897ad 100644 --- a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend +++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend | |||
@@ -3,35 +3,35 @@ | |||
3 | # Copyright (C) 2016, 2017 O.S. Systems Software LTDA. | 3 | # Copyright (C) 2016, 2017 O.S. Systems Software LTDA. |
4 | # Copyright (C) 2017-2018 NXP | 4 | # Copyright (C) 2017-2018 NXP |
5 | 5 | ||
6 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 6 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
7 | 7 | ||
8 | SRC_URI_append_imxgpu = " \ | 8 | SRC_URI:append:imxgpu = " \ |
9 | file://0014-Add-IMX-GPU-support.patch \ | 9 | file://0014-Add-IMX-GPU-support.patch \ |
10 | file://0001-egl.prf-Fix-build-error-when-egl-headers-need-platfo.patch \ | 10 | file://0001-egl.prf-Fix-build-error-when-egl-headers-need-platfo.patch \ |
11 | " | 11 | " |
12 | 12 | ||
13 | PACKAGECONFIG_GL_IMX_GPU = "" | 13 | PACKAGECONFIG_GL_IMX_GPU = "" |
14 | PACKAGECONFIG_GL_IMX_GPU_mx8 = "gbm kms" | 14 | PACKAGECONFIG_GL_IMX_GPU:mx8 = "gbm kms" |
15 | 15 | ||
16 | PACKAGECONFIG_GL_imxpxp = "gles2" | 16 | PACKAGECONFIG_GL:imxpxp = "gles2" |
17 | PACKAGECONFIG_GL_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)} \ | 17 | PACKAGECONFIG_GL:imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)} \ |
18 | ${PACKAGECONFIG_GL_IMX_GPU}" | 18 | ${PACKAGECONFIG_GL_IMX_GPU}" |
19 | PACKAGECONFIG_GL_imxgpu3d = "gles2 \ | 19 | PACKAGECONFIG_GL:imxgpu3d = "gles2 \ |
20 | ${PACKAGECONFIG_GL_IMX_GPU}" | 20 | ${PACKAGECONFIG_GL_IMX_GPU}" |
21 | PACKAGECONFIG_GL_use-mainline-bsp ?= "gles2 gbm kms" | 21 | PACKAGECONFIG_GL:use-mainline-bsp ?= "gles2 gbm kms" |
22 | 22 | ||
23 | PACKAGECONFIG_PLATFORM = "" | 23 | PACKAGECONFIG_PLATFORM = "" |
24 | PACKAGECONFIG_PLATFORM_imxgpu2d = "no-opengl linuxfb" | 24 | PACKAGECONFIG_PLATFORM:imxgpu2d = "no-opengl linuxfb" |
25 | PACKAGECONFIG_PLATFORM_imxgpu3d = " \ | 25 | PACKAGECONFIG_PLATFORM:imxgpu3d = " \ |
26 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ | 26 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ |
27 | bb.utils.contains('DISTRO_FEATURES', 'wayland', '', \ | 27 | bb.utils.contains('DISTRO_FEATURES', 'wayland', '', \ |
28 | 'eglfs', d), d)}" | 28 | 'eglfs', d), d)}" |
29 | PACKAGECONFIG_PLATFORM_use-mainline-bsp = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'eglfs', d)}" | 29 | PACKAGECONFIG_PLATFORM:use-mainline-bsp = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'eglfs', d)}" |
30 | PACKAGECONFIG += "${PACKAGECONFIG_PLATFORM}" | 30 | PACKAGECONFIG += "${PACKAGECONFIG_PLATFORM}" |
31 | 31 | ||
32 | PACKAGECONFIG_VULKAN_IMX_GPU = "" | 32 | PACKAGECONFIG_VULKAN_IMX_GPU = "" |
33 | PACKAGECONFIG_VULKAN_IMX_GPU_mx8 = "vulkan" | 33 | PACKAGECONFIG_VULKAN_IMX_GPU:mx8 = "vulkan" |
34 | PACKAGECONFIG_VULKAN_IMX_GPU_mx8mm = "" | 34 | PACKAGECONFIG_VULKAN_IMX_GPU:mx8mm = "" |
35 | PACKAGECONFIG_VULKAN = "" | 35 | PACKAGECONFIG_VULKAN = "" |
36 | PACKAGECONFIG_VULKAN_imxgpu = "${PACKAGECONFIG_VULKAN_IMX_GPU}" | 36 | PACKAGECONFIG_VULKAN:imxgpu = "${PACKAGECONFIG_VULKAN_IMX_GPU}" |
37 | PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'vulkan', '${PACKAGECONFIG_VULKAN}', '', d)}" | 37 | PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'vulkan', '${PACKAGECONFIG_VULKAN}', '', d)}" |
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend index 168db095..c1594e05 100644 --- a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend +++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend | |||
@@ -1,8 +1,8 @@ | |||
1 | # etnaviv mesa does not have glx | 1 | # etnaviv mesa does not have glx |
2 | PACKAGECONFIG_remove_use-mainline-bsp = "xcomposite-glx" | 2 | PACKAGECONFIG:remove:use-mainline-bsp = "xcomposite-glx" |
3 | 3 | ||
4 | PACKAGECONFIG_remove_mx6 = "xcomposite-egl xcomposite-glx" | 4 | PACKAGECONFIG:remove:mx6 = "xcomposite-egl xcomposite-glx" |
5 | PACKAGECONFIG_remove_mx7 = "xcomposite-egl xcomposite-glx" | 5 | PACKAGECONFIG:remove:mx7 = "xcomposite-egl xcomposite-glx" |
6 | 6 | ||
7 | # i.MX8 does never provide native x11, so required dependencies are not met | 7 | # i.MX8 does never provide native x11, so required dependencies are not met |
8 | PACKAGECONFIG_remove_mx8 = "xcomposite-egl xcomposite-glx" | 8 | PACKAGECONFIG:remove:mx8 = "xcomposite-egl xcomposite-glx" |
diff --git a/dynamic-layers/virtualization-layer/recipes-extended/libvirt/libvirt_%.bbappend b/dynamic-layers/virtualization-layer/recipes-extended/libvirt/libvirt_%.bbappend index c7e6d32e..f64637bd 100644 --- a/dynamic-layers/virtualization-layer/recipes-extended/libvirt/libvirt_%.bbappend +++ b/dynamic-layers/virtualization-layer/recipes-extended/libvirt/libvirt_%.bbappend | |||
@@ -1,9 +1,9 @@ | |||
1 | PACKAGECONFIG_qoriq-ppc = "qemu yajl lxc test remote macvtap libvirtd netcf udev python" | 1 | PACKAGECONFIG:qoriq-ppc = "qemu yajl lxc test remote macvtap libvirtd netcf udev python" |
2 | 2 | ||
3 | FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:" | 3 | FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:" |
4 | SRC_URI_append_qoriq-ppc = " file://qemu.conf" | 4 | SRC_URI:append:qoriq-ppc = " file://qemu.conf" |
5 | 5 | ||
6 | do_install_append_qoriq-ppc() { | 6 | do_install:append:qoriq-ppc() { |
7 | install -m 0644 ${WORKDIR}/qemu.conf ${D}${sysconfdir}/libvirt/qemu.conf | 7 | install -m 0644 ${WORKDIR}/qemu.conf ${D}${sysconfdir}/libvirt/qemu.conf |
8 | } | 8 | } |
9 | 9 | ||