diff options
author | Zhenhua Luo <zhenhua.luo@freescale.com> | 2015-08-17 18:12:52 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-04-19 15:03:15 -0300 |
commit | d869d9080dfd9a44fd84b3a57acee08666ab45b8 (patch) | |
tree | d67416d63b2f5dd6635538a2a983cab780f3b200 /recipes-devtools/qemu/qemu-fsl_git.bb | |
parent | 16a50412b0adcbd51fce55006fe15155181be06b (diff) | |
download | meta-freescale-d869d9080dfd9a44fd84b3a57acee08666ab45b8.tar.gz |
qemu: unify the recipe for QorIQ ARM and QorIQ PPC
* rename recipe to qemu-qoriq_git.bb to be product specific
* add DESCRIPTION
* conditionally define QEMU_TARGETS and EXTRA_OECONF
* skip dev-deps check to fix build error
* add COMPATIBLE_MACHINE
Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
Diffstat (limited to 'recipes-devtools/qemu/qemu-fsl_git.bb')
-rw-r--r-- | recipes-devtools/qemu/qemu-fsl_git.bb | 49 |
1 files changed, 0 insertions, 49 deletions
diff --git a/recipes-devtools/qemu/qemu-fsl_git.bb b/recipes-devtools/qemu/qemu-fsl_git.bb deleted file mode 100644 index 94fb9b19..00000000 --- a/recipes-devtools/qemu/qemu-fsl_git.bb +++ /dev/null | |||
@@ -1,49 +0,0 @@ | |||
1 | require recipes-devtools/qemu/qemu.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \ | ||
4 | file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913" | ||
5 | |||
6 | # This means QEMU v2.2.0 with FSL specific patches applied | ||
7 | PV = "2.2.0+${SRCPV}" | ||
8 | |||
9 | # NOTE: this recipe requires poky's qemu.inc which assumes version 2.3 | ||
10 | # where glx enable config option changed to --enable-opengl. For now we | ||
11 | # restore it, but we should remove the following lines when upgrading | ||
12 | # to qemu 2.3: | ||
13 | PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,mesa" | ||
14 | |||
15 | SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;branch=master" | ||
16 | SRCREV = "00ac004143e9fe46944a1885b04268fcd3a95a3a" | ||
17 | |||
18 | S = "${WORKDIR}/git" | ||
19 | |||
20 | QEMU_TARGETS = "arm" | ||
21 | |||
22 | inherit pkgconfig | ||
23 | |||
24 | # Append build host pkg-config paths for native target since the host may provide sdl | ||
25 | do_configure_prepend() { | ||
26 | export PKG_CONFIG=${STAGING_DIR_NATIVE}${bindir_native}/pkg-config | ||
27 | } | ||
28 | |||
29 | do_configure_append () { | ||
30 | if ! grep 'CONFIG_FDT=y' config-host.mak; then | ||
31 | echo "CONFIG_RDMA=y" >> config_host_mak | ||
32 | fi | ||
33 | } | ||
34 | |||
35 | # gets around qemu.inc trying to install powerpc_rom.bin | ||
36 | do_install_prepend() { | ||
37 | touch ${WORKDIR}/powerpc_rom.bin | ||
38 | } | ||
39 | |||
40 | do_install_append() { | ||
41 | rm ${WORKDIR}/powerpc_rom.bin | ||
42 | # Prevent QA warnings about installed ${localstatedir}/run | ||
43 | if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi | ||
44 | } | ||
45 | |||
46 | FILES_${PN} += "/usr/share/qemu/" | ||
47 | |||
48 | # FIXME: Avoid WARNING due missing patch for native/nativesdk | ||
49 | BBCLASSEXTEND = "" | ||