diff options
author | Yuqing Zhu <carol.zhu@nxp.com> | 2018-08-06 17:23:33 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-09-07 17:30:35 -0300 |
commit | 5439a57ad5abb6c2b7b12db414b739cec74c2662 (patch) | |
tree | 384e3daa924917e6bbef6df0aeeabaa2dfd63b83 /recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad-1.14.imx/configure-allow-to-disable-libssh2.patch | |
parent | 68a53a2de31bc3ecfb36d9a7fc9b935548114f0f (diff) | |
download | meta-freescale-5439a57ad5abb6c2b7b12db414b739cec74c2662.tar.gz |
gstreamer1.0-plugins-bad: Upgrade to v1.14.imx
Add GST_EXPORT APIs for GST1.14
kmssink:
Add HDR10 support
Add hdr metadata reset when exit playback
Add fps print when exit
Add alignment for video src crop size for dpu
waylandsink:
Add fps print
Support video crop meta using viewporter protocol
Pass dmabuf modifier to weston
Hard code scale ratio for i.mx8qxp instead of using
setplane to try scale ratio as its upscale has no limitation
Update patch to fix applying conflict
Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad-1.14.imx/configure-allow-to-disable-libssh2.patch')
-rw-r--r-- | recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad-1.14.imx/configure-allow-to-disable-libssh2.patch | 61 |
1 files changed, 61 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad-1.14.imx/configure-allow-to-disable-libssh2.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad-1.14.imx/configure-allow-to-disable-libssh2.patch new file mode 100644 index 00000000..ad863298 --- /dev/null +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad-1.14.imx/configure-allow-to-disable-libssh2.patch | |||
@@ -0,0 +1,61 @@ | |||
1 | From f59c5269f92d59a5296cbfeeb682d42095cd88ad Mon Sep 17 00:00:00 2001 | ||
2 | From: Wenzong Fan <wenzong.fan@windriver.com> | ||
3 | Date: Thu, 18 Sep 2014 02:24:07 -0400 | ||
4 | Subject: [PATCH] gstreamer1.0-plugins-bad: allow to disable libssh2 | ||
5 | |||
6 | libssh2 is automatically linked to if present, this undetermined | ||
7 | dependency may cause build errors like: | ||
8 | |||
9 | .../x86_64-poky-linux/4.9.0/ld: cannot find -lssh2 | ||
10 | |||
11 | libssh2 isn't an oe-core recipe, so allow to disable it from | ||
12 | configure. | ||
13 | |||
14 | Upstream-Status: Pending | ||
15 | |||
16 | Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> | ||
17 | --- | ||
18 | configure.ac | 23 +++++++++++++++++------ | ||
19 | 1 file changed, 17 insertions(+), 6 deletions(-) | ||
20 | |||
21 | Index: gst-plugins-bad-1.12.3/configure.ac | ||
22 | =================================================================== | ||
23 | --- gst-plugins-bad-1.12.3.orig/configure.ac | ||
24 | +++ gst-plugins-bad-1.12.3/configure.ac | ||
25 | @@ -2139,6 +2139,15 @@ AG_GST_CHECK_FEATURE(CHROMAPRINT, [chrom | ||
26 | ]) | ||
27 | |||
28 | dnl *** Curl *** | ||
29 | +AC_ARG_ENABLE([libssh2], | ||
30 | + [ --enable-libssh2 enable LIBSSH2 support @<:@default=auto@:>@], | ||
31 | + [case "${enableval}" in | ||
32 | + yes) NEED_SSH2=yes ;; | ||
33 | + no) NEED_SSH2=no ;; | ||
34 | + auto) NEED_SSH2=auto ;; | ||
35 | + *) AC_MSG_ERROR([bad value ${enableval} for --enable-libssh2]) ;; | ||
36 | + esac],[NEED_SSH2=auto]) | ||
37 | + | ||
38 | translit(dnm, m, l) AM_CONDITIONAL(USE_CURL, true) | ||
39 | AG_GST_CHECK_FEATURE(CURL, [Curl plugin], curl, [ | ||
40 | PKG_CHECK_MODULES(CURL, libcurl >= 7.35.0, [ | ||
41 | @@ -2161,12 +2170,14 @@ AG_GST_CHECK_FEATURE(CURL, [Curl plugin] | ||
42 | ]) | ||
43 | AC_SUBST(CURL_CFLAGS) | ||
44 | AC_SUBST(CURL_LIBS) | ||
45 | - PKG_CHECK_MODULES(SSH2, libssh2 >= 1.4.3, [ | ||
46 | - HAVE_SSH2="yes" | ||
47 | - AC_DEFINE(HAVE_SSH2, 1, [Define if libssh2 is available]) | ||
48 | - ], [ | ||
49 | - HAVE_SSH2="no" | ||
50 | - ]) | ||
51 | + if test "x$NEED_SSH2" != "xno"; then | ||
52 | + PKG_CHECK_MODULES(SSH2, libssh2 >= 1.4.3, [ | ||
53 | + HAVE_SSH2="yes" | ||
54 | + AC_DEFINE(HAVE_SSH2, 1, [Define if libssh2 is available]) | ||
55 | + ], [ | ||
56 | + HAVE_SSH2="no" | ||
57 | + ]) | ||
58 | + fi | ||
59 | AM_CONDITIONAL(USE_SSH2, test "x$HAVE_SSH2" = "xyes") | ||
60 | AC_SUBST(SSH2_CFLAGS) | ||
61 | AC_SUBST(SSH2_LIBS) | ||