diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-08-31 13:28:24 -0500 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2022-09-01 15:52:32 -0500 |
commit | 178bcddd87bbb379d0d2abc3349d3c1417c54d49 (patch) | |
tree | 9b924ffaa0d67ea69748b20b18af11392bb74210 /recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch | |
parent | 19cc0331a2c855381436182d94913e7a0ddb0047 (diff) | |
download | meta-freescale-178bcddd87bbb379d0d2abc3349d3c1417c54d49.tar.gz |
gstreamer1.0*: Upgrade 1.18.5.imx -> 1.20.0.imx
Includes:
- gstreamer1.0
- gstreamer1.0-plugins-base
- gstreamer1.0-plugins-good
- gstreamer1.0-plugins-bad
Drops downgraded recipe copies for 1.18.5:
- gstreamer1.0-libav
- gstreamer1.0-plugins-ugly
- gstreamer1.0-rtsp-server
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch')
-rw-r--r-- | recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch | 42 |
1 files changed, 13 insertions, 29 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch index b8167090..029b80e1 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From f19ff66640f2f472c4e9d9055253032d34e125c6 Mon Sep 17 00:00:00 2001 | 1 | From 3bc5d48257032b6bbee532aad15062fbbcc43bfe Mon Sep 17 00:00:00 2001 |
2 | From: Andrey Zhizhikin <andrey.z@gmail.com> | 2 | From: Andrey Zhizhikin <andrey.z@gmail.com> |
3 | Date: Mon, 27 Jan 2020 10:22:35 +0000 | 3 | Date: Mon, 27 Jan 2020 10:22:35 +0000 |
4 | Subject: [PATCH 4/4] opencv: resolve missing opencv data dir in yocto build | 4 | Subject: [PATCH] opencv: resolve missing opencv data dir in yocto build |
5 | 5 | ||
6 | When Yocto build is performed, opencv searches for data dir using simple | 6 | When Yocto build is performed, opencv searches for data dir using simple |
7 | 'test' command, this fails because pkg-config provides an absolute | 7 | 'test' command, this fails because pkg-config provides an absolute |
@@ -11,39 +11,23 @@ in order for the 'test' utility to pick up the absolute path. | |||
11 | Upstream-Status: Inappropriate [OE-specific] | 11 | Upstream-Status: Inappropriate [OE-specific] |
12 | 12 | ||
13 | Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> | 13 | Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> |
14 | Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com> | ||
15 | |||
14 | --- | 16 | --- |
15 | ext/opencv/meson.build | 7 ++++--- | 17 | ext/opencv/meson.build | 3 +++ |
16 | 1 file changed, 4 insertions(+), 3 deletions(-) | 18 | 1 file changed, 3 insertions(+) |
17 | 19 | ||
18 | diff --git a/ext/opencv/meson.build b/ext/opencv/meson.build | 20 | diff --git a/ext/opencv/meson.build b/ext/opencv/meson.build |
19 | index 0b0b3fc..0ed3344 100644 | 21 | index 1d86b90..b5c8b95 100644 |
20 | --- a/ext/opencv/meson.build | 22 | --- a/ext/opencv/meson.build |
21 | +++ b/ext/opencv/meson.build | 23 | +++ b/ext/opencv/meson.build |
22 | @@ -78,20 +78,21 @@ else | 24 | @@ -87,6 +87,9 @@ if opencv_found |
23 | endif | 25 | opencv_prefix = opencv_dep.get_variable('prefix') |
24 | |||
25 | if opencv_found | ||
26 | + pkgconf_sysroot = run_command(python3, '-c', 'import os; print(os.environ.get("PKG_CONFIG_SYSROOT_DIR"))').stdout().strip() | ||
27 | opencv_prefix = opencv_dep.get_pkgconfig_variable('prefix') | ||
28 | gstopencv_cargs += ['-DOPENCV_PREFIX="' + opencv_prefix + '"'] | 26 | gstopencv_cargs += ['-DOPENCV_PREFIX="' + opencv_prefix + '"'] |
29 | 27 | ||
28 | + pkgconf_sysroot = run_command(python3, '-c', 'import os; print(os.environ.get("PKG_CONFIG_SYSROOT_DIR"))').stdout().strip() | ||
29 | + opencv_prefix = pkgconf_sysroot + opencv_prefix | ||
30 | + | ||
30 | # Check the data dir used by opencv for its xml data files | 31 | # Check the data dir used by opencv for its xml data files |
31 | # Use prefix from pkg-config to be compatible with cross-compilation | 32 | # Use prefix from pkg-config to be compatible with cross-compilation |
32 | - r = run_command('test', '-d', opencv_prefix + '/share/opencv') | 33 | r = run_command('test', '-d', opencv_prefix + '/share/opencv', check: false) |
33 | + r = run_command('test', '-d', pkgconf_sysroot + opencv_prefix + '/share/opencv') | ||
34 | if r.returncode() == 0 | ||
35 | gstopencv_cargs += '-DOPENCV_PATH_NAME="opencv"' | ||
36 | else | ||
37 | - r = run_command('test', '-d', opencv_prefix + '/share/OpenCV') | ||
38 | + r = run_command('test', '-d', pkgconf_sysroot + opencv_prefix + '/share/OpenCV') | ||
39 | if r.returncode() == 0 | ||
40 | gstopencv_cargs += '-DOPENCV_PATH_NAME="OpenCV"' | ||
41 | else | ||
42 | - r = run_command('test', '-d', opencv_prefix + '/share/opencv4') | ||
43 | + r = run_command('test', '-d', pkgconf_sysroot + opencv_prefix + '/share/opencv4') | ||
44 | if r.returncode() == 0 | ||
45 | gstopencv_cargs += '-DOPENCV_PATH_NAME="opencv4"' | ||
46 | else | ||
47 | -- | ||
48 | 2.28.0 | ||
49 | |||