diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-03-30 15:03:02 -0500 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2022-04-04 16:57:41 -0500 |
commit | b43b7a038e314256170992fba02f77611d949f36 (patch) | |
tree | 2284c23ced87c1a9a1cf93ef3aae00967eb7afcd /recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch | |
parent | 01ad835b7d50a10c3e3cbfd9509fd32f8dbc293a (diff) | |
download | meta-freescale-b43b7a038e314256170992fba02f77611d949f36.tar.gz |
gstreamer1.0-plugins-bad: Upgrade 1.18.0.imx -> 1.18.5.imx
Also separate the base recipe copy from the overrides for ease of
maintenance.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch')
-rw-r--r-- | recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch | 49 |
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch new file mode 100644 index 00000000..b8167090 --- /dev/null +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch | |||
@@ -0,0 +1,49 @@ | |||
1 | From f19ff66640f2f472c4e9d9055253032d34e125c6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrey Zhizhikin <andrey.z@gmail.com> | ||
3 | Date: Mon, 27 Jan 2020 10:22:35 +0000 | ||
4 | Subject: [PATCH 4/4] opencv: resolve missing opencv data dir in yocto build | ||
5 | |||
6 | When Yocto build is performed, opencv searches for data dir using simple | ||
7 | 'test' command, this fails because pkg-config provides an absolute | ||
8 | path on the target which needs to be prepended by PKG_CONFIG_SYSROOT_DIR | ||
9 | in order for the 'test' utility to pick up the absolute path. | ||
10 | |||
11 | Upstream-Status: Inappropriate [OE-specific] | ||
12 | |||
13 | Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> | ||
14 | --- | ||
15 | ext/opencv/meson.build | 7 ++++--- | ||
16 | 1 file changed, 4 insertions(+), 3 deletions(-) | ||
17 | |||
18 | diff --git a/ext/opencv/meson.build b/ext/opencv/meson.build | ||
19 | index 0b0b3fc..0ed3344 100644 | ||
20 | --- a/ext/opencv/meson.build | ||
21 | +++ b/ext/opencv/meson.build | ||
22 | @@ -78,20 +78,21 @@ else | ||
23 | endif | ||
24 | |||
25 | if opencv_found | ||
26 | + pkgconf_sysroot = run_command(python3, '-c', 'import os; print(os.environ.get("PKG_CONFIG_SYSROOT_DIR"))').stdout().strip() | ||
27 | opencv_prefix = opencv_dep.get_pkgconfig_variable('prefix') | ||
28 | gstopencv_cargs += ['-DOPENCV_PREFIX="' + opencv_prefix + '"'] | ||
29 | |||
30 | # Check the data dir used by opencv for its xml data files | ||
31 | # Use prefix from pkg-config to be compatible with cross-compilation | ||
32 | - r = run_command('test', '-d', opencv_prefix + '/share/opencv') | ||
33 | + r = run_command('test', '-d', pkgconf_sysroot + opencv_prefix + '/share/opencv') | ||
34 | if r.returncode() == 0 | ||
35 | gstopencv_cargs += '-DOPENCV_PATH_NAME="opencv"' | ||
36 | else | ||
37 | - r = run_command('test', '-d', opencv_prefix + '/share/OpenCV') | ||
38 | + r = run_command('test', '-d', pkgconf_sysroot + opencv_prefix + '/share/OpenCV') | ||
39 | if r.returncode() == 0 | ||
40 | gstopencv_cargs += '-DOPENCV_PATH_NAME="OpenCV"' | ||
41 | else | ||
42 | - r = run_command('test', '-d', opencv_prefix + '/share/opencv4') | ||
43 | + r = run_command('test', '-d', pkgconf_sysroot + opencv_prefix + '/share/opencv4') | ||
44 | if r.returncode() == 0 | ||
45 | gstopencv_cargs += '-DOPENCV_PATH_NAME="opencv4"' | ||
46 | else | ||
47 | -- | ||
48 | 2.28.0 | ||
49 | |||