diff options
author | Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | 2020-05-31 22:02:35 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-05-31 20:09:03 -0300 |
commit | e6e0b794bad8a092614fa7f37a9e4345aaaabee0 (patch) | |
tree | 25468cefdbb0f5302882176cd41753d4dc7852e6 /recipes-security/optee-imx/optee-client/0001-flags-do-not-override-CFLAGS-from-host.patch | |
parent | fb5ad362adeba61877f7a697db0acc495abddf2b (diff) | |
download | meta-freescale-e6e0b794bad8a092614fa7f37a9e4345aaaabee0.tar.gz |
optee-client: add patch to avoid CFLAGS overrides
Base optee-client implementation uses immediate assignment of CFLAGS
variable in it's build structure, which causes Yocto CFLAGS to be
overridden and not properly propagated into the build system.
Introduce a patch which uses append operator intead of immediate
assignment to have both CFLAGS variables to be combined.
Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Diffstat (limited to 'recipes-security/optee-imx/optee-client/0001-flags-do-not-override-CFLAGS-from-host.patch')
-rw-r--r-- | recipes-security/optee-imx/optee-client/0001-flags-do-not-override-CFLAGS-from-host.patch | 34 |
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-security/optee-imx/optee-client/0001-flags-do-not-override-CFLAGS-from-host.patch b/recipes-security/optee-imx/optee-client/0001-flags-do-not-override-CFLAGS-from-host.patch new file mode 100644 index 00000000..3bbf898b --- /dev/null +++ b/recipes-security/optee-imx/optee-client/0001-flags-do-not-override-CFLAGS-from-host.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From ea7e0fba6da734e5f99f84d10d456ceaaed05883 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrey Zhizhikin <andrey.z@gmail.com> | ||
3 | Date: Sun, 31 May 2020 20:40:25 +0000 | ||
4 | Subject: [PATCH] flags: do not override CFLAGS from host | ||
5 | |||
6 | Some build systems set CFLAGS in environment before the build, but they | ||
7 | got overridden by CFLAGS immediate assignment operator. | ||
8 | |||
9 | Replace immediate assignment with append directive, so the former | ||
10 | definition of CFLAGS gets properly expanded. | ||
11 | |||
12 | Upstream-Status: Submitted [https://github.com/OP-TEE/optee_client/pull/211] | ||
13 | |||
14 | Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> | ||
15 | --- | ||
16 | flags.mk | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/flags.mk b/flags.mk | ||
20 | index 71f3d18..af13495 100644 | ||
21 | --- a/flags.mk | ||
22 | +++ b/flags.mk | ||
23 | @@ -6,7 +6,7 @@ CROSS_COMPILE ?= arm-linux-gnueabihf- | ||
24 | CC ?= $(CROSS_COMPILE)gcc | ||
25 | AR ?= $(CROSS_COMPILE)ar | ||
26 | |||
27 | -CFLAGS := -Wall -Wbad-function-cast -Wcast-align \ | ||
28 | +CFLAGS += -Wall -Wbad-function-cast -Wcast-align \ | ||
29 | -Werror-implicit-function-declaration -Wextra \ | ||
30 | -Wfloat-equal -Wformat-nonliteral -Wformat-security \ | ||
31 | -Wformat=2 -Winit-self -Wmissing-declarations \ | ||
32 | -- | ||
33 | 2.17.1 | ||
34 | |||