summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2021.04.bb4
-rw-r--r--recipes-bsp/u-boot/u-boot-mfgtool.inc4
2 files changed, 4 insertions, 4 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx_2021.04.bb b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
index 40772e2b..6a279a12 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
@@ -8,7 +8,7 @@ require u-boot-imx-common_${PV}.inc
8PROVIDES += "u-boot" 8PROVIDES += "u-boot"
9 9
10do_deploy_append_mx8m() { 10do_deploy_append_mx8m() {
11 # Deploy the mkimage, u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary 11 # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
12 if [ -n "${UBOOT_CONFIG}" ] 12 if [ -n "${UBOOT_CONFIG}" ]
13 then 13 then
14 for config in ${UBOOT_MACHINE}; do 14 for config in ${UBOOT_MACHINE}; do
@@ -19,7 +19,7 @@ do_deploy_append_mx8m() {
19 then 19 then
20 install -d ${DEPLOYDIR}/${BOOT_TOOLS} 20 install -d ${DEPLOYDIR}/${BOOT_TOOLS}
21 install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} 21 install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
22 install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${UBOOT_CONFIG} 22 install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${type}
23 fi 23 fi
24 done 24 done
25 unset j 25 unset j
diff --git a/recipes-bsp/u-boot/u-boot-mfgtool.inc b/recipes-bsp/u-boot/u-boot-mfgtool.inc
index 91526ad7..92d055bf 100644
--- a/recipes-bsp/u-boot/u-boot-mfgtool.inc
+++ b/recipes-bsp/u-boot/u-boot-mfgtool.inc
@@ -17,5 +17,5 @@ UBOOT_CONFIG = "mfgtool"
17# Add 'mfgtool' suffix 17# Add 'mfgtool' suffix
18UBOOT_IMAGE = "u-boot-${MACHINE}-mfgtool-${PV}-${PR}.${UBOOT_SUFFIX}" 18UBOOT_IMAGE = "u-boot-${MACHINE}-mfgtool-${PV}-${PR}.${UBOOT_SUFFIX}"
19UBOOT_SYMLINK = "u-boot-${MACHINE}-mfgtool.${UBOOT_SUFFIX}" 19UBOOT_SYMLINK = "u-boot-${MACHINE}-mfgtool.${UBOOT_SUFFIX}"
20SPL_IMAGE = "${SPL_BINARY}-${MACHINE}-mfgtool-${PV}-${PR}" 20SPL_IMAGE = "${SPL_BINARYNAME}-${MACHINE}-mfgtool-${PV}-${PR}"
21SPL_SYMLINK = "${SPL_BINARY}-mfgtool-${MACHINE}" 21SPL_SYMLINK = "${SPL_BINARYNAME}-mfgtool-${MACHINE}"