diff options
2 files changed, 47 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-glplugin-Change-wayland-default-res-to-1024x768.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-glplugin-Change-wayland-default-res-to-1024x768.patch new file mode 100644 index 00000000..ee1cffbb --- /dev/null +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-glplugin-Change-wayland-default-res-to-1024x768.patch | |||
@@ -0,0 +1,42 @@ | |||
1 | From bb2db3bb88e1f72b611c1ae1cc4854bf570daac8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Jian <Jian.Li@freescale.com> | ||
3 | Date: Tue, 17 Nov 2015 14:39:07 +0800 | ||
4 | Subject: [PATCH 10/18] [glplugin] Change wayland default res to 1024x768 | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | Change wayland backend default window resolution | ||
10 | from 320x240 to 1024x768 | ||
11 | |||
12 | Upstream-Status: Inappropriate [i.MX specific] | ||
13 | |||
14 | Signed-off-by: Jian <Jian.Li@freescale.com> | ||
15 | Signed-off-by: Lyon Wang <lyon.wang@freescale.com> | ||
16 | --- | ||
17 | gst-libs/gst/gl/wayland/gstglwindow_wayland_egl.c | 4 ++-- | ||
18 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
19 | |||
20 | diff --git a/gst-libs/gst/gl/wayland/gstglwindow_wayland_egl.c b/gst-libs/gst/gl/wayland/gstglwindow_wayland_egl.c | ||
21 | index 6e1f0c5..48b37a2 100644 | ||
22 | --- a/gst-libs/gst/gl/wayland/gstglwindow_wayland_egl.c | ||
23 | +++ b/gst-libs/gst/gl/wayland/gstglwindow_wayland_egl.c | ||
24 | @@ -305,13 +305,13 @@ create_surfaces (GstGLWindowWaylandEGL * window_egl) | ||
25 | if (window_egl->window.window_width > 0) | ||
26 | width = window_egl->window.window_width; | ||
27 | else | ||
28 | - width = 320; | ||
29 | + width = 1024; | ||
30 | window_egl->window.window_width = width; | ||
31 | |||
32 | if (window_egl->window.window_height > 0) | ||
33 | height = window_egl->window.window_height; | ||
34 | else | ||
35 | - height = 240; | ||
36 | + height = 768; | ||
37 | window_egl->window.window_height = height; | ||
38 | |||
39 | if (!window_egl->window.native) { | ||
40 | -- | ||
41 | 1.9.1 | ||
42 | |||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend index 67dc1f77..98e8d144 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend | |||
@@ -1,5 +1,6 @@ | |||
1 | # Vivante EGL headers require the correct preprocessor | 1 | # Vivante EGL headers require the correct preprocessor |
2 | # defines to be set for each platform | 2 | # defines to be set for each platform |
3 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
3 | 4 | ||
4 | CFLAGS_append_mx6 = " -DLINUX \ | 5 | CFLAGS_append_mx6 = " -DLINUX \ |
5 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ | 6 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ |
@@ -9,4 +10,8 @@ PACKAGECONFIG_GL_mx6sl = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', \ | |||
9 | bb.utils.contains('DISTRO_FEATURES', 'x11', \ | 10 | bb.utils.contains('DISTRO_FEATURES', 'x11', \ |
10 | 'opengl', '', d), '', d)}" | 11 | 'opengl', '', d), '', d)}" |
11 | 12 | ||
13 | SRC_URI_append = " file://0001-glplugin-Change-wayland-default-res-to-1024x768.patch \ | ||
14 | " | ||
15 | |||
16 | |||
12 | PACKAGE_ARCH_mx6 = "${MACHINE_SOCARCH}" | 17 | PACKAGE_ARCH_mx6 = "${MACHINE_SOCARCH}" |