summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.6+fslc.bb2
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_5.15.bb2
-rw-r--r--recipes-kernel/linux/linux-fslc-lts_5.15.bb4
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-Fix-types-to-match-callback-functions.patch53
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.3.imx.bb1
5 files changed, 58 insertions, 4 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.6+fslc.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.6+fslc.bb
index fc51acfe..4cec73e5 100644
--- a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.6+fslc.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.6+fslc.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
9 9
10PV .= "+git${SRCPV}" 10PV .= "+git${SRCPV}"
11 11
12SRCREV = "1adf982c5954f2f87919c6874279386f82e898a6" 12SRCREV = "43f9d48f2941c61cf9ed8dd923d12db7d855874e"
13SRC_URI = "git://github.com/Freescale/kernel-module-imx-gpu-viv.git;protocol=https;branch=master" 13SRC_URI = "git://github.com/Freescale/kernel-module-imx-gpu-viv.git;protocol=https;branch=master"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
diff --git a/recipes-kernel/linux/linux-fslc-imx_5.15.bb b/recipes-kernel/linux/linux-fslc-imx_5.15.bb
index 7d23198b..80c7deef 100644
--- a/recipes-kernel/linux/linux-fslc-imx_5.15.bb
+++ b/recipes-kernel/linux/linux-fslc-imx_5.15.bb
@@ -51,7 +51,7 @@ LICENSE = "GPL-2.0-only"
51LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" 51LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
52 52
53KBRANCH = "5.15-2.2.x-imx" 53KBRANCH = "5.15-2.2.x-imx"
54SRCREV = "3ff5eb3ff57e665c47c072284d7f624e5452b85d" 54SRCREV = "3248ffcb12d15a0e40b9a020ba362591b8137923"
55 55
56# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 56# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
57# required by kernel-yocto.bbclass. 57# required by kernel-yocto.bbclass.
diff --git a/recipes-kernel/linux/linux-fslc-lts_5.15.bb b/recipes-kernel/linux/linux-fslc-lts_5.15.bb
index 9b0afbd9..c77d43c9 100644
--- a/recipes-kernel/linux/linux-fslc-lts_5.15.bb
+++ b/recipes-kernel/linux/linux-fslc-lts_5.15.bb
@@ -19,9 +19,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
19# 19#
20# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 20# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
21# should be updated once patchlevel is merged. 21# should be updated once patchlevel is merged.
22LINUX_VERSION = "5.15.86" 22LINUX_VERSION = "5.15.91"
23 23
24KBRANCH = "5.15.x+fslc" 24KBRANCH = "5.15.x+fslc"
25SRCREV = "a86fe5cb4fe96228e358108d0ed91d2c49bce097" 25SRCREV = "4d20f1dcda24d6b2ee234e91bf2ba00083058586"
26 26
27COMPATIBLE_MACHINE = "(imx-generic-bsp)" 27COMPATIBLE_MACHINE = "(imx-generic-bsp)"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-Fix-types-to-match-callback-functions.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-Fix-types-to-match-callback-functions.patch
new file mode 100644
index 00000000..378d5e27
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-Fix-types-to-match-callback-functions.patch
@@ -0,0 +1,53 @@
1From 98b5411642ffac9d895de968748102c2c6d18cb4 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 1 Feb 2023 14:29:49 -0800
4Subject: [PATCH] Fix types to match callback functions
5
6Fixes build errors seen with gcc13
7
8| ../git/gst-libs/gst/gl/gstglphymemory.c:312:25: error: incompatible function pointer types assigning to 'GDestroyNotify' (aka 'void (*)(void *)') from 'void (GstMemory *)' (aka 'void (struct _GstMemory *)') [-Win
9compatible-function-pointer-types]
10| params->parent.notify = gst_gl_phy_mem_destroy;
11| ^ ~~~~~~~~~~~~~~~~~~~~~~
12| ../git/gst-libs/gst/gl/gstglphymemory.c:340:5: warning: cast to smaller integer type 'guint' (aka 'unsigned int') from 'guint8 *' (aka 'unsigned char *') [-Wpointer-to-int-cast]
13| (guint)memblk->paddr,
14| ^~~~~~~~~~~~~~~~~~~~
15| ../git/gst-libs/gst/gl/gstglphymemory.c:345:7: error: incompatible function pointer types passing 'void (GstGLContext *, DirectVIVData *)' (aka 'void (struct _GstGLContext *, DirectVIVData *)') to parameter of ty
16pe 'GstGLContextThreadFunc' (aka 'void (*)(struct _GstGLContext *, void *)') [-Wincompatible-function-pointer-types]
17| _do_viv_direct_tex_bind_mem, &directvivdata);
18| ^~~~~~~~~~~~~~~~~~~~~~~~~~~
19
20Upstream-Status: Submitted [https://github.com/nxp-imx/gst-plugins-base/pull/1]
21Signed-off-by: Khem Raj <raj.khem@gmail.com>
22---
23 gst-libs/gst/gl/gstglphymemory.c | 5 +++--
24 1 file changed, 3 insertions(+), 2 deletions(-)
25
26diff --git a/gst-libs/gst/gl/gstglphymemory.c b/gst-libs/gst/gl/gstglphymemory.c
27index d82c9a66a..0a191f1a5 100644
28--- a/gst-libs/gst/gl/gstglphymemory.c
29+++ b/gst-libs/gst/gl/gstglphymemory.c
30@@ -163,9 +163,10 @@ _finish_texture (GstGLContext * ctx, gpointer * data)
31 }
32
33 static void
34-_do_viv_direct_tex_bind_mem (GstGLContext * ctx, DirectVIVData * data)
35+_do_viv_direct_tex_bind_mem (GstGLContext * ctx, void * data_in)
36 {
37 GstGLFuncs *gl = ctx->gl_vtable;
38+ DirectVIVData *data = (DirectVIVData*) data_in;
39
40 GST_DEBUG ("viv direct bind, tex_id %d, fmt: %d, res: (%dx%d)", data->tex_id,
41 data->fmt, data->w, data->h);
42@@ -211,7 +212,7 @@ _directviv_video_format_to_gl_format (GstVideoFormat format)
43 }
44
45 static void
46-gst_gl_phy_mem_destroy (GstMemory * mem)
47+gst_gl_phy_mem_destroy (void * mem)
48 {
49 gst_memory_unref (mem);
50 }
51--
522.39.1
53
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.3.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.3.imx.bb
index d365699f..d338f986 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.3.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.3.imx.bb
@@ -17,6 +17,7 @@ SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-ba
17 file://0001-ENGR00312515-get-caps-from-src-pad-when-query-caps.patch \ 17 file://0001-ENGR00312515-get-caps-from-src-pad-when-query-caps.patch \
18 file://0003-viv-fb-Make-sure-config.h-is-included.patch \ 18 file://0003-viv-fb-Make-sure-config.h-is-included.patch \
19 file://0002-ssaparse-enhance-SSA-text-lines-parsing.patch \ 19 file://0002-ssaparse-enhance-SSA-text-lines-parsing.patch \
20 file://0001-Fix-types-to-match-callback-functions.patch \
20 " 21 "
21SRC_URI[sha256sum] = "96d8a6413ba9394fbec1217aeef63741a729d476a505a797c1d5337d8fa7c204" 22SRC_URI[sha256sum] = "96d8a6413ba9394fbec1217aeef63741a729d476a505a797c1d5337d8fa7c204"
22 23