diff options
-rw-r--r-- | .github/workflows/backport.yaml | 8 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-imx-common_2021.04.inc (renamed from recipes-bsp/u-boot/u-boot-imx-common.inc) | 6 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb (renamed from recipes-bsp/u-boot/u-boot-imx-mfgtool_2020.04.bb) | 0 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-imx_2021.04.bb (renamed from recipes-bsp/u-boot/u-boot-imx_2020.04.bb) | 2 | ||||
-rw-r--r-- | recipes-extended/tsntool/tsntool_git.bb | 2 |
5 files changed, 9 insertions, 9 deletions
diff --git a/.github/workflows/backport.yaml b/.github/workflows/backport.yaml index 43245301..54dce5bc 100644 --- a/.github/workflows/backport.yaml +++ b/.github/workflows/backport.yaml | |||
@@ -1,6 +1,6 @@ | |||
1 | name: Backport labeled merged pull requests | 1 | name: Backport labeled merged pull requests |
2 | on: | 2 | on: |
3 | pull_request: | 3 | pull_request_target: |
4 | types: [closed] | 4 | types: [closed] |
5 | issue_comment: | 5 | issue_comment: |
6 | types: [created] | 6 | types: [created] |
@@ -12,11 +12,11 @@ jobs: | |||
12 | # or when a comment containing `/backport` is created | 12 | # or when a comment containing `/backport` is created |
13 | if: > | 13 | if: > |
14 | ( | 14 | ( |
15 | github.event_name == 'pull_request' && | 15 | github.event_name == 'pull_request_target' && |
16 | github.event.pull_request.merged | 16 | github.event.pull_request_target.merged |
17 | ) || ( | 17 | ) || ( |
18 | github.event_name == 'issue_comment' && | 18 | github.event_name == 'issue_comment' && |
19 | github.event.issue.pull_request && | 19 | github.event.issue.pull_request_target && |
20 | contains(github.event.comment.body, '/backport') | 20 | contains(github.event.comment.body, '/backport') |
21 | ) | 21 | ) |
22 | steps: | 22 | steps: |
diff --git a/recipes-bsp/u-boot/u-boot-imx-common.inc b/recipes-bsp/u-boot/u-boot-imx-common_2021.04.inc index f1edc92c..2abcac9b 100644 --- a/recipes-bsp/u-boot/u-boot-imx-common.inc +++ b/recipes-bsp/u-boot/u-boot-imx-common_2021.04.inc | |||
@@ -3,9 +3,9 @@ DESCRIPTION = "i.MX U-Boot suppporting i.MX reference boards." | |||
3 | LICENSE = "GPLv2+" | 3 | LICENSE = "GPLv2+" |
4 | LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263" | 4 | LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
5 | 5 | ||
6 | SRCBRANCH = "imx_v2020.04_5.4.70_2.3.0" | 6 | SRCBRANCH = "lf_v2021.04" |
7 | SRC_URI = "git://source.codeaurora.org/external/imx/uboot-imx.git;protocol=https;branch=${SRCBRANCH}" | 7 | SRC_URI = "git://source.codeaurora.org/external/imx/uboot-imx.git;protocol=https;branch=${SRCBRANCH}" |
8 | SRCREV = "185bdaaaf5644319284566e5c340927d28954a1a" | 8 | SRCREV = "3463140881c523e248d2fcb6bfc9ed25c0db93bd" |
9 | 9 | ||
10 | DEPENDS += "flex-native bison-native bc-native dtc-native" | 10 | DEPENDS += "flex-native bison-native bc-native dtc-native" |
11 | 11 | ||
@@ -14,7 +14,7 @@ B = "${WORKDIR}/build" | |||
14 | 14 | ||
15 | inherit fsl-u-boot-localversion | 15 | inherit fsl-u-boot-localversion |
16 | 16 | ||
17 | LOCALVERSION ?= "-imx_v2020.04_5.4.70_2.3.2" | 17 | LOCALVERSION ?= "-imx_v2021.04_5.10.35_2.0.0" |
18 | 18 | ||
19 | BOOT_TOOLS = "imx-boot-tools" | 19 | BOOT_TOOLS = "imx-boot-tools" |
20 | 20 | ||
diff --git a/recipes-bsp/u-boot/u-boot-imx-mfgtool_2020.04.bb b/recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb index 2b296c19..2b296c19 100644 --- a/recipes-bsp/u-boot/u-boot-imx-mfgtool_2020.04.bb +++ b/recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb | |||
diff --git a/recipes-bsp/u-boot/u-boot-imx_2020.04.bb b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb index 058229e2..40772e2b 100644 --- a/recipes-bsp/u-boot/u-boot-imx_2020.04.bb +++ b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb | |||
@@ -3,7 +3,7 @@ | |||
3 | # Copyright (C) 2017-2021 NXP | 3 | # Copyright (C) 2017-2021 NXP |
4 | 4 | ||
5 | require recipes-bsp/u-boot/u-boot.inc | 5 | require recipes-bsp/u-boot/u-boot.inc |
6 | require u-boot-imx-common.inc | 6 | require u-boot-imx-common_${PV}.inc |
7 | 7 | ||
8 | PROVIDES += "u-boot" | 8 | PROVIDES += "u-boot" |
9 | 9 | ||
diff --git a/recipes-extended/tsntool/tsntool_git.bb b/recipes-extended/tsntool/tsntool_git.bb index 94091db8..8ef79d27 100644 --- a/recipes-extended/tsntool/tsntool_git.bb +++ b/recipes-extended/tsntool/tsntool_git.bb | |||
@@ -8,7 +8,7 @@ DEPENDS = "cjson libnl readline" | |||
8 | inherit pkgconfig | 8 | inherit pkgconfig |
9 | 9 | ||
10 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/tsntool;protocol=https;nobranch=1" | 10 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/tsntool;protocol=https;nobranch=1" |
11 | SRCREV = "1d1686e83c8f83472055189c278b837434990dcc" | 11 | SRCREV = "3111f7f79e7d1b1a5e60f37fe76785559b2d0360" |
12 | 12 | ||
13 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
14 | 14 | ||