diff options
-rw-r--r-- | recipes-security/optee-imx/optee-os_3.15.0.imx.bb | 3 | ||||
-rw-r--r-- | recipes-security/optee-imx/optee-test_3.15.0.imx.bb | 8 |
2 files changed, 3 insertions, 8 deletions
diff --git a/recipes-security/optee-imx/optee-os_3.15.0.imx.bb b/recipes-security/optee-imx/optee-os_3.15.0.imx.bb index 15244c45..6d10b93d 100644 --- a/recipes-security/optee-imx/optee-os_3.15.0.imx.bb +++ b/recipes-security/optee-imx/optee-os_3.15.0.imx.bb | |||
@@ -40,8 +40,7 @@ PLATFORM_FLAVOR:mx8dx-nxp-bsp = "mx8dxmek" | |||
40 | PLATFORM_FLAVOR:mx8dxl-nxp-bsp = "mx8dxlevk" | 40 | PLATFORM_FLAVOR:mx8dxl-nxp-bsp = "mx8dxlevk" |
41 | PLATFORM_FLAVOR:mx8ulp-nxp-bsp = "mx8ulpevk" | 41 | PLATFORM_FLAVOR:mx8ulp-nxp-bsp = "mx8ulpevk" |
42 | 42 | ||
43 | OPTEE_ARCH ?= "arm32" | 43 | OPTEE_ARCH:arm = "arm32" |
44 | OPTEE_ARCH:armv7a = "arm32" | ||
45 | OPTEE_ARCH:aarch64 = "arm64" | 44 | OPTEE_ARCH:aarch64 = "arm64" |
46 | 45 | ||
47 | # Optee-os can be built for 32 bits and 64 bits at the same time | 46 | # Optee-os can be built for 32 bits and 64 bits at the same time |
diff --git a/recipes-security/optee-imx/optee-test_3.15.0.imx.bb b/recipes-security/optee-imx/optee-test_3.15.0.imx.bb index a44454a7..a3649d74 100644 --- a/recipes-security/optee-imx/optee-test_3.15.0.imx.bb +++ b/recipes-security/optee-imx/optee-test_3.15.0.imx.bb | |||
@@ -21,18 +21,14 @@ inherit python3native features_check | |||
21 | 21 | ||
22 | REQUIRED_MACHINE_FEATURES = "optee" | 22 | REQUIRED_MACHINE_FEATURES = "optee" |
23 | 23 | ||
24 | OPTEE_ARCH ?= "arm32" | 24 | OPTEE_ARCH:arm = "arm32" |
25 | OPTEE_ARCH:armv7a = "arm32" | ||
26 | OPTEE_ARCH:aarch64 = "arm64" | 25 | OPTEE_ARCH:aarch64 = "arm64" |
27 | 26 | ||
28 | TA_DEV_KIT_DIR:arm = "${STAGING_INCDIR}/optee/export-user_ta_arm32/" | ||
29 | TA_DEV_KIT_DIR:aarch64 = "${STAGING_INCDIR}/optee/export-user_ta_arm64/" | ||
30 | |||
31 | CFLAGS += "--sysroot=${STAGING_DIR_HOST}" | 27 | CFLAGS += "--sysroot=${STAGING_DIR_HOST}" |
32 | CXXFLAGS += "--sysroot=${STAGING_DIR_HOST}" | 28 | CXXFLAGS += "--sysroot=${STAGING_DIR_HOST}" |
33 | 29 | ||
34 | EXTRA_OEMAKE = " \ | 30 | EXTRA_OEMAKE = " \ |
35 | TA_DEV_KIT_DIR=${TA_DEV_KIT_DIR} \ | 31 | TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta_${OPTEE_ARCH}/ \ |
36 | ARCH=${OPTEE_ARCH} \ | 32 | ARCH=${OPTEE_ARCH} \ |
37 | OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}${exec_prefix} \ | 33 | OPTEE_CLIENT_EXPORT=${STAGING_DIR_HOST}${exec_prefix} \ |
38 | CROSS_COMPILE_HOST=${HOST_PREFIX} \ | 34 | CROSS_COMPILE_HOST=${HOST_PREFIX} \ |