diff options
-rw-r--r-- | conf/machine/imx6qdlsabreauto.conf | 2 | ||||
-rw-r--r-- | conf/machine/imx6qdlsabresd.conf | 2 | ||||
-rw-r--r-- | recipes-graphics/cairo/cairo_%.bbappend | 2 | ||||
-rw-r--r-- | recipes-graphics/harfbuzz/harfbuzz_%.bbappend | 5 | ||||
-rw-r--r-- | recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.0.bb | 3 | ||||
-rw-r--r-- | recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc | 20 | ||||
-rw-r--r-- | recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb | 7 | ||||
-rw-r--r-- | recipes-graphics/pango/pango_%.bbappend | 5 | ||||
-rw-r--r-- | recipes-graphics/wayland/weston_10.0.0.imx.bb | 4 | ||||
-rw-r--r-- | recipes-graphics/xwayland/xwayland_%.bbappend | 7 | ||||
-rw-r--r-- | recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb | 4 | ||||
-rw-r--r-- | recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.2.bb | 4 |
12 files changed, 59 insertions, 6 deletions
diff --git a/conf/machine/imx6qdlsabreauto.conf b/conf/machine/imx6qdlsabreauto.conf index 16a061e5..b7b44589 100644 --- a/conf/machine/imx6qdlsabreauto.conf +++ b/conf/machine/imx6qdlsabreauto.conf | |||
@@ -34,7 +34,7 @@ KERNEL_DEVICETREE:use-mainline-bsp = " \ | |||
34 | 34 | ||
35 | ### u-boot-fslc settings ### | 35 | ### u-boot-fslc settings ### |
36 | SPL_BINARY:pn-u-boot-fslc = "SPL" | 36 | SPL_BINARY:pn-u-boot-fslc = "SPL" |
37 | UBOOT_CONFIG:pn-u-boot-fslc ??= "sd-fslc" | 37 | UBOOT_CONFIG:pn-u-boot-fslc ??= "sd" |
38 | UBOOT_SUFFIX:pn-u-boot-fslc = "img" | 38 | UBOOT_SUFFIX:pn-u-boot-fslc = "img" |
39 | 39 | ||
40 | ### u-boot-imx settings ### | 40 | ### u-boot-imx settings ### |
diff --git a/conf/machine/imx6qdlsabresd.conf b/conf/machine/imx6qdlsabresd.conf index 62ad478e..7c40a860 100644 --- a/conf/machine/imx6qdlsabresd.conf +++ b/conf/machine/imx6qdlsabresd.conf | |||
@@ -43,7 +43,7 @@ KERNEL_DEVICETREE:use-mainline-bsp = " \ | |||
43 | 43 | ||
44 | ### u-boot-fslc settings ### | 44 | ### u-boot-fslc settings ### |
45 | SPL_BINARY:pn-u-boot-fslc = "SPL" | 45 | SPL_BINARY:pn-u-boot-fslc = "SPL" |
46 | UBOOT_CONFIG:pn-u-boot-fslc ??= "sd-fslc" | 46 | UBOOT_CONFIG:pn-u-boot-fslc ??= "sd" |
47 | UBOOT_SUFFIX:pn-u-boot-fslc = "img" | 47 | UBOOT_SUFFIX:pn-u-boot-fslc = "img" |
48 | 48 | ||
49 | ### u-boot-imx settings ### | 49 | ### u-boot-imx settings ### |
diff --git a/recipes-graphics/cairo/cairo_%.bbappend b/recipes-graphics/cairo/cairo_%.bbappend index 245adb59..c61e9a58 100644 --- a/recipes-graphics/cairo/cairo_%.bbappend +++ b/recipes-graphics/cairo/cairo_%.bbappend | |||
@@ -3,6 +3,6 @@ PACKAGECONFIG:remove:imxgpu3d = "opengl" | |||
3 | 3 | ||
4 | # links with imx-gpu libs which are pre-built for glibc | 4 | # links with imx-gpu libs which are pre-built for glibc |
5 | # gcompat will address it during runtime | 5 | # gcompat will address it during runtime |
6 | LDFLAGS:append:imxgpu3d:libc-musl = " -Wl,--allow-shlib-undefined" | ||
7 | LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined" | 6 | LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined" |
8 | 7 | ||
8 | RDEPENDS:${PN}:append:imxgpu:libc-musl = " gcompat" | ||
diff --git a/recipes-graphics/harfbuzz/harfbuzz_%.bbappend b/recipes-graphics/harfbuzz/harfbuzz_%.bbappend new file mode 100644 index 00000000..bf8c38fc --- /dev/null +++ b/recipes-graphics/harfbuzz/harfbuzz_%.bbappend | |||
@@ -0,0 +1,5 @@ | |||
1 | # links with imx-gpu libs which are pre-built for glibc | ||
2 | # gcompat will address it during runtime | ||
3 | LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined" | ||
4 | |||
5 | RDEPENDS:${PN}:append:imxgpu:libc-musl = " gcompat" | ||
diff --git a/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.0.bb b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.0.bb index ad8de74c..e2f5912b 100644 --- a/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.0.bb +++ b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.0.bb | |||
@@ -23,5 +23,8 @@ do_install () { | |||
23 | } | 23 | } |
24 | 24 | ||
25 | INSANE_SKIP:${PN} += "ldflags" | 25 | INSANE_SKIP:${PN} += "ldflags" |
26 | INSANE_SKIP:append:libc-musl = " file-rdeps" | ||
26 | 27 | ||
27 | COMPATIBLE_MACHINE = "(imxdpu)" | 28 | COMPATIBLE_MACHINE = "(imxdpu)" |
29 | |||
30 | RDEPENDS:${PN}:append:libc-musl = " gcompat" | ||
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc index e95761a1..dcfb049b 100644 --- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc +++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc | |||
@@ -25,6 +25,8 @@ DEPENDS:append:mx8-nxp-bsp = " patchelf-native" | |||
25 | # We depend on mesa to fill in what is missing. | 25 | # We depend on mesa to fill in what is missing. |
26 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa', '', d)}" | 26 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa', '', d)}" |
27 | 27 | ||
28 | DEPENDS:append:libc-musl = " gcompat" | ||
29 | |||
28 | PROVIDES += " \ | 30 | PROVIDES += " \ |
29 | imx-gpu-viv \ | 31 | imx-gpu-viv \ |
30 | libgal-imx \ | 32 | libgal-imx \ |
@@ -247,6 +249,24 @@ do_install () { | |||
247 | chown -R root:root "${D}" | 249 | chown -R root:root "${D}" |
248 | } | 250 | } |
249 | 251 | ||
252 | do_install:append:libc-musl() { | ||
253 | # libs | ||
254 | for f in `find ${D}${libdir} -name '*.so*' -type f` | ||
255 | do | ||
256 | patchelf --add-needed libgcompat.so.0 $f | ||
257 | done | ||
258 | # binaries | ||
259 | for f in `find ${D}/opt ${D}${bindir} -name '*' -type f -executable` | ||
260 | do | ||
261 | # prune scripts | ||
262 | if `patchelf --print-interpreter $f 2>&1 > /dev/null` | ||
263 | then | ||
264 | patchelf --set-interpreter ${root_prefix}`patchelf --print-interpreter $f` $f | ||
265 | patchelf --add-needed libgcompat.so.0 $f | ||
266 | fi | ||
267 | done | ||
268 | } | ||
269 | |||
250 | ALLOW_EMPTY:${PN} = "1" | 270 | ALLOW_EMPTY:${PN} = "1" |
251 | 271 | ||
252 | FILES:libclc-imx = "${libdir}/libCLC${SOLIBS} ${includedir}/CL/cl_viv_vx_ext.h" | 272 | FILES:libclc-imx = "${libdir}/libCLC${SOLIBS} ${includedir}/CL/cl_viv_vx_ext.h" |
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb index bd584dbe..4136631b 100644 --- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb +++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb | |||
@@ -1,9 +1,10 @@ | |||
1 | require imx-gpu-viv-6.inc | 1 | require imx-gpu-viv-6.inc |
2 | 2 | ||
3 | DEPENDS:append:libc-musl = " gcompat" | ||
4 | INSANE_SKIP:append:libc-musl = " file-rdeps" | ||
5 | |||
6 | SRC_URI[md5sum] = "22de8a5f59a56a7ef499f590d1659b6f" | 3 | SRC_URI[md5sum] = "22de8a5f59a56a7ef499f590d1659b6f" |
7 | SRC_URI[sha256sum] = "52921c0b59529f1598084e991eda1863100754f28a7744ba958158dff8074b3b" | 4 | SRC_URI[sha256sum] = "52921c0b59529f1598084e991eda1863100754f28a7744ba958158dff8074b3b" |
8 | 5 | ||
6 | INSANE_SKIP:append:libc-musl = " file-rdeps" | ||
7 | |||
9 | COMPATIBLE_MACHINE = "(mx8-nxp-bsp)" | 8 | COMPATIBLE_MACHINE = "(mx8-nxp-bsp)" |
9 | |||
10 | RDEPENDS:${PN}:append:libc-musl = " gcompat" | ||
diff --git a/recipes-graphics/pango/pango_%.bbappend b/recipes-graphics/pango/pango_%.bbappend new file mode 100644 index 00000000..bf8c38fc --- /dev/null +++ b/recipes-graphics/pango/pango_%.bbappend | |||
@@ -0,0 +1,5 @@ | |||
1 | # links with imx-gpu libs which are pre-built for glibc | ||
2 | # gcompat will address it during runtime | ||
3 | LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined" | ||
4 | |||
5 | RDEPENDS:${PN}:append:imxgpu:libc-musl = " gcompat" | ||
diff --git a/recipes-graphics/wayland/weston_10.0.0.imx.bb b/recipes-graphics/wayland/weston_10.0.0.imx.bb index a9f6ec13..b9e8fca5 100644 --- a/recipes-graphics/wayland/weston_10.0.0.imx.bb +++ b/recipes-graphics/wayland/weston_10.0.0.imx.bb | |||
@@ -202,6 +202,10 @@ EXTRA_OEMESON:append:imxfbdev = " -Dbackend-default=fbdev" | |||
202 | 202 | ||
203 | EXTRA_OEMESON += "-Ddeprecated-wl-shell=true" | 203 | EXTRA_OEMESON += "-Ddeprecated-wl-shell=true" |
204 | 204 | ||
205 | # links with imx-gpu libs which are pre-built for glibc | ||
206 | # gcompat will address it during runtime | ||
207 | LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined" | ||
208 | |||
205 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | 209 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" |
206 | COMPATIBLE_MACHINE = "(imxfbdev|imxgpu)" | 210 | COMPATIBLE_MACHINE = "(imxfbdev|imxgpu)" |
207 | 211 | ||
diff --git a/recipes-graphics/xwayland/xwayland_%.bbappend b/recipes-graphics/xwayland/xwayland_%.bbappend index 69063121..f2141f4f 100644 --- a/recipes-graphics/xwayland/xwayland_%.bbappend +++ b/recipes-graphics/xwayland/xwayland_%.bbappend | |||
@@ -10,3 +10,10 @@ OPENGL_PKGCONFIGS_REMOVE_IMXGPU = "" | |||
10 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx6-nxp-bsp = "glamor glx" | 10 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx6-nxp-bsp = "glamor glx" |
11 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx7-nxp-bsp = "glamor glx" | 11 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx7-nxp-bsp = "glamor glx" |
12 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx8-nxp-bsp = "glx" | 12 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx8-nxp-bsp = "glx" |
13 | |||
14 | |||
15 | # links with imx-gpu libs which are pre-built for glibc | ||
16 | # gcompat will address it during runtime | ||
17 | LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined" | ||
18 | |||
19 | RDEPENDS:${PN}:append:imxgpu:libc-musl = " gcompat" | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb index ba1b9787..3cbd2179 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb | |||
@@ -137,6 +137,10 @@ PACKAGECONFIG[viv-fb] = ",,virtual/libgles2" | |||
137 | 137 | ||
138 | EXTRA_OEMESON += "-Dc_args="${CFLAGS} -I${STAGING_INCDIR_IMX}"" | 138 | EXTRA_OEMESON += "-Dc_args="${CFLAGS} -I${STAGING_INCDIR_IMX}"" |
139 | 139 | ||
140 | # links with imx-gpu libs which are pre-built for glibc | ||
141 | # gcompat will address it during runtime | ||
142 | LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined" | ||
143 | |||
140 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" | 144 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" |
141 | 145 | ||
142 | ########### End of i.MX overrides ######### | 146 | ########### End of i.MX overrides ######### |
diff --git a/recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.2.bb b/recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.2.bb index 3d557207..957d6ddf 100644 --- a/recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.2.bb +++ b/recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.2.bb | |||
@@ -16,3 +16,7 @@ INSANE_SKIP:${PN} = "already-stripped" | |||
16 | FILES:${PN} += "${datadir}/imx-mm" | 16 | FILES:${PN} += "${datadir}/imx-mm" |
17 | 17 | ||
18 | COMPATIBLE_MACHINE = "(mx8-nxp-bsp)" | 18 | COMPATIBLE_MACHINE = "(mx8-nxp-bsp)" |
19 | |||
20 | INSANE_SKIP:append:libc-musl = " file-rdeps" | ||
21 | |||
22 | RDEPENDS:${PN}:append:libc-musl = " gcompat" | ||