diff options
-rw-r--r-- | recipes-extended/crconf/crconf/0001-Modify-the-Makefile-for-cross-compile.patch | 30 | ||||
-rw-r--r-- | recipes-extended/crconf/crconf_git.bb | 18 |
2 files changed, 48 insertions, 0 deletions
diff --git a/recipes-extended/crconf/crconf/0001-Modify-the-Makefile-for-cross-compile.patch b/recipes-extended/crconf/crconf/0001-Modify-the-Makefile-for-cross-compile.patch new file mode 100644 index 00000000..4459c370 --- /dev/null +++ b/recipes-extended/crconf/crconf/0001-Modify-the-Makefile-for-cross-compile.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From 2c260c8c437c7f72f093b6c157a38b93443bde1d Mon Sep 17 00:00:00 2001 | ||
2 | From: Chunrong Guo <chunrong.guo@nxp.com> | ||
3 | Date: Mon, 11 Dec 2017 15:45:05 +0800 | ||
4 | Subject: [PATCH] Modify the Makefile for cross compile | ||
5 | |||
6 | Upstream-Status: Inappropriate [embedded specific] | ||
7 | |||
8 | Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> | ||
9 | --- | ||
10 | Makefile | 4 ++-- | ||
11 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
12 | |||
13 | diff --git a/Makefile b/Makefile | ||
14 | index c7bfee2..d6421f3 100644 | ||
15 | --- a/Makefile | ||
16 | +++ b/Makefile | ||
17 | @@ -4,8 +4,8 @@ LIBDIR=/usr/lib | ||
18 | SBINDIR=/sbin | ||
19 | MANDIR=/share/man | ||
20 | |||
21 | -CC = gcc | ||
22 | -HOSTCC = gcc | ||
23 | +CC ?= gcc | ||
24 | +HOSTCC ?= gcc | ||
25 | CCOPTS = -D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall | ||
26 | CFLAGS = $(CCOPTS) -I../include | ||
27 | |||
28 | -- | ||
29 | 2.7.4 | ||
30 | |||
diff --git a/recipes-extended/crconf/crconf_git.bb b/recipes-extended/crconf/crconf_git.bb new file mode 100644 index 00000000..7dc92776 --- /dev/null +++ b/recipes-extended/crconf/crconf_git.bb | |||
@@ -0,0 +1,18 @@ | |||
1 | SUMMARY = "crconf -Linux crypto layer configuraton tool" | ||
2 | SECTION = "base" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://Makefile;beginline=1;endline=5;md5=0f77fc44eb5911007ae4ac9f6736e111" | ||
5 | |||
6 | SRC_URI = "git://github.com/Thermi/crconf.git;protocol=https;nobranch=1" | ||
7 | |||
8 | EXTRA_OEMAKE = "'CC=${CC}' 'HOSTCC=${CC}'" | ||
9 | |||
10 | SRCREV = "7b5819e7638e471d41dd2dca71f012d5a022f014" | ||
11 | |||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | do_install () { | ||
15 | oe_runmake install DESTDIR=${D} | ||
16 | } | ||
17 | |||
18 | FILES_${PN} += "/share/man/* ${libdir}/* ${sbindir}/*" | ||