diff options
-rw-r--r-- | recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_10.0.0.bb | 9 | ||||
-rw-r--r-- | recipes-graphics/libva/libva_%.bbappend | 1 | ||||
-rw-r--r-- | recipes-graphics/piglit/piglit_%.bbappend | 2 | ||||
-rw-r--r-- | recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend | 1 | ||||
-rw-r--r-- | recipes-sato/webkit/webkitgtk_%.bbappend | 4 |
5 files changed, 15 insertions, 2 deletions
diff --git a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_10.0.0.bb b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_10.0.0.bb index bd041582..4cc2685b 100644 --- a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_10.0.0.bb +++ b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_10.0.0.bb | |||
@@ -43,6 +43,13 @@ FILES:${PN} += " \ | |||
43 | ${libdir}/apitrace/scripts/* \ | 43 | ${libdir}/apitrace/scripts/* \ |
44 | ${libdir}/apitrace/wrappers/* \ | 44 | ${libdir}/apitrace/wrappers/* \ |
45 | " | 45 | " |
46 | 46 | EXTRA_OECMAKE += "\ | |
47 | -DENABLE_GUI=OFF \ | ||
48 | -DENABLE_STATIC_LIBGCC=OFF \ | ||
49 | -DENABLE_STATIC_LIBSTDCXX=OFF \ | ||
50 | -DPython3_ROOT_DIR=/usr/bin/python3-native \ | ||
51 | " | ||
47 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | 52 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" |
48 | COMPATIBLE_MACHINE = "(imxgpu)" | 53 | COMPATIBLE_MACHINE = "(imxgpu)" |
54 | SECURITY_CFLAGS:toolchain-clang = "" | ||
55 | |||
diff --git a/recipes-graphics/libva/libva_%.bbappend b/recipes-graphics/libva/libva_%.bbappend new file mode 100644 index 00000000..080052f8 --- /dev/null +++ b/recipes-graphics/libva/libva_%.bbappend | |||
@@ -0,0 +1 @@ | |||
PACKAGECONFIG:remove:imxgpu = "glx" | |||
diff --git a/recipes-graphics/piglit/piglit_%.bbappend b/recipes-graphics/piglit/piglit_%.bbappend index 72cf8eff..2b7561d1 100644 --- a/recipes-graphics/piglit/piglit_%.bbappend +++ b/recipes-graphics/piglit/piglit_%.bbappend | |||
@@ -1,4 +1,4 @@ | |||
1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
2 | 2 | ||
3 | PACKAGECONFIG:remove:imxgpu = "glx" | 3 | PACKAGECONFIG:remove:imxgpu = "x11 glx" |
4 | PACKAGECONFIG:append:mx8-nxp-bsp = " opencl" | 4 | PACKAGECONFIG:append:mx8-nxp-bsp = " opencl" |
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend new file mode 100644 index 00000000..18847603 --- /dev/null +++ b/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend | |||
@@ -0,0 +1 @@ | |||
EXTRA_OEMESON:append:imx-nxp-bsp = " -Dtests=disabled -Dexamples=disabled" | |||
diff --git a/recipes-sato/webkit/webkitgtk_%.bbappend b/recipes-sato/webkit/webkitgtk_%.bbappend new file mode 100644 index 00000000..085be634 --- /dev/null +++ b/recipes-sato/webkit/webkitgtk_%.bbappend | |||
@@ -0,0 +1,4 @@ | |||
1 | # Fixes compile errors like | ||
2 | # Source/WebCore/platform/graphics/egl/GLContextEGL.cpp:198:59: error: invalid 'static_cast' from type 'GLNativeWindowType' {aka 'long unsigned int'} to type 'EGLNativeWindowType' {aka 'wl_egl_window*'} | ||
3 | PACKAGECONFIG:remove:imxgpu3d = "opengl opengl-or-es" | ||
4 | PACKAGECONFIG:append:imxgpu3d = " gles2" | ||