summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-security/optee-imx/optee-client_3.2.0.imx.bb14
1 files changed, 5 insertions, 9 deletions
diff --git a/recipes-security/optee-imx/optee-client_3.2.0.imx.bb b/recipes-security/optee-imx/optee-client_3.2.0.imx.bb
index 707e82fd..d3607ed4 100644
--- a/recipes-security/optee-imx/optee-client_3.2.0.imx.bb
+++ b/recipes-security/optee-imx/optee-client_3.2.0.imx.bb
@@ -13,20 +13,16 @@ SRC_URI = "${OPTEE_CLIENT_SRC};branch=${SRCBRANCH}"
13 13
14SRCREV = "71a9bef78fff2d5d4db8a2307d3b91e2aa671dc9" 14SRCREV = "71a9bef78fff2d5d4db8a2307d3b91e2aa671dc9"
15 15
16FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
17
18SRC_URI_append = " file://tee-supplicant.service" 16SRC_URI_append = " file://tee-supplicant.service"
19 17
20S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
21SYSTEMD_SERVICE_${PN} = "tee-supplicant.service" 19SYSTEMD_SERVICE_${PN} = "tee-supplicant.service"
22 20
23do_compile () { 21OPTEE_ARCH ?= "arm32"
24 if [ ${DEFAULTTUNE} = "aarch64" ]; then 22OPTEE_ARCH_armv7a = "arm32"
25 oe_runmake -C ${S} ARCH=arm64 23OPTEE_ARCH_aarch64 = "arm64"
26 else 24
27 oe_runmake -C ${S} ARCH=arm 25EXTRA_OEMAKE = "ARCH=${OPTEE_ARCH}"
28 fi
29}
30 26
31do_install () { 27do_install () {
32 oe_runmake install 28 oe_runmake install