diff options
-rw-r--r-- | recipes-dpaa2/dpl-examples/dpl-examples_git.bb | 15 |
1 files changed, 9 insertions, 6 deletions
diff --git a/recipes-dpaa2/dpl-examples/dpl-examples_git.bb b/recipes-dpaa2/dpl-examples/dpl-examples_git.bb index 17946b3f..d6d668ba 100644 --- a/recipes-dpaa2/dpl-examples/dpl-examples_git.bb +++ b/recipes-dpaa2/dpl-examples/dpl-examples_git.bb | |||
@@ -1,30 +1,33 @@ | |||
1 | SUMMARY = "Datapath layout examples" | 1 | SUMMARY = "Datapath layout examples" |
2 | LICENSE = "Freescale-EULA" | 2 | LICENSE = "Freescale-EULA" |
3 | LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f" | 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=386a6287daa6504b7e7e5014ddfb3987" |
4 | 4 | ||
5 | DEPENDS = "dtc-native" | 5 | DEPENDS = "dtc-native" |
6 | 6 | ||
7 | inherit deploy | 7 | inherit deploy |
8 | 8 | ||
9 | SRC_URI = "git://git.freescale.com/ppc/sdk/dpl-examples.git;nobranch=1" | 9 | SRC_URI = "git://github.com/qoriq-open-source/dpl-examples.git;nobranch=1" |
10 | SRCREV = "cea280fd06b9c43fa73f3d9ef629b171cccd0fcd" | 10 | SRCREV = "592fc2fd1f13107c8a4ae8070fed11a5f8d10471" |
11 | 11 | ||
12 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
13 | 13 | ||
14 | REGLEX_ls2088a = "ls2088a" | ||
15 | REGLEX_ls1088a = "ls1088a" | ||
16 | |||
14 | do_install () { | 17 | do_install () { |
15 | install -d ${D}/boot | 18 | install -d ${D}/boot |
16 | install -m 644 ${S}/ls2080a/RDB/*.dtb ${D}/boot | 19 | install -m 644 ${S}/${REGLEX}/RDB/*.dtb ${D}/boot |
17 | } | 20 | } |
18 | 21 | ||
19 | do_deploy () { | 22 | do_deploy () { |
20 | install -d ${DEPLOYDIR}/dpl-examples | 23 | install -d ${DEPLOYDIR}/dpl-examples |
21 | install -m 644 ${S}/ls2080a/RDB/*.dtb ${DEPLOYDIR}/dpl-examples | 24 | install -m 644 ${S}/${REGLEX}/RDB/*.dtb ${DEPLOYDIR}/dpl-examples |
22 | } | 25 | } |
23 | addtask deploy before do_build after do_install | 26 | addtask deploy before do_build after do_install |
24 | 27 | ||
25 | PACKAGES += "${PN}-image" | 28 | PACKAGES += "${PN}-image" |
26 | FILES_${PN}-image += "/boot" | 29 | FILES_${PN}-image += "/boot" |
27 | 30 | ||
28 | COMPATIBLE_MACHINE = "(ls2080ardb|ls2088a)" | 31 | COMPATIBLE_MACHINE = "(ls2080ardb|ls2088a|ls1088a)" |
29 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 32 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
30 | 33 | ||