summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch25
-rw-r--r--recipes-kernel/linux/linux-qoriq/0001-Makfefile-add-cflags.patch26
-rw-r--r--recipes-kernel/linux/linux-qoriq/0001-fix-gcc8-build-error.patch25
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.14.bb4
4 files changed, 28 insertions, 52 deletions
diff --git a/recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch b/recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch
deleted file mode 100644
index b4c4aed8..00000000
--- a/recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch
+++ /dev/null
@@ -1,25 +0,0 @@
1From 5066b8f46b0f2348881923491b93825ac04d13d2 Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Sat, 29 Sep 2018 14:12:34 +0800
4Subject: [PATCH] Makefile: fix gcc-8 build error
5
6Signed-off-by: BJ DevOps Team <bjdevops@NXP1.onmicrosoft.com>
7---
8 Makefile | 1 +
9 1 file changed, 1 insertion(+)
10
11diff --git a/Makefile b/Makefile
12index 53d57ac..b7c5fd4 100644
13--- a/Makefile
14+++ b/Makefile
15@@ -395,6 +395,7 @@ LINUXINCLUDE += $(filter-out $(LINUXINCLUDE),$(USERINCLUDE))
16 KBUILD_AFLAGS := -D__ASSEMBLY__
17 KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \
18 -fno-strict-aliasing -fno-common \
19+ -Wno-packed-not-aligned -Wno-tautological-compare \
20 -Werror-implicit-function-declaration \
21 -Wno-format-security \
22 -std=gnu89
23--
241.8.3.1
25
diff --git a/recipes-kernel/linux/linux-qoriq/0001-Makfefile-add-cflags.patch b/recipes-kernel/linux/linux-qoriq/0001-Makfefile-add-cflags.patch
new file mode 100644
index 00000000..b01545f8
--- /dev/null
+++ b/recipes-kernel/linux/linux-qoriq/0001-Makfefile-add-cflags.patch
@@ -0,0 +1,26 @@
1From e2283cc7582ba82f346b05fdb38f0057e54de7fa Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Tue, 12 Mar 2019 03:52:03 +0100
4Subject: [PATCH] Makfefile: add cflags
5
6Signed-off-by: C.r. Guo <nxa13725@lsv07004.swis.us-cdc01.nxp.com>
7---
8 Makefile | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/Makefile b/Makefile
12index 967692b..ae395cd 100644
13--- a/Makefile
14+++ b/Makefile
15@@ -417,7 +417,7 @@ LINUXINCLUDE := \
16 KBUILD_AFLAGS := -D__ASSEMBLY__
17 KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \
18 -fno-strict-aliasing -fno-common -fshort-wchar \
19- -Werror-implicit-function-declaration \
20+ -Werror-implicit-function-declaration -Wno-misleading-indentation -Wno-tautological-compare \
21 -Wno-format-security \
22 -std=gnu89
23 KBUILD_CPPFLAGS := -D__KERNEL__
24--
252.7.4
26
diff --git a/recipes-kernel/linux/linux-qoriq/0001-fix-gcc8-build-error.patch b/recipes-kernel/linux/linux-qoriq/0001-fix-gcc8-build-error.patch
deleted file mode 100644
index 3cd25014..00000000
--- a/recipes-kernel/linux/linux-qoriq/0001-fix-gcc8-build-error.patch
+++ /dev/null
@@ -1,25 +0,0 @@
1From 844ce11967bca7b7f68c6cb459e02c9a10f32574 Mon Sep 17 00:00:00 2001
2From: BJ DevOps Team <bjdevops@NXP1.onmicrosoft.com>
3Date: Tue, 3 Jul 2018 15:06:29 +0800
4Subject: [PATCH] fix gcc8 build error
5
6---
7 Makefile | 2 ++
8 1 file changed, 2 insertions(+)
9
10diff --git a/Makefile b/Makefile
11index d6db01a..85d9d6c 100644
12--- a/Makefile
13+++ b/Makefile
14@@ -422,6 +422,8 @@ LINUXINCLUDE := \
15 KBUILD_AFLAGS := -D__ASSEMBLY__
16 KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \
17 -fno-strict-aliasing -fno-common -fshort-wchar \
18+ -Wno-packed-not-aligned \
19+ -Wno-tautological-compare \
20 -Werror-implicit-function-declaration \
21 -Wno-format-security \
22 -std=gnu89
23--
241.8.3.1
25
diff --git a/recipes-kernel/linux/linux-qoriq_4.14.bb b/recipes-kernel/linux/linux-qoriq_4.14.bb
index cb06ae43..9f4bcf04 100644
--- a/recipes-kernel/linux/linux-qoriq_4.14.bb
+++ b/recipes-kernel/linux/linux-qoriq_4.14.bb
@@ -7,9 +7,9 @@ LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" 7LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
8 8
9SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \ 9SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \
10 file://0001-fix-gcc8-build-error.patch \ 10 file://0001-Makfefile-add-cflags.patch \
11" 11"
12SRCREV = "7e0006ca696756b867abbeb7a4ed97ffe9caf725" 12SRCREV = "7e52442b136c439c142c4859a70ce92208c481a9"
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15 15