diff options
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc-common_2017.09.inc (renamed from recipes-bsp/u-boot/u-boot-fslc.inc) | 16 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb | 17 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc_2017.09.bb | 12 |
3 files changed, 17 insertions, 28 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc.inc b/recipes-bsp/u-boot/u-boot-fslc-common_2017.09.inc index 39ecc2cd..6173cda0 100644 --- a/recipes-bsp/u-boot/u-boot-fslc.inc +++ b/recipes-bsp/u-boot/u-boot-fslc-common_2017.09.inc | |||
@@ -1,4 +1,4 @@ | |||
1 | # Copyright (C) 2012-2016 O.S. Systems Software LTDA. | 1 | # Copyright (C) 2012-2017 O.S. Systems Software LTDA. |
2 | # Released under the MIT license (see COPYING.MIT for the terms) | 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
3 | 3 | ||
4 | require recipes-bsp/u-boot/u-boot.inc | 4 | require recipes-bsp/u-boot/u-boot.inc |
@@ -16,19 +16,13 @@ COMPATIBLE_MACHINE = "(mxs|mx5|mx6|mx7|vf|use-mainline-bsp)" | |||
16 | DEPENDS_append = " dtc-native" | 16 | DEPENDS_append = " dtc-native" |
17 | DEPENDS_mxs += "elftosb-native openssl-native" | 17 | DEPENDS_mxs += "elftosb-native openssl-native" |
18 | 18 | ||
19 | PROVIDES += "u-boot" | 19 | SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}" |
20 | 20 | ||
21 | SRCBRANCH ??= "master" | 21 | SRCREV = "9f164a1a01fceb53fc88ad474a5cda70f1c486c2" |
22 | SRCBRANCH = "2017.09+fslc" | ||
22 | 23 | ||
23 | SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}" | 24 | PV = "v2017.09+git${SRCPV}" |
24 | 25 | ||
25 | S = "${WORKDIR}/git" | 26 | S = "${WORKDIR}/git" |
26 | 27 | ||
27 | # FIXME: Allow linking of 'tools' binaries with native libraries | ||
28 | # used for generating the boot logo and other tools used | ||
29 | # during the build process. | ||
30 | EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \ | ||
31 | HOSTLDFLAGS="${BUILD_LDFLAGS}" \ | ||
32 | HOSTSTRIP=true' | ||
33 | |||
34 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 28 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb index 0bbcd084..b67a53ce 100644 --- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb +++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb | |||
@@ -1,20 +1,11 @@ | |||
1 | require u-boot-fslc-common_${PV}.inc | ||
2 | |||
1 | DESCRIPTION = "U-boot bootloader mxsboot tool" | 3 | DESCRIPTION = "U-boot bootloader mxsboot tool" |
2 | LICENSE = "GPLv2+" | ||
3 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" | ||
4 | SECTION = "bootloader" | 4 | SECTION = "bootloader" |
5 | DEPENDS = "openssl" | ||
6 | PROVIDES = "u-boot-mxsboot" | ||
7 | |||
8 | PV = "v2017.09+git${SRCPV}" | ||
9 | 5 | ||
10 | SRCREV = "9f164a1a01fceb53fc88ad474a5cda70f1c486c2" | 6 | DEPENDS_append = " openssl" |
11 | SRCBRANCH = "2017.09+fslc" | ||
12 | 7 | ||
13 | SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}" | 8 | PROVIDES = "u-boot-mxsboot" |
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | inherit fsl-u-boot-localversion | ||
18 | 9 | ||
19 | EXTRA_OEMAKE = 'HOSTCC="${CC} ${CPPFLAGS}" HOSTLDFLAGS="-L${libdir} -L${base_libdir}" HOSTSTRIP=true CONFIG_MX28=y' | 10 | EXTRA_OEMAKE = 'HOSTCC="${CC} ${CPPFLAGS}" HOSTLDFLAGS="-L${libdir} -L${base_libdir}" HOSTSTRIP=true CONFIG_MX28=y' |
20 | 11 | ||
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb b/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb index b3fd47a6..3aff2fa7 100644 --- a/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb +++ b/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb | |||
@@ -1,6 +1,10 @@ | |||
1 | include u-boot-fslc.inc | 1 | require u-boot-fslc-common_${PV}.inc |
2 | 2 | ||
3 | PV = "v2017.09+git${SRCPV}" | 3 | PROVIDES += "u-boot" |
4 | 4 | ||
5 | SRCREV = "9f164a1a01fceb53fc88ad474a5cda70f1c486c2" | 5 | # FIXME: Allow linking of 'tools' binaries with native libraries |
6 | SRCBRANCH = "2017.09+fslc" | 6 | # used for generating the boot logo and other tools used |
7 | # during the build process. | ||
8 | EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \ | ||
9 | HOSTLDFLAGS="${BUILD_LDFLAGS}" \ | ||
10 | HOSTSTRIP=true' | ||