diff options
-rw-r--r-- | recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.4.2.bb | 37 |
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.4.2.bb b/recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.4.2.bb new file mode 100644 index 00000000..35cdbd5f --- /dev/null +++ b/recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.4.2.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | # Copyright (C) 2016 Freescale Semiconductor | ||
2 | # Copyright 2017-2018 NXP | ||
3 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
4 | |||
5 | DESCRIPTION = "G2D graphics library and apps for i.MX with DRM" | ||
6 | LICENSE = "Proprietary" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=75abe2fa1d16ca79f87cde926f05f72d" | ||
8 | |||
9 | RDEPENDS_${PN} = "virtual/libgal-x11 libdrm" | ||
10 | |||
11 | PROVIDES += "virtual/libg2d" | ||
12 | |||
13 | SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true" | ||
14 | |||
15 | S="${WORKDIR}/${PN}-${PV}" | ||
16 | |||
17 | inherit fsl-eula-unpack | ||
18 | |||
19 | SRC_URI[md5sum] = "9beeb2c66f1bad4e82a77487486a31c8" | ||
20 | SRC_URI[sha256sum] = "905e797d7fb573b5fea616940b07dc15d817fe2f5e94668f883e9faaa516989a" | ||
21 | |||
22 | do_install () { | ||
23 | |||
24 | install -d ${D}${libdir} | ||
25 | install -d ${D}${includedir} | ||
26 | |||
27 | cp -r ${S}/g2d/usr/lib/*.so* ${D}${libdir} | ||
28 | cp -Pr ${S}/g2d/usr/include/* ${D}${includedir} | ||
29 | cp -r ${S}/gpu-demos/opt ${D} | ||
30 | } | ||
31 | |||
32 | INSANE_SKIP_${PN} += "ldflags" | ||
33 | |||
34 | FILES_${PN} = "${libdir}/libg2d* /opt" | ||
35 | FILES_${PN}-dev = "${libdir}/libg2d${SOLIBSDEV} ${includedir}" | ||
36 | |||
37 | COMPATIBLE_MACHINE = "(mx8mm)" | ||