diff options
-rw-r--r-- | recipes-kernel/linux/linux-qoriq_4.9.bb | 71 |
1 files changed, 0 insertions, 71 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_4.9.bb b/recipes-kernel/linux/linux-qoriq_4.9.bb deleted file mode 100644 index 04ff7b96..00000000 --- a/recipes-kernel/linux/linux-qoriq_4.9.bb +++ /dev/null | |||
@@ -1,71 +0,0 @@ | |||
1 | inherit kernel qoriq_build_64bit_kernel siteinfo | ||
2 | inherit fsl-kernel-localversion | ||
3 | |||
4 | SUMMARY = "Linux Kernel for Freescale QorIQ platforms" | ||
5 | SECTION = "kernel" | ||
6 | LICENSE = "GPLv2" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" | ||
8 | |||
9 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \ | ||
10 | file://0001-Makefile-fix-gcc-8-build-error.patch \ | ||
11 | " | ||
12 | SRCREV = "e8b01fb24fb8eb1adee9667eba2cae702b5892e9" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | DEPENDS_append = " libgcc" | ||
17 | # not put Images into /boot of rootfs, install kernel-image if needed | ||
18 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base = "" | ||
19 | |||
20 | KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}" | ||
21 | KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}" | ||
22 | KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}" | ||
23 | |||
24 | ZIMAGE_BASE_NAME = "zImage-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}" | ||
25 | ZIMAGE_BASE_NAME[vardepsexclude] = "DATETIME" | ||
26 | |||
27 | SCMVERSION ?= "y" | ||
28 | LOCALVERSION = "" | ||
29 | DELTA_KERNEL_DEFCONFIG ?= "" | ||
30 | DELTA_KERNEL_DEFCONFIG_prepend_qoriq-arm64 = "lsdk.config " | ||
31 | DELTA_KERNEL_DEFCONFIG_prepend_fsl-lsch2-32b = "multi_v7_lpae.config multi_v8.config lsdk.config " | ||
32 | DELTA_KERNEL_DEFCONFIG_prepend_ls102xa = "multi_v7_lpae.config lsdk.config " | ||
33 | |||
34 | do_merge_delta_config[dirs] = "${B}" | ||
35 | |||
36 | do_merge_delta_config() { | ||
37 | # create .config with make config | ||
38 | oe_runmake -C ${S} O=${B} ${KERNEL_DEFCONFIG} | ||
39 | |||
40 | # check if bigendian is enabled | ||
41 | if [ "${SITEINFO_ENDIANNESS}" = "be" ]; then | ||
42 | echo "CONFIG_CPU_BIG_ENDIAN=y" >> .config | ||
43 | echo "CONFIG_MTD_CFI_BE_BYTE_SWAP=y" >> .config | ||
44 | fi | ||
45 | |||
46 | # add config fragments | ||
47 | for deltacfg in ${DELTA_KERNEL_DEFCONFIG}; do | ||
48 | if [ -f ${S}/arch/${ARCH}/configs/${deltacfg} ]; then | ||
49 | oe_runmake -C ${S} O=${B} ${deltacfg} | ||
50 | elif [ -f "${WORKDIR}/${deltacfg}" ]; then | ||
51 | ${S}/scripts/kconfig/merge_config.sh -m .config ${WORKDIR}/${deltacfg} | ||
52 | elif [ -f "${deltacfg}" ]; then | ||
53 | ${S}/scripts/kconfig/merge_config.sh -m .config ${deltacfg} | ||
54 | fi | ||
55 | done | ||
56 | cp .config ${WORKDIR}/defconfig | ||
57 | } | ||
58 | addtask merge_delta_config before do_preconfigure after do_patch | ||
59 | |||
60 | # The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b) | ||
61 | do_compile_prepend_fsl-lsch2-32b() { | ||
62 | ln -sfT ${STAGING_KERNEL_DIR}/arch/arm64/boot/dts/freescale ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale | ||
63 | } | ||
64 | |||
65 | do_install_append_qoriq-arm() { | ||
66 | install -m 0644 arch/${ARCH}/boot/zImage ${D}/boot/zImage-${KERNEL_VERSION} | ||
67 | ln -sf zImage-${KERNEL_VERSION} ${D}/boot/zImage | ||
68 | } | ||
69 | |||
70 | FILES_${KERNEL_PACKAGE_NAME}-image += "/boot/zImage*" | ||
71 | COMPATIBLE_MACHINE = "(qoriq)" | ||