diff options
5 files changed, 0 insertions, 359 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-fix-build-for-opencv-3-4-2.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-fix-build-for-opencv-3-4-2.patch deleted file mode 100644 index 5c53e8e5..00000000 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-fix-build-for-opencv-3-4-2.patch +++ /dev/null | |||
@@ -1,63 +0,0 @@ | |||
1 | From c247745faaf885fd3fa094198fc0ea288e295dbf Mon Sep 17 00:00:00 2001 | ||
2 | From: Thibault Saunier <tsaunier@igalia.com> | ||
3 | Date: Fri, 13 Jul 2018 14:42:28 -0400 | ||
4 | Subject: [PATCH] opencv: Fix build for opencv >= 3.4.2 | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | The `CV_RGB` macro is now in `imgproc.hpp`. | ||
10 | |||
11 | Fixes: | ||
12 | |||
13 | ../subprojects/gst-plugins-bad/ext/opencv/gsthanddetect.cpp:497:40: error: ‘CV_RGB’ was not declared in this scope | ||
14 | cvCircle (img, center, radius, CV_RGB (0, 0, 200), 1, 8, 0); | ||
15 | ^~~~~~ | ||
16 | --- | ||
17 | ext/opencv/MotionCells.cpp | 3 +++ | ||
18 | ext/opencv/gsthanddetect.cpp | 3 +++ | ||
19 | ext/opencv/gsttemplatematch.cpp | 3 +++ | ||
20 | 3 files changed, 9 insertions(+) | ||
21 | |||
22 | diff --git a/ext/opencv/MotionCells.cpp b/ext/opencv/MotionCells.cpp | ||
23 | index f85989e117..175ec901b2 100644 | ||
24 | --- a/ext/opencv/MotionCells.cpp | ||
25 | +++ b/ext/opencv/MotionCells.cpp | ||
26 | @@ -51,6 +51,9 @@ | ||
27 | |||
28 | #include <errno.h> | ||
29 | #include "MotionCells.h" | ||
30 | +#if (CV_MAJOR_VERSION >= 3) | ||
31 | +#include <opencv2/imgproc.hpp> | ||
32 | +#endif | ||
33 | #include <opencv2/imgproc/imgproc_c.h> | ||
34 | |||
35 | MotionCells::MotionCells () | ||
36 | diff --git a/ext/opencv/gsthanddetect.cpp b/ext/opencv/gsthanddetect.cpp | ||
37 | index 60fd5be72b..47203fd0ea 100644 | ||
38 | --- a/ext/opencv/gsthanddetect.cpp | ||
39 | +++ b/ext/opencv/gsthanddetect.cpp | ||
40 | @@ -62,6 +62,9 @@ | ||
41 | |||
42 | /* element header */ | ||
43 | #include "gsthanddetect.h" | ||
44 | +#if (CV_MAJOR_VERSION >= 3) | ||
45 | +#include <opencv2/imgproc.hpp> | ||
46 | +#endif | ||
47 | #include <opencv2/imgproc/imgproc_c.h> | ||
48 | |||
49 | GST_DEBUG_CATEGORY_STATIC (gst_handdetect_debug); | ||
50 | diff --git a/ext/opencv/gsttemplatematch.cpp b/ext/opencv/gsttemplatematch.cpp | ||
51 | index f39208dc28..ec0b56af88 100644 | ||
52 | --- a/ext/opencv/gsttemplatematch.cpp | ||
53 | +++ b/ext/opencv/gsttemplatematch.cpp | ||
54 | @@ -63,6 +63,9 @@ | ||
55 | |||
56 | #include "../../gst-libs/gst/gst-i18n-plugin.h" | ||
57 | #include "gsttemplatematch.h" | ||
58 | +#if (CV_MAJOR_VERSION >= 3) | ||
59 | +#include <opencv2/imgproc.hpp> | ||
60 | +#endif | ||
61 | #include <opencv2/imgproc/imgproc_c.h> | ||
62 | |||
63 | GST_DEBUG_CATEGORY_STATIC (gst_template_match_debug); | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-Fix-build-with-opencv-3.4.5.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-Fix-build-with-opencv-3.4.5.patch deleted file mode 100644 index 4c9cba61..00000000 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-Fix-build-with-opencv-3.4.5.patch +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | From 70661ec35ba7655b52f4043ee7362202bc632472 Mon Sep 17 00:00:00 2001 | ||
2 | From: Vincent Dehors <vincent.dehors@smile.fr> | ||
3 | Date: Mon, 4 Mar 2019 09:01:37 +0100 | ||
4 | Subject: [PATCH] opencv: Fix build with opencv >= 3.4.5 | ||
5 | |||
6 | Including C header imgproc_c.h leads to a compilation error : several | ||
7 | conflicting declartions for cvMoments(). Including the HPP fixes this error | ||
8 | as it is done in other CPP files in the same directory. | ||
9 | |||
10 | Upstream-Status: Inappropriate, code ported to C++ in more recent version | ||
11 | Signed-off-by: Vincent DEHORS <vincent.dehors@smile.fr> | ||
12 | |||
13 | --- | ||
14 | ext/opencv/gstgrabcut.cpp | 9 +++++---- | ||
15 | 1 file changed, 5 insertions(+), 4 deletions(-) | ||
16 | |||
17 | diff --git a/ext/opencv/gstgrabcut.cpp b/ext/opencv/gstgrabcut.cpp | ||
18 | index 4cbc706d5..65b508f20 100644 | ||
19 | --- a/ext/opencv/gstgrabcut.cpp | ||
20 | +++ b/ext/opencv/gstgrabcut.cpp | ||
21 | @@ -85,11 +85,12 @@ | ||
22 | #endif | ||
23 | |||
24 | #include "gstgrabcut.h" | ||
25 | -extern "C" | ||
26 | -{ | ||
27 | + | ||
28 | +#if (CV_MAJOR_VERSION >= 3) | ||
29 | +#include <opencv2/imgproc.hpp> | ||
30 | +#endif | ||
31 | #include <opencv2/imgproc/imgproc_c.h> | ||
32 | -} | ||
33 | -#include <opencv2/imgproc/imgproc.hpp> | ||
34 | + | ||
35 | GST_DEBUG_CATEGORY_STATIC (gst_grabcut_debug); | ||
36 | #define GST_CAT_DEFAULT gst_grabcut_debug | ||
37 | |||
38 | -- | ||
39 | 2.20.1 | ||
40 | |||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base-1.14.imx/0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base-1.14.imx/0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch deleted file mode 100644 index bcada34c..00000000 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base-1.14.imx/0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch +++ /dev/null | |||
@@ -1,167 +0,0 @@ | |||
1 | From 7022b87353a37b78bae7cf0106a4e47913bb5c97 Mon Sep 17 00:00:00 2001 | ||
2 | From: Alexander Kanavin <alex.kanavin@gmail.com> | ||
3 | Date: Thu, 5 Apr 2018 10:15:08 +0800 | ||
4 | Subject: [PATCH] Makefile.am: don't hardcode libtool name when running | ||
5 | introspection tools | ||
6 | |||
7 | Upstream-Status: Pending [review on oe-core maillist] | ||
8 | Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> | ||
9 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
10 | |||
11 | --- | ||
12 | gst-libs/gst/allocators/Makefile.am | 2 +- | ||
13 | gst-libs/gst/app/Makefile.am | 2 +- | ||
14 | gst-libs/gst/audio/Makefile.am | 2 +- | ||
15 | gst-libs/gst/gl/Makefile.am | 2 +- | ||
16 | gst-libs/gst/pbutils/Makefile.am | 2 +- | ||
17 | gst-libs/gst/riff/Makefile.am | 2 +- | ||
18 | gst-libs/gst/rtp/Makefile.am | 2 +- | ||
19 | gst-libs/gst/rtsp/Makefile.am | 2 +- | ||
20 | gst-libs/gst/sdp/Makefile.am | 2 +- | ||
21 | gst-libs/gst/tag/Makefile.am | 2 +- | ||
22 | gst-libs/gst/video/Makefile.am | 2 +- | ||
23 | 11 files changed, 11 insertions(+), 11 deletions(-) | ||
24 | |||
25 | diff --git a/gst-libs/gst/allocators/Makefile.am b/gst-libs/gst/allocators/Makefile.am | ||
26 | index 1957d28..1ecc950 100644 | ||
27 | --- a/gst-libs/gst/allocators/Makefile.am | ||
28 | +++ b/gst-libs/gst/allocators/Makefile.am | ||
29 | @@ -42,7 +42,7 @@ GstAllocators-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstallocators-@ | ||
30 | --add-include-path=`PKG_CONFIG_PATH="$(GST_PKG_CONFIG_PATH)" $(PKG_CONFIG) --variable=girdir gstreamer-@GST_API_VERSION@` \ | ||
31 | --library=libgstallocators-@GST_API_VERSION@.la \ | ||
32 | --include=Gst-@GST_API_VERSION@ \ | ||
33 | - --libtool="$(top_builddir)/libtool" \ | ||
34 | + --libtool="$(LIBTOOL)" \ | ||
35 | --pkg gstreamer-@GST_API_VERSION@ \ | ||
36 | --pkg-export gstreamer-allocators-@GST_API_VERSION@ \ | ||
37 | --output $@ \ | ||
38 | diff --git a/gst-libs/gst/app/Makefile.am b/gst-libs/gst/app/Makefile.am | ||
39 | index 52f6ad3..5bfd606 100644 | ||
40 | --- a/gst-libs/gst/app/Makefile.am | ||
41 | +++ b/gst-libs/gst/app/Makefile.am | ||
42 | @@ -56,7 +56,7 @@ GstApp-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstapp-@GST_API_VERSIO | ||
43 | --library=libgstapp-@GST_API_VERSION@.la \ | ||
44 | --include=Gst-@GST_API_VERSION@ \ | ||
45 | --include=GstBase-@GST_API_VERSION@ \ | ||
46 | - --libtool="$(top_builddir)/libtool" \ | ||
47 | + --libtool="$(LIBTOOL)" \ | ||
48 | --pkg gstreamer-@GST_API_VERSION@ \ | ||
49 | --pkg gstreamer-base-@GST_API_VERSION@ \ | ||
50 | --pkg-export gstreamer-app-@GST_API_VERSION@ \ | ||
51 | diff --git a/gst-libs/gst/audio/Makefile.am b/gst-libs/gst/audio/Makefile.am | ||
52 | index 2922245..7fb65f2 100644 | ||
53 | --- a/gst-libs/gst/audio/Makefile.am | ||
54 | +++ b/gst-libs/gst/audio/Makefile.am | ||
55 | @@ -184,7 +184,7 @@ GstAudio-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstaudio-@GST_API_VE | ||
56 | --include=Gst-@GST_API_VERSION@ \ | ||
57 | --include=GstBase-@GST_API_VERSION@ \ | ||
58 | --include=GstTag-@GST_API_VERSION@ \ | ||
59 | - --libtool="$(top_builddir)/libtool" \ | ||
60 | + --libtool="$(LIBTOOL)" \ | ||
61 | --pkg gstreamer-@GST_API_VERSION@ \ | ||
62 | --pkg gstreamer-base-@GST_API_VERSION@ \ | ||
63 | --pkg-export gstreamer-audio-@GST_API_VERSION@ \ | ||
64 | diff --git a/gst-libs/gst/gl/Makefile.am b/gst-libs/gst/gl/Makefile.am | ||
65 | index 4e77e8c..3276d7f 100644 | ||
66 | --- a/gst-libs/gst/gl/Makefile.am | ||
67 | +++ b/gst-libs/gst/gl/Makefile.am | ||
68 | @@ -193,7 +193,7 @@ GstGL-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstgl-@GST_API_VERSION@ | ||
69 | --include=Gst-@GST_API_VERSION@ \ | ||
70 | --include=GstBase-@GST_API_VERSION@ \ | ||
71 | --include=GstVideo-@GST_API_VERSION@ \ | ||
72 | - --libtool="${LIBTOOL}" \ | ||
73 | + --libtool="$(LIBTOOL)" \ | ||
74 | --pkg gstreamer-@GST_API_VERSION@ \ | ||
75 | --pkg gstreamer-base-@GST_API_VERSION@ \ | ||
76 | --pkg gstreamer-video-@GST_API_VERSION@ \ | ||
77 | diff --git a/gst-libs/gst/pbutils/Makefile.am b/gst-libs/gst/pbutils/Makefile.am | ||
78 | index ae51993..35a6e44 100644 | ||
79 | --- a/gst-libs/gst/pbutils/Makefile.am | ||
80 | +++ b/gst-libs/gst/pbutils/Makefile.am | ||
81 | @@ -103,7 +103,7 @@ GstPbutils-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstpbutils-@GST_AP | ||
82 | --include=GstTag-@GST_API_VERSION@ \ | ||
83 | --include=GstVideo-@GST_API_VERSION@ \ | ||
84 | --include=GstAudio-@GST_API_VERSION@ \ | ||
85 | - --libtool="$(top_builddir)/libtool" \ | ||
86 | + --libtool="$(LIBTOOL)" \ | ||
87 | --pkg gstreamer-@GST_API_VERSION@ \ | ||
88 | --pkg gstreamer-tag-@GST_API_VERSION@ \ | ||
89 | --pkg gstreamer-video-@GST_API_VERSION@ \ | ||
90 | diff --git a/gst-libs/gst/riff/Makefile.am b/gst-libs/gst/riff/Makefile.am | ||
91 | index fb53f06..e66ef4f 100644 | ||
92 | --- a/gst-libs/gst/riff/Makefile.am | ||
93 | +++ b/gst-libs/gst/riff/Makefile.am | ||
94 | @@ -49,7 +49,7 @@ libgstriff_@GST_API_VERSION@_la_LDFLAGS = $(GST_LIB_LDFLAGS) $(GST_ALL_LDFLAGS) | ||
95 | # --include=GstAudio-@GST_API_VERSION@ \ | ||
96 | # --include=GstTag-@GST_API_VERSION@ \ | ||
97 | # --include=Gst-@GST_API_VERSION@ \ | ||
98 | -# --libtool="$(top_builddir)/libtool" \ | ||
99 | +# --libtool="$(LIBTOOL)" \ | ||
100 | # --pkg gstreamer-@GST_API_VERSION@ \ | ||
101 | # --pkg gstreamer-tag-@GST_API_VERSION@ \ | ||
102 | # --pkg gstreamer-audio-@GST_API_VERSION@ \ | ||
103 | diff --git a/gst-libs/gst/rtp/Makefile.am b/gst-libs/gst/rtp/Makefile.am | ||
104 | index a6f971d..77ebeeb 100644 | ||
105 | --- a/gst-libs/gst/rtp/Makefile.am | ||
106 | +++ b/gst-libs/gst/rtp/Makefile.am | ||
107 | @@ -69,7 +69,7 @@ GstRtp-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstrtp-@GST_API_VERSIO | ||
108 | --library=libgstrtp-@GST_API_VERSION@.la \ | ||
109 | --include=Gst-@GST_API_VERSION@ \ | ||
110 | --include=GstBase-@GST_API_VERSION@ \ | ||
111 | - --libtool="$(top_builddir)/libtool" \ | ||
112 | + --libtool="$(LIBTOOL)" \ | ||
113 | --pkg gstreamer-@GST_API_VERSION@ \ | ||
114 | --pkg gstreamer-base-@GST_API_VERSION@ \ | ||
115 | --pkg-export gstreamer-rtp-@GST_API_VERSION@ \ | ||
116 | diff --git a/gst-libs/gst/rtsp/Makefile.am b/gst-libs/gst/rtsp/Makefile.am | ||
117 | index ceb07f4..db9d0fd 100644 | ||
118 | --- a/gst-libs/gst/rtsp/Makefile.am | ||
119 | +++ b/gst-libs/gst/rtsp/Makefile.am | ||
120 | @@ -76,7 +76,7 @@ GstRtsp-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstrtsp-@GST_API_VERS | ||
121 | --include=Gio-2.0 \ | ||
122 | --include=Gst-@GST_API_VERSION@ \ | ||
123 | --include=GstSdp-@GST_API_VERSION@ \ | ||
124 | - --libtool="$(top_builddir)/libtool" \ | ||
125 | + --libtool="$(LIBTOOL)" \ | ||
126 | --pkg gio-2.0 \ | ||
127 | --pkg gstreamer-@GST_API_VERSION@ \ | ||
128 | --pkg gstreamer-sdp-@GST_API_VERSION@ \ | ||
129 | diff --git a/gst-libs/gst/sdp/Makefile.am b/gst-libs/gst/sdp/Makefile.am | ||
130 | index e197e9b..6e05cc7 100644 | ||
131 | --- a/gst-libs/gst/sdp/Makefile.am | ||
132 | +++ b/gst-libs/gst/sdp/Makefile.am | ||
133 | @@ -34,7 +34,7 @@ GstSdp-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstsdp-@GST_API_VERSIO | ||
134 | --add-include-path=`PKG_CONFIG_PATH="$(GST_PKG_CONFIG_PATH)" $(PKG_CONFIG) --variable=girdir gstreamer-@GST_API_VERSION@` \ | ||
135 | --library=libgstsdp-@GST_API_VERSION@.la \ | ||
136 | --include=Gst-@GST_API_VERSION@ \ | ||
137 | - --libtool="$(top_builddir)/libtool" \ | ||
138 | + --libtool="$(LIBTOOL)" \ | ||
139 | --pkg gstreamer-@GST_API_VERSION@ \ | ||
140 | --pkg-export gstreamer-sdp-@GST_API_VERSION@ \ | ||
141 | --output $@ \ | ||
142 | diff --git a/gst-libs/gst/tag/Makefile.am b/gst-libs/gst/tag/Makefile.am | ||
143 | index 0247c33..c86515b 100644 | ||
144 | --- a/gst-libs/gst/tag/Makefile.am | ||
145 | +++ b/gst-libs/gst/tag/Makefile.am | ||
146 | @@ -66,7 +66,7 @@ GstTag-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgsttag-@GST_API_VERSIO | ||
147 | --library=libgsttag-@GST_API_VERSION@.la \ | ||
148 | --include=Gst-@GST_API_VERSION@ \ | ||
149 | --include=GstBase-@GST_API_VERSION@ \ | ||
150 | - --libtool="$(top_builddir)/libtool" \ | ||
151 | + --libtool="$(LIBTOOL)" \ | ||
152 | --pkg gstreamer-@GST_API_VERSION@ \ | ||
153 | --pkg gstreamer-base-@GST_API_VERSION@ \ | ||
154 | --pkg-export gstreamer-tag-@GST_API_VERSION@ \ | ||
155 | diff --git a/gst-libs/gst/video/Makefile.am b/gst-libs/gst/video/Makefile.am | ||
156 | index 9fc1ccf..0f8455f 100644 | ||
157 | --- a/gst-libs/gst/video/Makefile.am | ||
158 | +++ b/gst-libs/gst/video/Makefile.am | ||
159 | @@ -124,7 +124,7 @@ GstVideo-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstvideo-@GST_API_VE | ||
160 | --library=libgstvideo-@GST_API_VERSION@.la \ | ||
161 | --include=Gst-@GST_API_VERSION@ \ | ||
162 | --include=GstBase-@GST_API_VERSION@ \ | ||
163 | - --libtool="$(top_builddir)/libtool" \ | ||
164 | + --libtool="$(LIBTOOL)" \ | ||
165 | --pkg gstreamer-@GST_API_VERSION@ \ | ||
166 | --pkg gstreamer-base-@GST_API_VERSION@ \ | ||
167 | --pkg-export gstreamer-video-@GST_API_VERSION@ \ | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base-1.14.imx/0001-gstreamer1.0-plugins-base-Fix-ion.h-header-inclusion.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base-1.14.imx/0001-gstreamer1.0-plugins-base-Fix-ion.h-header-inclusion.patch deleted file mode 100644 index d3822cfc..00000000 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base-1.14.imx/0001-gstreamer1.0-plugins-base-Fix-ion.h-header-inclusion.patch +++ /dev/null | |||
@@ -1,45 +0,0 @@ | |||
1 | From 84f693a70e6f3084ca67063a6336aaf3287abb49 Mon Sep 17 00:00:00 2001 | ||
2 | From: Yuqing Zhu <carol.zhu@nxp.com> | ||
3 | Date: Thu, 27 Sep 2018 13:53:49 +0800 | ||
4 | Subject: [PATCH] gstreamer1.0-plugins-base: Fix ion.h header inclusion to be | ||
5 | standard | ||
6 | |||
7 | NXP "solution" was to manually copy the header to include/linux. | ||
8 | Let's point the Makefile to the proper (mainline) location instead: | ||
9 | https://elixir.bootlin.com/linux/v4.17/source/drivers/staging/android/uapi/ion.h | ||
10 | |||
11 | Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com> | ||
12 | --- | ||
13 | configure.ac | 2 +- | ||
14 | gst-libs/gst/allocators/gstionmemory.c | 2 +- | ||
15 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
16 | |||
17 | diff --git a/configure.ac b/configure.ac | ||
18 | index 51272df..4bea0dd 100644 | ||
19 | --- a/configure.ac | ||
20 | +++ b/configure.ac | ||
21 | @@ -678,7 +678,7 @@ AG_GST_CHECK_FEATURE(CDPARANOIA, [CDParanoia], cdparanoia, [ | ||
22 | dnl check for ion | ||
23 | translit(dnm, m, l) AM_CONDITIONAL(USE_ION, true) | ||
24 | AG_GST_CHECK_FEATURE(ION, [ion], ion, [ | ||
25 | - AC_CHECK_HEADER(linux/ion.h, HAVE_ION="yes", HAVE_ION="no") | ||
26 | + AC_CHECK_HEADER(ion.h, HAVE_ION="yes", HAVE_ION="no") | ||
27 | ]) | ||
28 | |||
29 | dnl FIXME : add second check somehow if that is necessary | ||
30 | diff --git a/gst-libs/gst/allocators/gstionmemory.c b/gst-libs/gst/allocators/gstionmemory.c | ||
31 | index 5e0455c..a285f09 100644 | ||
32 | --- a/gst-libs/gst/allocators/gstionmemory.c | ||
33 | +++ b/gst-libs/gst/allocators/gstionmemory.c | ||
34 | @@ -26,7 +26,7 @@ | ||
35 | #include <sys/ioctl.h> | ||
36 | #include <sys/mman.h> | ||
37 | #include <sys/types.h> | ||
38 | -#include <linux/ion.h> | ||
39 | +#include <ion.h> | ||
40 | #include <linux/dma-buf.h> | ||
41 | #include <linux/version.h> | ||
42 | |||
43 | -- | ||
44 | 1.9.1 | ||
45 | |||
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0001-imx-gst1.0-plugin-Fix-ion.h-header-inclusion-to-be-s.patch b/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0001-imx-gst1.0-plugin-Fix-ion.h-header-inclusion-to-be-s.patch deleted file mode 100644 index 4e861a5d..00000000 --- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin/0001-imx-gst1.0-plugin-Fix-ion.h-header-inclusion-to-be-s.patch +++ /dev/null | |||
@@ -1,44 +0,0 @@ | |||
1 | From e4c96421700ecd008814bceceaf03f0ee9323c02 Mon Sep 17 00:00:00 2001 | ||
2 | From: Yuqing Zhu <carol.zhu@nxp.com> | ||
3 | Date: Thu, 27 Sep 2018 16:00:55 +0800 | ||
4 | Subject: [PATCH] imx-gst1.0-plugin: Fix ion.h header inclusion to be standard | ||
5 | |||
6 | NXP "solution" was to manually copy the header to include/linux. | ||
7 | Let's point the Makefile to the proper (mainline) location instead: | ||
8 | https://elixir.bootlin.com/linux/v4.17/source/drivers/staging/android/uapi/ion.h | ||
9 | |||
10 | Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com> | ||
11 | --- | ||
12 | configure.ac | 2 +- | ||
13 | libs/gstimxcommon.c | 2 +- | ||
14 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/configure.ac b/configure.ac | ||
17 | index 7b2709d..d94e3a8 100755 | ||
18 | --- a/configure.ac | ||
19 | +++ b/configure.ac | ||
20 | @@ -216,7 +216,7 @@ dnl check ion allocator headfile | ||
21 | old_CFLAGS=$CFLAGS | ||
22 | PKG_CHECK_MODULES(GST, gstreamer-$GST_MAJORMINOR >= 1.14, CFLAGS="$CFLAGS `$PKG_CONFIG --cflags gstreamer-allocators-1.0`",\ | ||
23 | CFLAGS="$CFLAGS `$PKG_CONFIG --cflags gstreamer-bad-allocators-1.0`") | ||
24 | -AC_CHECK_HEADERS([linux/ion.h gst/allocators/gstionmemory.h], HAVE_ION="yes", HAVE_ION="no") | ||
25 | +AC_CHECK_HEADERS([ion.h gst/allocators/gstionmemory.h], HAVE_ION="yes", HAVE_ION="no") | ||
26 | AM_CONDITIONAL(USE_ION, test "x$HAVE_ION" = "xyes") | ||
27 | CFLAGS=$old_CFLAGS | ||
28 | |||
29 | diff --git a/libs/gstimxcommon.c b/libs/gstimxcommon.c | ||
30 | index eb808b9..c02ab5f 100644 | ||
31 | --- a/libs/gstimxcommon.c | ||
32 | +++ b/libs/gstimxcommon.c | ||
33 | @@ -26,7 +26,7 @@ | ||
34 | #include <linux/version.h> | ||
35 | #include <linux/dma-buf.h> | ||
36 | #ifdef USE_ION | ||
37 | -#include <linux/ion.h> | ||
38 | +#include <ion.h> | ||
39 | #endif | ||
40 | const char *dev_ion = "/dev/ion"; | ||
41 | |||
42 | -- | ||
43 | 1.9.1 | ||
44 | |||