diff options
-rw-r--r-- | meta-fsl-ppc/recipes-bsp/u-boot/files/0001-u-boot-mpc85xx-u-boot-.lds-remove-_GLOBAL_OFFSET_TAB.patch | 77 | ||||
-rw-r--r-- | meta-fsl-ppc/recipes-bsp/u-boot/u-boot-qoriq_2014.07.bb | 3 |
2 files changed, 79 insertions, 1 deletions
diff --git a/meta-fsl-ppc/recipes-bsp/u-boot/files/0001-u-boot-mpc85xx-u-boot-.lds-remove-_GLOBAL_OFFSET_TAB.patch b/meta-fsl-ppc/recipes-bsp/u-boot/files/0001-u-boot-mpc85xx-u-boot-.lds-remove-_GLOBAL_OFFSET_TAB.patch new file mode 100644 index 00000000..e6b8d2e5 --- /dev/null +++ b/meta-fsl-ppc/recipes-bsp/u-boot/files/0001-u-boot-mpc85xx-u-boot-.lds-remove-_GLOBAL_OFFSET_TAB.patch | |||
@@ -0,0 +1,77 @@ | |||
1 | From 9ba002f1b1afc7af84a352f4ecab32a30d7ba353 Mon Sep 17 00:00:00 2001 | ||
2 | From: Zhenhua Luo <zhenhua.luo@freescale.com> | ||
3 | Date: Mon, 9 Feb 2015 18:33:56 +0800 | ||
4 | Subject: [PATCH] u-boot/mpc85xx/u-boot*.lds: remove _GLOBAL_OFFSET_TABLE_ | ||
5 | definition | ||
6 | |||
7 | In binutils-2.25, the _GLOBAL_OFFSET_TABLE_ symbols defined by PROVIDE in | ||
8 | u-boot.lds overrides the linker built-in symbols | ||
9 | (https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=commitdiff;h=b893397a4b1316610f49819344817715e4305de9), | ||
10 | so the linker is treating _GLOBAL_OFFSET_TABLE_ as a definition into the .reloc section. | ||
11 | |||
12 | To align with the change of binutils-2.25, the _GLOBAL_OFFSET_TABLE_ symbol | ||
13 | should not be defined in sections, and the symbols in linker generated .got | ||
14 | section should be used(https://sourceware.org/ml/binutils/2008-09/msg00122.html). | ||
15 | |||
16 | Fixed the following build errors with binutils-2.25: | ||
17 | | powerpc-poky-linux-gnuspe-ld.bfd: _GLOBAL_OFFSET_TABLE_ not defined in linker created .got | ||
18 | |||
19 | Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com> | ||
20 | --- | ||
21 | arch/powerpc/cpu/mpc85xx/u-boot-nand.lds | 1 - | ||
22 | arch/powerpc/cpu/mpc85xx/u-boot-nand_spl.lds | 1 - | ||
23 | arch/powerpc/cpu/mpc85xx/u-boot-spl.lds | 1 - | ||
24 | arch/powerpc/cpu/mpc85xx/u-boot.lds | 1 - | ||
25 | 4 files changed, 4 deletions(-) | ||
26 | |||
27 | diff --git a/arch/powerpc/cpu/mpc85xx/u-boot-nand.lds b/arch/powerpc/cpu/mpc85xx/u-boot-nand.lds | ||
28 | index f933b21..0399f93 100644 | ||
29 | --- a/arch/powerpc/cpu/mpc85xx/u-boot-nand.lds | ||
30 | +++ b/arch/powerpc/cpu/mpc85xx/u-boot-nand.lds | ||
31 | @@ -44,7 +44,6 @@ SECTIONS | ||
32 | _GOT2_TABLE_ = .; | ||
33 | KEEP(*(.got2)) | ||
34 | KEEP(*(.got)) | ||
35 | - PROVIDE(_GLOBAL_OFFSET_TABLE_ = . + 4); | ||
36 | _FIXUP_TABLE_ = .; | ||
37 | KEEP(*(.fixup)) | ||
38 | } | ||
39 | diff --git a/arch/powerpc/cpu/mpc85xx/u-boot-nand_spl.lds b/arch/powerpc/cpu/mpc85xx/u-boot-nand_spl.lds | ||
40 | index b83c553..f044564 100644 | ||
41 | --- a/arch/powerpc/cpu/mpc85xx/u-boot-nand_spl.lds | ||
42 | +++ b/arch/powerpc/cpu/mpc85xx/u-boot-nand_spl.lds | ||
43 | @@ -22,7 +22,6 @@ SECTIONS | ||
44 | _GOT2_TABLE_ = .; | ||
45 | KEEP(*(.got2)) | ||
46 | KEEP(*(.got)) | ||
47 | - PROVIDE(_GLOBAL_OFFSET_TABLE_ = . + 4); | ||
48 | _FIXUP_TABLE_ = .; | ||
49 | KEEP(*(.fixup)) | ||
50 | } | ||
51 | diff --git a/arch/powerpc/cpu/mpc85xx/u-boot-spl.lds b/arch/powerpc/cpu/mpc85xx/u-boot-spl.lds | ||
52 | index 5ae7b3e..889a4c2 100644 | ||
53 | --- a/arch/powerpc/cpu/mpc85xx/u-boot-spl.lds | ||
54 | +++ b/arch/powerpc/cpu/mpc85xx/u-boot-spl.lds | ||
55 | @@ -29,7 +29,6 @@ SECTIONS | ||
56 | _GOT2_TABLE_ = .; | ||
57 | KEEP(*(.got2)) | ||
58 | KEEP(*(.got)) | ||
59 | - PROVIDE(_GLOBAL_OFFSET_TABLE_ = . + 4); | ||
60 | _FIXUP_TABLE_ = .; | ||
61 | KEEP(*(.fixup)) | ||
62 | } | ||
63 | diff --git a/arch/powerpc/cpu/mpc85xx/u-boot.lds b/arch/powerpc/cpu/mpc85xx/u-boot.lds | ||
64 | index 2cf0b25..f15eaf3 100644 | ||
65 | --- a/arch/powerpc/cpu/mpc85xx/u-boot.lds | ||
66 | +++ b/arch/powerpc/cpu/mpc85xx/u-boot.lds | ||
67 | @@ -50,7 +50,6 @@ SECTIONS | ||
68 | _GOT2_TABLE_ = .; | ||
69 | KEEP(*(.got2)) | ||
70 | KEEP(*(.got)) | ||
71 | - PROVIDE(_GLOBAL_OFFSET_TABLE_ = . + 4); | ||
72 | _FIXUP_TABLE_ = .; | ||
73 | KEEP(*(.fixup)) | ||
74 | } | ||
75 | -- | ||
76 | 2.1.0 | ||
77 | |||
diff --git a/meta-fsl-ppc/recipes-bsp/u-boot/u-boot-qoriq_2014.07.bb b/meta-fsl-ppc/recipes-bsp/u-boot/u-boot-qoriq_2014.07.bb index b7806584..3e519e2f 100644 --- a/meta-fsl-ppc/recipes-bsp/u-boot/u-boot-qoriq_2014.07.bb +++ b/meta-fsl-ppc/recipes-bsp/u-boot/u-boot-qoriq_2014.07.bb | |||
@@ -17,7 +17,8 @@ DEPENDS = "boot-format-native libgcc ${@base_contains('TCMODE', 'external-fsl', | |||
17 | 17 | ||
18 | inherit deploy | 18 | inherit deploy |
19 | 19 | ||
20 | SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;nobranch=1" | 20 | SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;nobranch=1 \ |
21 | file://0001-u-boot-mpc85xx-u-boot-.lds-remove-_GLOBAL_OFFSET_TAB.patch" | ||
21 | SRCREV = "659b6a23a8b1f3026200bc6352dbacef53f4dcb1" | 22 | SRCREV = "659b6a23a8b1f3026200bc6352dbacef53f4dcb1" |
22 | 23 | ||
23 | python () { | 24 | python () { |