diff options
-rw-r--r-- | recipes-bsp/rcw/ls2-rcw_git.bb | 32 |
1 files changed, 0 insertions, 32 deletions
diff --git a/recipes-bsp/rcw/ls2-rcw_git.bb b/recipes-bsp/rcw/ls2-rcw_git.bb deleted file mode 100644 index ceb8bd63..00000000 --- a/recipes-bsp/rcw/ls2-rcw_git.bb +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | SUMMARY = "Reset Configuration Word" | ||
2 | DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets" | ||
3 | LICENSE = "BSD" | ||
4 | LIC_FILES_CHKSUM = "file://BSD-LICENSE;md5=627727dce58484c4bd5f9b19665d81b3" | ||
5 | |||
6 | inherit deploy siteinfo | ||
7 | |||
8 | INHIBIT_DEFAULT_DEPS = "1" | ||
9 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
10 | |||
11 | SRC_URI = "git://github.com/qoriq-open-source/rcw.git;nobranch=1" | ||
12 | SRCREV = "bfe8c5eb72cbae387af1c8662957caa801c2309f" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | M="${@d.getVar('MACHINE', True).replace('-64b','').replace('-32b','').replace('-${SITEINFO_ENDIANNESS}','')}" | ||
17 | |||
18 | do_install () { | ||
19 | install -d ${D}/boot/rcw | ||
20 | cp -a ${S}/${M} ${D}/boot/rcw/ | ||
21 | chown -R root:root ${D} | ||
22 | } | ||
23 | |||
24 | do_deploy () { | ||
25 | install -d ${DEPLOYDIR}/rcw | ||
26 | cp -a ${S}/${M} ${DEPLOYDIR}/rcw/ | ||
27 | } | ||
28 | addtask deploy before do_build after do_install | ||
29 | |||
30 | PACKAGES += "${PN}-image" | ||
31 | FILES_${PN}-image += "/boot" | ||
32 | COMPATIBLE_MACHINE = "(ls1012a|ls2080a|ls2088a|ls1088a)" | ||