diff options
-rw-r--r-- | conf/machine/imx8mmevk.conf | 1 | ||||
-rw-r--r-- | conf/machine/imx8mqevk.conf | 1 | ||||
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-boot_0.2.bb | 9 |
3 files changed, 0 insertions, 11 deletions
diff --git a/conf/machine/imx8mmevk.conf b/conf/machine/imx8mmevk.conf index 82001101..44b3249f 100644 --- a/conf/machine/imx8mmevk.conf +++ b/conf/machine/imx8mmevk.conf | |||
@@ -19,7 +19,6 @@ KERNEL_DEVICETREE += "freescale/fsl-imx8mm-evk-m4.dtb " | |||
19 | KERNEL_DEVICETREE += "freescale/fsl-imx8mm-evk-rm67191.dtb " | 19 | KERNEL_DEVICETREE += "freescale/fsl-imx8mm-evk-rm67191.dtb " |
20 | KERNEL_DEVICETREE += "freescale/fsl-imx8mm-evk-root.dtb" | 20 | KERNEL_DEVICETREE += "freescale/fsl-imx8mm-evk-root.dtb" |
21 | 21 | ||
22 | IMAGE_BOOTFILES_DEPENDS += "imx-m4-demos:do_deploy" | ||
23 | IMAGE_BOOTFILES += "imx8mm_m4_TCM_hello_world.bin \ | 22 | IMAGE_BOOTFILES += "imx8mm_m4_TCM_hello_world.bin \ |
24 | imx8mm_m4_TCM_rpmsg_lite_pingpong_rtos_linux_remote.bin \ | 23 | imx8mm_m4_TCM_rpmsg_lite_pingpong_rtos_linux_remote.bin \ |
25 | imx8mm_m4_TCM_rpmsg_lite_str_echo_rtos.bin \ | 24 | imx8mm_m4_TCM_rpmsg_lite_str_echo_rtos.bin \ |
diff --git a/conf/machine/imx8mqevk.conf b/conf/machine/imx8mqevk.conf index f3280b9c..96f12203 100644 --- a/conf/machine/imx8mqevk.conf +++ b/conf/machine/imx8mqevk.conf | |||
@@ -21,7 +21,6 @@ KERNEL_DEVICETREE += "freescale/fsl-imx8mq-evk-lcdif-adv7535.dtb" | |||
21 | KERNEL_DEVICETREE += "freescale/fsl-imx8mq-evk-m4.dtb freescale/fsl-imx8mq-evk-mipi-csi2.dtb" | 21 | KERNEL_DEVICETREE += "freescale/fsl-imx8mq-evk-m4.dtb freescale/fsl-imx8mq-evk-mipi-csi2.dtb" |
22 | KERNEL_DEVICETREE += "freescale/fsl-imx8mq-evk-pcie1-m2.dtb freescale/fsl-imx8mq-evk-pdm.dtb" | 22 | KERNEL_DEVICETREE += "freescale/fsl-imx8mq-evk-pcie1-m2.dtb freescale/fsl-imx8mq-evk-pdm.dtb" |
23 | 23 | ||
24 | IMAGE_BOOTFILES_DEPENDS += "imx-m4-demos:do_deploy" | ||
25 | IMAGE_BOOTFILES += "imx8mq_m4_TCM_hello_world.bin imx8mq_m4_TCM_rpmsg_lite_pingpong_rtos_linux_remote.bin imx8mq_m4_TCM_rpmsg_lite_str_echo_rtos.bin" | 24 | IMAGE_BOOTFILES += "imx8mq_m4_TCM_hello_world.bin imx8mq_m4_TCM_rpmsg_lite_pingpong_rtos_linux_remote.bin imx8mq_m4_TCM_rpmsg_lite_str_echo_rtos.bin" |
26 | 25 | ||
27 | UBOOT_CONFIG ??= "sd" | 26 | UBOOT_CONFIG ??= "sd" |
diff --git a/recipes-bsp/imx-mkimage/imx-boot_0.2.bb b/recipes-bsp/imx-mkimage/imx-boot_0.2.bb index b232ed52..7bd50312 100644 --- a/recipes-bsp/imx-mkimage/imx-boot_0.2.bb +++ b/recipes-bsp/imx-mkimage/imx-boot_0.2.bb | |||
@@ -25,21 +25,12 @@ inherit deploy | |||
25 | # Add CFLAGS with native INCDIR & LIBDIR for imx-mkimage build | 25 | # Add CFLAGS with native INCDIR & LIBDIR for imx-mkimage build |
26 | CFLAGS = "-O2 -Wall -std=c99 -static -I ${STAGING_INCDIR_NATIVE} -L ${STAGING_LIBDIR_NATIVE}" | 26 | CFLAGS = "-O2 -Wall -std=c99 -static -I ${STAGING_INCDIR_NATIVE} -L ${STAGING_LIBDIR_NATIVE}" |
27 | 27 | ||
28 | # For i.MX 8, this package aggregates the imx-m4-demos | ||
29 | # output. Note that this aggregation replaces the aggregation | ||
30 | # that would otherwise be done in the image build as controlled | ||
31 | # by IMAGE_BOOTFILES_DEPENDS and IMAGE_BOOTFILES in image_types_fsl.bbclass | ||
32 | IMX_M4_DEMOS = "" | ||
33 | IMX_M4_DEMOS_mx8qm = "imx-m4-demos:do_deploy" | ||
34 | IMX_M4_DEMOS_mx8qxp = "imx-m4-demos:do_deploy" | ||
35 | |||
36 | # This package aggregates output deployed by other packages, | 28 | # This package aggregates output deployed by other packages, |
37 | # so set the appropriate dependencies | 29 | # so set the appropriate dependencies |
38 | do_compile[depends] += " \ | 30 | do_compile[depends] += " \ |
39 | virtual/bootloader:do_deploy \ | 31 | virtual/bootloader:do_deploy \ |
40 | ${@' '.join('%s:do_deploy' % r for r in '${IMX_EXTRA_FIRMWARE}'.split() )} \ | 32 | ${@' '.join('%s:do_deploy' % r for r in '${IMX_EXTRA_FIRMWARE}'.split() )} \ |
41 | imx-atf:do_deploy \ | 33 | imx-atf:do_deploy \ |
42 | ${IMX_M4_DEMOS} \ | ||
43 | " | 34 | " |
44 | 35 | ||
45 | SC_FIRMWARE_NAME ?= "scfw_tcm.bin" | 36 | SC_FIRMWARE_NAME ?= "scfw_tcm.bin" |