diff options
-rw-r--r-- | recipes-bsp/imx-test/imx-test/0001-mxc_v4l2_test-fix-compilation-error-produced-by-gcc9.patch | 39 | ||||
-rw-r--r-- | recipes-bsp/imx-test/imx-test_git.bb | 5 |
2 files changed, 42 insertions, 2 deletions
diff --git a/recipes-bsp/imx-test/imx-test/0001-mxc_v4l2_test-fix-compilation-error-produced-by-gcc9.patch b/recipes-bsp/imx-test/imx-test/0001-mxc_v4l2_test-fix-compilation-error-produced-by-gcc9.patch new file mode 100644 index 00000000..3fb9d4ef --- /dev/null +++ b/recipes-bsp/imx-test/imx-test/0001-mxc_v4l2_test-fix-compilation-error-produced-by-gcc9.patch | |||
@@ -0,0 +1,39 @@ | |||
1 | From d2e35983281a811b38e540ab82e7643322e84aab Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | ||
3 | Date: Wed, 4 Dec 2019 14:17:50 +0000 | ||
4 | Subject: [PATCH] mxc_v4l2_test: fix compilation error produced by gcc9 | ||
5 | |||
6 | Fix trivial compilation error when GCC9 is used: | ||
7 | |||
8 | error: call to '__open_missing_mode' declared with attribute error: open | ||
9 | with O_CREAT or O_TMPFILE in second argument needs 3 arguments | ||
10 | |||
11 | This is now caused by not explicitly supplying the mode when O_CREAT is | ||
12 | used as disposition. | ||
13 | |||
14 | Upstream-Status: Pending | ||
15 | |||
16 | Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | ||
17 | --- | ||
18 | test/mxc_v4l2_test/mx8_v4l2_cap_drm.c | 4 ---- | ||
19 | 1 file changed, 4 deletions(-) | ||
20 | |||
21 | diff --git a/test/mxc_v4l2_test/mx8_v4l2_cap_drm.c b/test/mxc_v4l2_test/mx8_v4l2_cap_drm.c | ||
22 | index 6e10744..d63b2db 100644 | ||
23 | --- a/test/mxc_v4l2_test/mx8_v4l2_cap_drm.c | ||
24 | +++ b/test/mxc_v4l2_test/mx8_v4l2_cap_drm.c | ||
25 | @@ -561,11 +561,7 @@ static int open_save_file(struct video_channel *video_ch) | ||
26 | |||
27 | for (i = 0; i < NUM_SENSORS; i++) { | ||
28 | if ((g_cam >> i) & 0x01) { | ||
29 | -#ifdef BUILD_FOR_ANDROID | ||
30 | fd = open(video_ch[i].save_file_name, O_RDWR | O_CREAT, 0660); | ||
31 | -#else | ||
32 | - fd = open(video_ch[i].save_file_name, O_RDWR | O_CREAT); | ||
33 | -#endif | ||
34 | if (fd < 0) { | ||
35 | v4l2_err("Channel[%d] unable to create recording file\n", i); | ||
36 | while (i) | ||
37 | -- | ||
38 | 2.17.1 | ||
39 | |||
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb index 084a2b04..184ee406 100644 --- a/recipes-bsp/imx-test/imx-test_git.bb +++ b/recipes-bsp/imx-test/imx-test_git.bb | |||
@@ -16,12 +16,13 @@ DEPENDS_append_imxvpu = " virtual/imxvpu" | |||
16 | PE = "1" | 16 | PE = "1" |
17 | PV = "7.0+${SRCPV}" | 17 | PV = "7.0+${SRCPV}" |
18 | 18 | ||
19 | SRCBRANCH = "imx_4.14.98_2.0.0_ga" | 19 | SRCBRANCH = "imx_4.19.35_1.1.0" |
20 | SRC_URI = " \ | 20 | SRC_URI = " \ |
21 | git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \ | 21 | git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \ |
22 | file://0001-mxc_v4l2_test-fix-compilation-error-produced-by-gcc9.patch \ | ||
22 | file://memtool_profile \ | 23 | file://memtool_profile \ |
23 | " | 24 | " |
24 | SRCREV = "d32727a9d7ef2543729c149a713db24b8f5c2aa8" | 25 | SRCREV = "709d14b037e7a45af018875c4a880f8f9c198288" |
25 | S = "${WORKDIR}/git" | 26 | S = "${WORKDIR}/git" |
26 | 27 | ||
27 | inherit module-base use-imx-headers | 28 | inherit module-base use-imx-headers |