diff options
3 files changed, 54 insertions, 42 deletions
diff --git a/recipes-bsp/isp-imx/isp-imx/0001-start_isp.sh-fix-NR_DEVICE_TREE_BASLER-variable.patch b/recipes-bsp/isp-imx/isp-imx/0001-start_isp.sh-fix-NR_DEVICE_TREE_BASLER-variable.patch new file mode 100644 index 00000000..950098cd --- /dev/null +++ b/recipes-bsp/isp-imx/isp-imx/0001-start_isp.sh-fix-NR_DEVICE_TREE_BASLER-variable.patch | |||
@@ -0,0 +1,53 @@ | |||
1 | From 9c65e20b82cfd9e82b849b3140eec7b8c18922dc Mon Sep 17 00:00:00 2001 | ||
2 | From: Chris Dimich <Chris.Dimich@boundarydevices.com> | ||
3 | Date: Mon, 13 Sep 2021 17:56:02 -0700 | ||
4 | Subject: [PATCH 1/1] start_isp.sh: fix NR_DEVICE_TREE_BASLER variable | ||
5 | |||
6 | Also remove uneeded -lm option from run.sh script. | ||
7 | |||
8 | Signed-off-by: Chris Dimich <Chris.Dimich@boundarydevices.com> | ||
9 | --- | ||
10 | imx/start_isp.sh | 8 ++++---- | ||
11 | 1 file changed, 4 insertions(+), 4 deletions(-) | ||
12 | |||
13 | diff --git a/imx/start_isp.sh b/imx/start_isp.sh | ||
14 | index 6daabc59c..250226935 100755 | ||
15 | --- a/imx/start_isp.sh | ||
16 | +++ b/imx/start_isp.sh | ||
17 | @@ -7,7 +7,7 @@ | ||
18 | # | ||
19 | |||
20 | RUNTIME_DIR="$( cd "$(dirname "$0")" >/dev/null 2>&1 ; pwd -P )" | ||
21 | -NR_DEVICE_TREE_BASLER=$(grep basler-camera-vvcam /sys/firmware/devicetree/base/soc@0/*/i2c@*/*/compatible -l | wc -l 2> /dev/null) | ||
22 | +NR_DEVICE_TREE_BASLER=$(grep basler-camera-vvcam `find /sys/firmware/devicetree/base/soc@0/ -name compatible | grep i2c` -l | wc -l 2> /dev/null) | ||
23 | NR_DEVICE_TREE_OV5640=$(grep ov5640 /sys/firmware/devicetree/base/soc@0/*/i2c@*/*/compatible -l | wc -l 2> /dev/null) | ||
24 | |||
25 | # check if the basler device has been enabled in the device tree | ||
26 | @@ -21,13 +21,13 @@ if [ $NR_DEVICE_TREE_BASLER -eq 1 ]; then | ||
27 | |||
28 | # Default configuration for Basler daA3840-30mc: basler_4k | ||
29 | # Available configurations: basler_4k, basler_1080p60, basler_4khdr, basler_1080p60hdr | ||
30 | - exec ./run.sh -c basler_4k -lm | ||
31 | + exec ./run.sh -c basler_4k | ||
32 | |||
33 | elif [ $NR_DEVICE_TREE_OV5640 -eq 1 ]; then | ||
34 | |||
35 | # Default configuration for Basler daA3840-30mc: basler_1080p60 | ||
36 | # Available configurations: basler_1080p60, basler_1080p60hdr | ||
37 | - exec ./run.sh -c basler_1080p60 -lm | ||
38 | + exec ./run.sh -c basler_1080p60 | ||
39 | |||
40 | fi | ||
41 | |||
42 | @@ -38,7 +38,7 @@ elif [ $NR_DEVICE_TREE_BASLER -eq 2 ]; then | ||
43 | cd $RUNTIME_DIR | ||
44 | # Default configuration for Basler daA3840-30mc: dual_basler_1080p60 | ||
45 | # Available configurations: dual_basler_1080p60, dual_basler_1080p60hdr, dual_basler_1080p25hdr | ||
46 | - exec ./run.sh -c dual_basler_1080p60 -lm | ||
47 | + exec ./run.sh -c dual_basler_1080p60 | ||
48 | |||
49 | else | ||
50 | # no device tree found exit with code no device or address | ||
51 | -- | ||
52 | 2.31.1 | ||
53 | |||
diff --git a/recipes-bsp/isp-imx/isp-imx/0001-start_isp.sh-fix-test-to-be-generic.patch b/recipes-bsp/isp-imx/isp-imx/0001-start_isp.sh-fix-test-to-be-generic.patch deleted file mode 100644 index be2e1c61..00000000 --- a/recipes-bsp/isp-imx/isp-imx/0001-start_isp.sh-fix-test-to-be-generic.patch +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | From 708f25cfe522df162c3e2c7c56cbe2f7000cb5e4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Gary Bisson <gary.bisson@boundarydevices.com> | ||
3 | Date: Mon, 14 Dec 2020 14:26:01 +0100 | ||
4 | Subject: [PATCH] start_isp.sh: fix test to be generic | ||
5 | |||
6 | So that it works on EVK and any other i.MX 8M Plus platform. | ||
7 | |||
8 | Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com> | ||
9 | --- | ||
10 | imx/start_isp.sh | 13 +++++-------- | ||
11 | 1 file changed, 5 insertions(+), 8 deletions(-) | ||
12 | |||
13 | Index: isp-imx-4.2.2.13.0/imx/start_isp.sh | ||
14 | =================================================================== | ||
15 | --- isp-imx-4.2.2.13.0.orig/imx/start_isp.sh | ||
16 | +++ isp-imx-4.2.2.13.0/imx/start_isp.sh | ||
17 | @@ -9,6 +9,7 @@ | ||
18 | RUNTIME_DIR="$( cd "$(dirname "$0")" >/dev/null 2>&1 ; pwd -P )" | ||
19 | NR_DEVICE_TREE_BASLER=$(grep basler-camera-vvcam /sys/firmware/devicetree/base/soc@0/*/i2c@*/*/compatible -l | wc -l 2> /dev/null) | ||
20 | NR_DEVICE_TREE_OV5640=$(grep ov5640 /sys/firmware/devicetree/base/soc@0/*/i2c@*/*/compatible -l | wc -l 2> /dev/null) | ||
21 | +DMESG_BASLER=`dmesg | grep Basler` | ||
22 | |||
23 | # check if the basler device has been enabled in the device tree | ||
24 | if [ $NR_DEVICE_TREE_BASLER -eq 1 ]; then | ||
25 | @@ -40,8 +41,15 @@ elif [ $NR_DEVICE_TREE_BASLER -eq 2 ]; t | ||
26 | # Available configurations: dual_basler_1080p60, dual_basler_1080p60hdr, dual_basler_1080p25hdr | ||
27 | exec ./run.sh -c dual_basler_1080p60 -lm | ||
28 | |||
29 | +elif [ ! -z "$DMESG_BASLER" ]; then | ||
30 | + | ||
31 | + echo "Starting isp_media_server for generic Basler" | ||
32 | + | ||
33 | + cd $RUNTIME_DIR | ||
34 | + exec ./run.sh -c basler_1080p60 | ||
35 | + | ||
36 | else | ||
37 | # no device tree found exit with code no device or address | ||
38 | - echo "No device tree found for Basler, check dtb file!" >&2 | ||
39 | + echo "Basler camera not found!" >&2 | ||
40 | exit 6 | ||
41 | fi | ||
diff --git a/recipes-bsp/isp-imx/isp-imx_4.2.2.13.0.bb b/recipes-bsp/isp-imx/isp-imx_4.2.2.13.0.bb index a6286cf3..b15d0b9e 100644 --- a/recipes-bsp/isp-imx/isp-imx_4.2.2.13.0.bb +++ b/recipes-bsp/isp-imx/isp-imx_4.2.2.13.0.bb | |||
@@ -7,7 +7,7 @@ DEPENDS = "python3 libdrm virtual/libg2d" | |||
7 | 7 | ||
8 | SRC_URI = " \ | 8 | SRC_URI = " \ |
9 | ${FSL_MIRROR}/${BP}.bin;fsl-eula=true \ | 9 | ${FSL_MIRROR}/${BP}.bin;fsl-eula=true \ |
10 | file://0001-start_isp.sh-fix-test-to-be-generic.patch \ | 10 | file://0001-start_isp.sh-fix-NR_DEVICE_TREE_BASLER-variable.patch \ |
11 | file://0001-isp-imx-drop-use-of-__TIME__-__DATE__.patch \ | 11 | file://0001-isp-imx-drop-use-of-__TIME__-__DATE__.patch \ |
12 | " | 12 | " |
13 | 13 | ||