diff options
-rw-r--r-- | recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.13.1.bb | 71 | ||||
-rw-r--r-- | recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb | 62 |
2 files changed, 62 insertions, 71 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.13.1.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.13.1.bb deleted file mode 100644 index 35996337..00000000 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.13.1.bb +++ /dev/null | |||
@@ -1,71 +0,0 @@ | |||
1 | # Copyright (C) 2018 O.S. Systems Software LTDA. | ||
2 | DESCRIPTION = "GStreamer 1.0 plugins for i.MX platforms" | ||
3 | LICENSE = "LGPLv2+" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605" | ||
5 | SECTION = "multimedia" | ||
6 | # gstreamer1.0-plugins-bad is in DEPENDS because the build script scans for the | ||
7 | # GstPhotography headers and libraries | ||
8 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad" | ||
9 | # add the audioparsers and the videoparsersbad plugins as RDEPENDS ; audioparsers | ||
10 | # for the uniaudio decoder, videoparsersbad for the VPU video decoder | ||
11 | # the gstreamer1.0-plugins-imx RDEPENDS is necessary to ensure the -good recipe is | ||
12 | # build (it is not a compile-time dependency however, hence RDEPENDS and not DEPENDS) | ||
13 | RDEPENDS_gstreamer1.0-plugins-imx = "gstreamer1.0-plugins-good" | ||
14 | RDEPENDS_gstreamer1.0-plugins-imx-imxaudio = "gstreamer1.0-plugins-good-audioparsers" | ||
15 | RDEPENDS_gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparsersbad" | ||
16 | |||
17 | PV .= "+git${SRCPV}" | ||
18 | |||
19 | SRCBRANCH ?= "master" | ||
20 | SRCREV = "805987bff74af13fcb14ff111955206f1c92554d" | ||
21 | SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}" | ||
22 | |||
23 | S = "${WORKDIR}/git" | ||
24 | |||
25 | inherit pkgconfig waf use-imx-headers | ||
26 | |||
27 | # configure the eglvivsink element to use the appropriate EGL platform code | ||
28 | # Wayland if 'wayland' is present in DISTRO_FEATURES, if not, | ||
29 | # X11 if x11 is present in DISTRO_FEATURES, | ||
30 | # Framebuffer otherwise | ||
31 | EGLVIVSINK_PLATFORM = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \ | ||
32 | bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \ | ||
33 | 'fb', d),d)}" | ||
34 | |||
35 | EGL_PLATFORM_CONF = "--egl-platform=${EGLVIVSINK_PLATFORM}" | ||
36 | |||
37 | EXTRA_OECONF = "--kernel-headers=${STAGING_INCDIR_IMX} ${PACKAGECONFIG_CONFARGS}" | ||
38 | |||
39 | EGLVIVSINK_DEPENDS = " \ | ||
40 | virtual/egl virtual/libgles2 \ | ||
41 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \ | ||
42 | bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', \ | ||
43 | '', d), d)} \ | ||
44 | " | ||
45 | |||
46 | PACKAGECONFIG ?= "uniaudiodec mp3encoder v4l2src v4l2sink" | ||
47 | PACKAGECONFIG_append_imxgpu3d = " eglvivsink" | ||
48 | PACKAGECONFIG_append_imxgpu2d = " g2d g2dpango" | ||
49 | PACKAGECONFIG_append_imxipu = " ipu" | ||
50 | PACKAGECONFIG_append_imxvpu = " vpu" | ||
51 | PACKAGECONFIG_append_imxpxp = " pxp" | ||
52 | |||
53 | PACKAGECONFIG[g2d] = ",--disable-g2d,imx-gpu-g2d" | ||
54 | PACKAGECONFIG[g2dpango] = ",--disable-g2dpango,imx-gpu-g2d pango" | ||
55 | PACKAGECONFIG[pxp] = ",--disable-pxp," | ||
56 | PACKAGECONFIG[ipu] = ",--disable-ipu," | ||
57 | PACKAGECONFIG[vpu] = ",--disable-vpu,libimxvpuapi" | ||
58 | PACKAGECONFIG[eglvivsink] = "${EGL_PLATFORM_CONF},--disable-eglvivsink,${EGLVIVSINK_DEPENDS}" | ||
59 | PACKAGECONFIG[v4l2src] = ",--disable-imxv4l2videosrc," | ||
60 | PACKAGECONFIG[v4l2sink] = ",--disable-imxv4l2videosink," | ||
61 | PACKAGECONFIG[uniaudiodec] = ",--disable-uniaudiodec,imx-codec" | ||
62 | PACKAGECONFIG[mp3encoder] = ",--disable-mp3encoder,imx-codec" | ||
63 | |||
64 | # LIBV is used by gst-plugins-package.inc to specify the GStreamer version (0.10 vs 1.0) | ||
65 | LIBV = "1.0" | ||
66 | require recipes-multimedia/gstreamer/gstreamer1.0-plugins-packaging.inc | ||
67 | |||
68 | # the following line is required to produce one package for each plugin | ||
69 | PACKAGES_DYNAMIC = "^${PN}-.*" | ||
70 | |||
71 | COMPATIBLE_MACHINE = "(mx6dl|mx6q|mx6sl|mx6sx|mx6ul|mx6ull|mx7d)" | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb new file mode 100644 index 00000000..7c6025dd --- /dev/null +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb | |||
@@ -0,0 +1,62 @@ | |||
1 | # Copyright (C) 2018 O.S. Systems Software LTDA. | ||
2 | DESCRIPTION = "GStreamer 1.0 plugins for i.MX platforms" | ||
3 | LICENSE = "LGPLv2+" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605" | ||
5 | SECTION = "multimedia" | ||
6 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base libimxdmabuffer" | ||
7 | # add the audioparsers and the videoparsersbad plugins as RDEPENDS ; audioparsers | ||
8 | # for the uniaudio decoder, videoparsersbad for the VPU video decoder | ||
9 | # the gstreamer1.0-plugins-imx RDEPENDS is necessary to ensure the -good recipe is | ||
10 | # built (it is not a compile-time dependency however, hence RDEPENDS and not DEPENDS) | ||
11 | RDEPENDS_gstreamer1.0-plugins-imx = "gstreamer1.0-plugins-good gstreamer1.0-plugins-bad" | ||
12 | RDEPENDS_gstreamer1.0-plugins-imx-imxaudio = "gstreamer1.0-plugins-good-audioparsers" | ||
13 | RDEPENDS_gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparsersbad" | ||
14 | |||
15 | PV .= "+git${SRCPV}" | ||
16 | |||
17 | SRCBRANCH ?= "master" | ||
18 | SRCREV = "11e3a555a280f97d55d5243e8259a255b3ed14d0" | ||
19 | SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}" | ||
20 | |||
21 | S = "${WORKDIR}/git" | ||
22 | |||
23 | inherit pkgconfig meson use-imx-headers | ||
24 | |||
25 | # libg2d on i.MX8 SoCs with a DPU is emulated via the DPU. | ||
26 | # That particular libg2d .so depends on libdrm, however. | ||
27 | # Also, due to behavioral differences, an additional flag | ||
28 | # is needed to improve performance. | ||
29 | LIBG2D_DPU_OPTION = "-Dg2d-based-on-dpu=false" | ||
30 | LIBG2D_DEPENDENCIES = "virtual/libg2d" | ||
31 | LIBG2D_DPU_OPTION_imxdpu = "-Dg2d-based-on-dpu=true" | ||
32 | LIBG2D_DEPENDENCIES_imxdpu = "virtual/libg2d libdrm" | ||
33 | |||
34 | EXTRA_OEMESON += "-Dimx-headers-path=${STAGING_INCDIR_IMX}" | ||
35 | |||
36 | PACKAGECONFIG ?= "uniaudiodec" | ||
37 | PACKAGECONFIG_append_imxgpu2d = " g2d" | ||
38 | PACKAGECONFIG_append_imxvpu = " vpu" | ||
39 | PACKAGECONFIG_append_imxipu = " ipu" | ||
40 | PACKAGECONFIG_append_imxpxp = " pxp" | ||
41 | # The custom imxv4l2 elements are only available on the i.MX6. | ||
42 | # The 2D blitter sinks require an MXC framebuffer, which | ||
43 | # is not available anymore on the i.MX8 (since these SoCs | ||
44 | # now use KMS instead of the old Linux framebuffer). | ||
45 | PACKAGECONFIG_append_mx6 = " imx2dvideosink v4l2" | ||
46 | PACKAGECONFIG_append_mx7 = " imx2dvideosink" | ||
47 | |||
48 | PACKAGECONFIG[g2d] = "-Dg2d=enabled ${LIBG2D_DPU_OPTION},-Dg2d=disabled,${LIBG2D_DEPENDENCIES}" | ||
49 | PACKAGECONFIG[pxp] = "-Dpxp=enabled,-Dpxp=disabled," | ||
50 | PACKAGECONFIG[ipu] = "-Dipu=enabled,-Dipu=disabled," | ||
51 | PACKAGECONFIG[vpu] = "-Dvpu=enabled,-Dvpu=disabled,libimxvpuapi2" | ||
52 | PACKAGECONFIG[imx2dvideosink] = "-Dimx2d-videosink=true,-Dimx2d-videosink=false," | ||
53 | PACKAGECONFIG[v4l2] = "-Dv4l2=true,-Dv4l2=false," | ||
54 | PACKAGECONFIG[uniaudiodec] = "-Duniaudiodec=enabled,-Duniaudiodec=disabled,imx-codec" | ||
55 | PACKAGECONFIG[mp3encoder] = "-Dmp3encoder=enabled,-Dmp3encoder=disabled,imx-codec" | ||
56 | |||
57 | require recipes-multimedia/gstreamer/gstreamer1.0-plugins-packaging.inc | ||
58 | |||
59 | # the following line is required to produce one package for each plugin | ||
60 | PACKAGES_DYNAMIC = "^${PN}-.*" | ||
61 | |||
62 | COMPATIBLE_MACHINE = "(mx6dl|mx6q|mx6sl|mx6sx|mx6ul|mx6ull|mx7d|mx8)" | ||