diff options
-rw-r--r-- | conf/machine/imx6ulevk.conf | 2 | ||||
-rw-r--r-- | recipes-graphics/directfb/directfb_%.bbappend | 13 | ||||
-rw-r--r-- | recipes-graphics/mesa/mesa-demos_%.bbappend | 20 | ||||
-rw-r--r-- | recipes-graphics/mesa/mesa_%.bbappend | 21 | ||||
-rw-r--r-- | recipes-graphics/wayland/weston_%.bbappend | 7 |
5 files changed, 16 insertions, 47 deletions
diff --git a/conf/machine/imx6ulevk.conf b/conf/machine/imx6ulevk.conf index 319d9f08..00423cbf 100644 --- a/conf/machine/imx6ulevk.conf +++ b/conf/machine/imx6ulevk.conf | |||
@@ -9,7 +9,7 @@ include conf/machine/include/tune-cortexa7.inc | |||
9 | 9 | ||
10 | MACHINE_FEATURES += " pci wifi bluetooth" | 10 | MACHINE_FEATURES += " pci wifi bluetooth" |
11 | 11 | ||
12 | SOC_FAMILY = "mx6:mx6ul" | 12 | SOC_FAMILY = "mx6ul" |
13 | 13 | ||
14 | KERNEL_DEVICETREE = "imx6ul-14x14-evk.dtb imx6ul-14x14-evk-csi.dtb" | 14 | KERNEL_DEVICETREE = "imx6ul-14x14-evk.dtb imx6ul-14x14-evk-csi.dtb" |
15 | 15 | ||
diff --git a/recipes-graphics/directfb/directfb_%.bbappend b/recipes-graphics/directfb/directfb_%.bbappend index 20aa642e..a95af537 100644 --- a/recipes-graphics/directfb/directfb_%.bbappend +++ b/recipes-graphics/directfb/directfb_%.bbappend | |||
@@ -1,12 +1,3 @@ | |||
1 | # i.MX6 has DirectFB acceleration support, so add it | 1 | # i.MX6 has DirectFB acceleration support, so add it |
2 | RDEPENDS_${PN}_append_mx6q = " libvivante-dfb-mx6" | 2 | RDEPENDS_${PN}_append_mx6 = " libvivante-dfb-mx6" |
3 | PACKAGE_ARCH_mx6q = "${MACHINE_ARCH}" | 3 | PACKAGE_ARCH_mx6 = "${MACHINE_ARCH}" |
4 | |||
5 | RDEPENDS_${PN}_append_mx6dl = " libvivante-dfb-mx6" | ||
6 | PACKAGE_ARCH_mx6dl = "${MACHINE_ARCH}" | ||
7 | |||
8 | RDEPENDS_${PN}_append_mx6sx = " libvivante-dfb-mx6" | ||
9 | PACKAGE_ARCH_mx6sx = "${MACHINE_ARCH}" | ||
10 | |||
11 | RDEPENDS_${PN}_append_mx6sl = " libvivante-dfb-mx6" | ||
12 | PACKAGE_ARCH_mx6sl = "${MACHINE_ARCH}" | ||
diff --git a/recipes-graphics/mesa/mesa-demos_%.bbappend b/recipes-graphics/mesa/mesa-demos_%.bbappend index cc245b22..1f070a44 100644 --- a/recipes-graphics/mesa/mesa-demos_%.bbappend +++ b/recipes-graphics/mesa/mesa-demos_%.bbappend | |||
@@ -1,24 +1,14 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
2 | 2 | ||
3 | MESA-DEMO-PATCH = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \ | 3 | SRC_URI_append_mx6 = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \ |
4 | file://fix-clear-build-break.patch \ | 4 | file://fix-clear-build-break.patch \ |
5 | file://Additional-eglSwapBuffer-calling-makes-wrong-throttl.patch \ | 5 | file://Additional-eglSwapBuffer-calling-makes-wrong-throttl.patch \ |
6 | file://Add-OpenVG-demos-to-support-wayland.patch" | 6 | file://Add-OpenVG-demos-to-support-wayland.patch" |
7 | 7 | ||
8 | # only apply patches on mx6 that have a GPU | 8 | PACKAGECONFIG_remove_mx6 = " \ |
9 | SRC_URI_append_mx6q = " ${MESA-DEMO-PATCH}" | 9 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ |
10 | SRC_URI_append_mx6dl = " ${MESA-DEMO-PATCH}" | 10 | bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu', '', d), d)}" |
11 | SRC_URI_append_mx6sx = " ${MESA-DEMO-PATCH}" | 11 | PACKAGECONFIG_remove_mx6sl = "gles1 gles2" |
12 | SRC_URI_append_mx6sl = " ${MESA-DEMO-PATCH}" | ||
13 | |||
14 | REMOVE_GLU = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ | ||
15 | bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu', '', d), d)}" | ||
16 | |||
17 | # only remove GLU on mx6 thave have a GPU | ||
18 | PACKAGECONFIG_remove_mx6q = "${REMOVE_GLU}" | ||
19 | PACKAGECONFIG_remove_mx6dl = "${REMOVE_GLU}" | ||
20 | PACKAGECONFIG_remove_mx6sx = "${REMOVE_GLU}" | ||
21 | PACKAGECONFIG_remove_mx6sl = "gles1 gles2 ${REMOVE_GLU}" | ||
22 | 12 | ||
23 | PACKAGECONFIG_append = "\ | 13 | PACKAGECONFIG_append = "\ |
24 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ | 14 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ |
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend index 66913e17..2536afd6 100644 --- a/recipes-graphics/mesa/mesa_%.bbappend +++ b/recipes-graphics/mesa/mesa_%.bbappend | |||
@@ -1,19 +1,12 @@ | |||
1 | PACKAGECONFIG_remove_mx6q = "egl gles" | 1 | PACKAGECONFIG_remove_mx6 = "egl gles" |
2 | PACKAGECONFIG_remove_mx6dl = "egl gles" | ||
3 | PACKAGECONFIG_remove_mx6sx = "egl gles" | ||
4 | PACKAGECONFIG_remove_mx6sl = "egl gles" | ||
5 | 2 | ||
6 | # i.MX6SL uses mesa software rendering | 3 | PROVIDES_remove_mx6 = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl" |
4 | PROVIDES_remove_mx6q = "virtual/libgl" | ||
5 | PROVIDES_remove_mx6dl = "virtual/libgl" | ||
6 | PROVIDES_remove_mx6sx = "virtual/libgl" | ||
7 | 7 | ||
8 | PROVIDES_remove_mx6q = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl virtual/libgl" | 8 | USE_VIV_LIBGL = "yes" |
9 | PROVIDES_remove_mx6dl = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl virtual/libgl" | 9 | USE_VIV_LIBGL_mx6sl = "no" |
10 | PROVIDES_remove_mx6sx = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl virtual/libgl" | ||
11 | PROVIDES_remove_mx6sl = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl" | ||
12 | |||
13 | USE_VIV_LIBGL = "no" | ||
14 | USE_VIV_LIBGL_mx6q = "yes" | ||
15 | USE_VIV_LIBGL_mx6dl = "yes" | ||
16 | USE_VIV_LIBGL_mx6sx = "yes" | ||
17 | 10 | ||
18 | # FIXME: mesa should support 'x11-no-tls' option | 11 | # FIXME: mesa should support 'x11-no-tls' option |
19 | python () { | 12 | python () { |
diff --git a/recipes-graphics/wayland/weston_%.bbappend b/recipes-graphics/wayland/weston_%.bbappend index a254f07f..a7496daa 100644 --- a/recipes-graphics/wayland/weston_%.bbappend +++ b/recipes-graphics/wayland/weston_%.bbappend | |||
@@ -1,11 +1,6 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
2 | 2 | ||
3 | # only install patch for mx6 with a GPU | 3 | SRC_URI_append_mx6 = " file://0001-MGS-840-Add-i.MX6-support-for-weston.patch" |
4 | GPU_PATCH = "file://0001-MGS-840-Add-i.MX6-support-for-weston.patch" | ||
5 | SRC_URI_append_mx6q = " ${GPU_PATCH}" | ||
6 | SRC_URI_append_mx6dl = " ${GPU_PATCH}" | ||
7 | SRC_URI_append_mx6sx = " ${GPU_PATCH}" | ||
8 | SRC_URI_append_mx6sl = " ${GPU_PATCH}" | ||
9 | 4 | ||
10 | PACKAGECONFIG_append_mx6q = " cairo-glesv2" | 5 | PACKAGECONFIG_append_mx6q = " cairo-glesv2" |
11 | PACKAGECONFIG_append_mx6dl = " cairo-glesv2" | 6 | PACKAGECONFIG_append_mx6dl = " cairo-glesv2" |