diff options
-rw-r--r-- | recipes-bsp/ppa/ppa-optee_git.bb | 18 | ||||
-rw-r--r-- | recipes-bsp/ppa/ppa.inc | 54 | ||||
-rw-r--r-- | recipes-bsp/ppa/ppa_git.bb | 20 |
3 files changed, 0 insertions, 92 deletions
diff --git a/recipes-bsp/ppa/ppa-optee_git.bb b/recipes-bsp/ppa/ppa-optee_git.bb deleted file mode 100644 index 41896baf..00000000 --- a/recipes-bsp/ppa/ppa-optee_git.bb +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | require ppa.inc | ||
2 | |||
3 | DEPENDS += "optee-os-qoriq" | ||
4 | |||
5 | PPA_PATH_ls1046a = "ls1046" | ||
6 | PPA_PATH_ls1043a = "ls1043" | ||
7 | PPA_PATH_ls1012a = "ls1012" | ||
8 | PPA_PATH_ls2088a = "ls2088" | ||
9 | |||
10 | do_compile() { | ||
11 | export CROSS_COMPILE="${WRAP_TARGET_PREFIX}" | ||
12 | cp ${RECIPE_SYSROOT}/lib/firmware/tee_${MACHINE}.bin ${S}/ppa/soc-${PPA_PATH}/tee.bin | ||
13 | cd ${S}/ppa | ||
14 | ./build rdb-fit spd=on ${PPA_PATH} | ||
15 | cd ${S} | ||
16 | } | ||
17 | |||
18 | COMPATIBLE_MACHINE = "(ls1043a|ls1046a|ls1012a|ls2088a)" | ||
diff --git a/recipes-bsp/ppa/ppa.inc b/recipes-bsp/ppa/ppa.inc deleted file mode 100644 index 8125375c..00000000 --- a/recipes-bsp/ppa/ppa.inc +++ /dev/null | |||
@@ -1,54 +0,0 @@ | |||
1 | SUMMARY = "Primary Protected Application" | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | LIC_FILES_CHKSUM = "file://license.txt;md5=2ecf925c01a48f61c88f78c30fe2ee3b" | ||
4 | |||
5 | DEPENDS += "u-boot-mkimage-native dtc-native" | ||
6 | |||
7 | inherit deploy | ||
8 | |||
9 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ppa-generic;nobranch=1 \ | ||
10 | " | ||
11 | SRCREV = "90e13c9e148972f75f5f2e7f7a904dabf1586049" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | python () { | ||
16 | ml = d.getVar("MULTILIB_VARIANTS", True) | ||
17 | arch = d.getVar("OVERRIDES", True) | ||
18 | if "fsl-lsch2-32b:" in arch: | ||
19 | if not "lib64" in ml: | ||
20 | raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled") | ||
21 | sys_multilib = d.getVar('TARGET_VENDOR') + 'mllib64-linux' | ||
22 | sys_original = d.getVar('TARGET_VENDOR') + '-' + d.getVar('TARGET_OS') | ||
23 | workdir = d.getVar('WORKDIR').replace(sys_original,sys_multilib) | ||
24 | d.setVar('DEPENDS_append', ' lib64-gcc-cross-aarch64 lib64-libgcc') | ||
25 | d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/aarch64' + sys_multilib) | ||
26 | d.setVar('TOOLCHAIN_OPTIONS', '--sysroot=' + workdir + '/lib64-recipe-sysroot') | ||
27 | d.setVar("WRAP_TARGET_PREFIX", 'aarch64' + sys_multilib + '-') | ||
28 | } | ||
29 | |||
30 | WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" | ||
31 | EXTRA_OEMAKE = 'CC64="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}" LD64="${WRAP_TARGET_PREFIX}ld ${TOOLCHAIN_OPTIONS}" OBJ64="${WRAP_TARGET_PREFIX}objcopy"' | ||
32 | |||
33 | PPA_NAME = "${PN}-${MACHINE}-${DATETIME}" | ||
34 | PPA_NAME[vardepsexclude] = "DATETIME" | ||
35 | |||
36 | do_install() { | ||
37 | install -d ${D}/boot/ | ||
38 | install ${S}/ppa/soc-${PPA_PATH}/build/obj/ppa.itb ${D}/boot/${PPA_NAME}.itb | ||
39 | ln -sfT ${PPA_NAME}.itb ${D}/boot/${PN}.itb | ||
40 | } | ||
41 | |||
42 | do_deploy(){ | ||
43 | install -d ${DEPLOYDIR} | ||
44 | install ${S}/ppa/soc-${PPA_PATH}/build/obj/ppa.itb ${DEPLOYDIR}/${PPA_NAME}.itb | ||
45 | ln -sfT ${PPA_NAME}.itb ${DEPLOYDIR}/${PN}.itb | ||
46 | } | ||
47 | addtask deploy before do_build after do_install | ||
48 | |||
49 | PACKAGES += "${PN}-image" | ||
50 | FILES_${PN}-image += "/boot" | ||
51 | |||
52 | CLEANBROKEN = "1" | ||
53 | PARALLEL_MAKE = "" | ||
54 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
diff --git a/recipes-bsp/ppa/ppa_git.bb b/recipes-bsp/ppa/ppa_git.bb deleted file mode 100644 index 5413d7d4..00000000 --- a/recipes-bsp/ppa/ppa_git.bb +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | require ppa.inc | ||
2 | |||
3 | PPA_PATH_ls1012a = "ls1012" | ||
4 | PPA_PATH_ls1043a = "ls1043" | ||
5 | PPA_PATH_ls1046a = "ls1046" | ||
6 | PPA_PATH_ls2088a = "ls2088" | ||
7 | PPA_PATH_ls1088a = "ls1088" | ||
8 | |||
9 | do_compile () { | ||
10 | export CROSS_COMPILE="${WRAP_TARGET_PREFIX}" | ||
11 | cd ${S}/ppa | ||
12 | if [ ${MACHINE} = ls1012afrdm ];then | ||
13 | ./build frdm-fit ${PPA_PATH} | ||
14 | else | ||
15 | ./build rdb-fit ${PPA_PATH} | ||
16 | fi | ||
17 | cd ${S} | ||
18 | } | ||
19 | |||
20 | COMPATIBLE_MACHINE = "(ls1043a|ls1046a|ls2088a|ls1012a|ls1088a)" | ||