diff options
-rw-r--r-- | recipes-dpaa2/gpp-aioptool/gpp-aioptool/0001-add-fcommon-to-fix-gcc-10-build-issue.patch | 36 | ||||
-rw-r--r-- | recipes-dpaa2/gpp-aioptool/gpp-aioptool_git.bb | 1 |
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-dpaa2/gpp-aioptool/gpp-aioptool/0001-add-fcommon-to-fix-gcc-10-build-issue.patch b/recipes-dpaa2/gpp-aioptool/gpp-aioptool/0001-add-fcommon-to-fix-gcc-10-build-issue.patch new file mode 100644 index 00000000..6b69e7fd --- /dev/null +++ b/recipes-dpaa2/gpp-aioptool/gpp-aioptool/0001-add-fcommon-to-fix-gcc-10-build-issue.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | From e506c4ea7e576e713fa64569b6784bdc22b3205f Mon Sep 17 00:00:00 2001 | ||
2 | From: Ting Liu <ting.liu@nxp.com> | ||
3 | Date: Fri, 9 Oct 2020 13:13:13 +0530 | ||
4 | Subject: [PATCH] add -fcommon to fix gcc 10 build issue | ||
5 | |||
6 | Fix: | ||
7 | | ...ld: src/aiop_logger.o:(.bss+0x0): multiple definition of `_debug_flag'; src/aiop_tool.o:(.bss+0x0): first defined here | ||
8 | | ...ld: src/aiop_logger.o:(.bss+0x2): multiple definition of `_verbose_flag'; src/aiop_tool.o:(.bss+0x2): first defined here | ||
9 | |||
10 | Reference: https://gcc.gnu.org/gcc-10/porting_to.html | ||
11 | As a workaround, legacy C code where all tentative definitions should be | ||
12 | placed into a common block can be compiled with -fcommon. | ||
13 | |||
14 | Upstream-Status: Pending | ||
15 | |||
16 | Signed-off-by: Ting Liu <ting.liu@nxp.com> | ||
17 | --- | ||
18 | Makefile | 2 +- | ||
19 | 1 files changed, 1 insertion(+), 1 deletions(-) | ||
20 | |||
21 | diff --git a/Makefile b/Makefile | ||
22 | index f10dda2..f568788 100644 | ||
23 | --- a/Makefile | ||
24 | +++ b/Makefile | ||
25 | @@ -23,7 +23,7 @@ BINDIR = bin | ||
26 | |||
27 | |||
28 | # FLAGS | ||
29 | -CFLAGS = -Wall | ||
30 | +CFLAGS = -Wall -fcommon | ||
31 | #CFLAGS += -g -O0 # Enable for Debugging | ||
32 | CFLAGS += -I$(top_builddir)/include | ||
33 | CFLAGS += -I$(top_builddir)/src | ||
34 | -- | ||
35 | 2.17.1 | ||
36 | |||
diff --git a/recipes-dpaa2/gpp-aioptool/gpp-aioptool_git.bb b/recipes-dpaa2/gpp-aioptool/gpp-aioptool_git.bb index a9c3180f..1e60c534 100644 --- a/recipes-dpaa2/gpp-aioptool/gpp-aioptool_git.bb +++ b/recipes-dpaa2/gpp-aioptool/gpp-aioptool_git.bb | |||
@@ -8,6 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=386a6287daa6504b7e7e5014ddfb3987" | |||
8 | 8 | ||
9 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/gpp-aioptool;nobranch=1 \ | 9 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/gpp-aioptool;nobranch=1 \ |
10 | file://0001-remove-libio.h.patch \ | 10 | file://0001-remove-libio.h.patch \ |
11 | file://0001-add-fcommon-to-fix-gcc-10-build-issue.patch \ | ||
11 | " | 12 | " |
12 | SRCREV = "6ead470dde043f3ca67f1ba19b313dd64ec199e1" | 13 | SRCREV = "6ead470dde043f3ca67f1ba19b313dd64ec199e1" |
13 | 14 | ||