diff options
-rw-r--r-- | recipes-virtualization/mux-server/mux-server/0001-Makefile-Fix-the-warning-during-build.patch | 31 | ||||
-rw-r--r-- | recipes-virtualization/mux-server/mux-server_1.02.bb | 29 |
2 files changed, 0 insertions, 60 deletions
diff --git a/recipes-virtualization/mux-server/mux-server/0001-Makefile-Fix-the-warning-during-build.patch b/recipes-virtualization/mux-server/mux-server/0001-Makefile-Fix-the-warning-during-build.patch deleted file mode 100644 index 32b0f19d..00000000 --- a/recipes-virtualization/mux-server/mux-server/0001-Makefile-Fix-the-warning-during-build.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From bcb58c751a7ff82095642d2c9424a7ae18bca3c6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Sujith Haridasan <Sujith_Haridasan@mentor.com> | ||
3 | Date: Wed, 27 Apr 2016 16:49:09 +0530 | ||
4 | Subject: [PATCH] Makefile: Fix the warning during build | ||
5 | |||
6 | Fix QA Issue: No GNU_HASH in the elf binary | ||
7 | This warning is caused when built with external | ||
8 | toolchain sourcery. | ||
9 | |||
10 | Signed-off-by: Sujith H <sujith.h@gmail.com> | ||
11 | Signed-off-by: Sujith Haridasan <Sujith_Haridasan@mentor.com> | ||
12 | --- | ||
13 | Makefile | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/Makefile b/Makefile | ||
17 | index c41030d..fa69b6f 100644 | ||
18 | --- a/Makefile | ||
19 | +++ b/Makefile | ||
20 | @@ -36,7 +36,7 @@ HOSTCC_OPTS_C= -Wall \ | ||
21 | all: mux_server | ||
22 | |||
23 | mux_server: mux_server.c | ||
24 | - $(HOSTCC) $(HOSTCC_OPTS) $(HOSTCC_OPTS_C) -o $@ $< -lpthread | ||
25 | + $(HOSTCC) $(HOSTCC_OPTS) $(HOSTCC_OPTS_C) -o $@ $< -lpthread ${LDFLAGS} | ||
26 | |||
27 | clean: | ||
28 | rm -f mux_server | ||
29 | -- | ||
30 | 1.9.1 | ||
31 | |||
diff --git a/recipes-virtualization/mux-server/mux-server_1.02.bb b/recipes-virtualization/mux-server/mux-server_1.02.bb deleted file mode 100644 index 83bafaa2..00000000 --- a/recipes-virtualization/mux-server/mux-server_1.02.bb +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | DESCRIPTION = "A Linux-based utility supporting console multiplexing and demultiplexing" | ||
2 | SECTION = "mux-server" | ||
3 | LICENSE = "LGPL-2.1" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" | ||
5 | |||
6 | SRC_URI = "git://git.freescale.com/ppc/sdk/hypervisor/mux_server.git;branch=master \ | ||
7 | file://0001-Makefile-Fix-the-warning-during-build.patch \ | ||
8 | " | ||
9 | SRCREV = "3e4c6a44a81bb5cf2996830e8034d26850f80efc" | ||
10 | |||
11 | S = "${WORKDIR}/git" | ||
12 | |||
13 | EXTRA_OEMAKE='HOSTCC="${CC}"' | ||
14 | |||
15 | inherit deploy | ||
16 | |||
17 | do_install () { | ||
18 | install -d ${D}${bindir} | ||
19 | install -m 755 mux_server ${D}${bindir} | ||
20 | } | ||
21 | |||
22 | do_deploy() { | ||
23 | install -d ${DEPLOYDIR}/hv | ||
24 | install -m 755 mux_server ${DEPLOYDIR}/hv/mux_server-${PKGV}-${PKGR} | ||
25 | ln -sf mux_server-${PKGV}-${PKGR} ${DEPLOYDIR}/hv/mux_server | ||
26 | } | ||
27 | addtask deploy after do_install | ||
28 | |||
29 | BBCLASSEXTEND = "native nativesdk" | ||