diff options
-rw-r--r-- | conf/machine/imx8mmevk.conf | 1 | ||||
-rw-r--r-- | conf/machine/imx8mqevk.conf | 1 | ||||
-rw-r--r-- | conf/machine/include/imx-base.inc | 2 | ||||
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-boot_0.2.bb | 23 | ||||
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-mkimage_git.bb | 2 | ||||
-rw-r--r-- | wic/imx-imx-boot-bootpart.wks.in (renamed from wic/imx-imx-boot-bootpart.wks) | 5 |
6 files changed, 9 insertions, 25 deletions
diff --git a/conf/machine/imx8mmevk.conf b/conf/machine/imx8mmevk.conf index 82001101..44b3249f 100644 --- a/conf/machine/imx8mmevk.conf +++ b/conf/machine/imx8mmevk.conf | |||
@@ -19,7 +19,6 @@ KERNEL_DEVICETREE += "freescale/fsl-imx8mm-evk-m4.dtb " | |||
19 | KERNEL_DEVICETREE += "freescale/fsl-imx8mm-evk-rm67191.dtb " | 19 | KERNEL_DEVICETREE += "freescale/fsl-imx8mm-evk-rm67191.dtb " |
20 | KERNEL_DEVICETREE += "freescale/fsl-imx8mm-evk-root.dtb" | 20 | KERNEL_DEVICETREE += "freescale/fsl-imx8mm-evk-root.dtb" |
21 | 21 | ||
22 | IMAGE_BOOTFILES_DEPENDS += "imx-m4-demos:do_deploy" | ||
23 | IMAGE_BOOTFILES += "imx8mm_m4_TCM_hello_world.bin \ | 22 | IMAGE_BOOTFILES += "imx8mm_m4_TCM_hello_world.bin \ |
24 | imx8mm_m4_TCM_rpmsg_lite_pingpong_rtos_linux_remote.bin \ | 23 | imx8mm_m4_TCM_rpmsg_lite_pingpong_rtos_linux_remote.bin \ |
25 | imx8mm_m4_TCM_rpmsg_lite_str_echo_rtos.bin \ | 24 | imx8mm_m4_TCM_rpmsg_lite_str_echo_rtos.bin \ |
diff --git a/conf/machine/imx8mqevk.conf b/conf/machine/imx8mqevk.conf index f3280b9c..96f12203 100644 --- a/conf/machine/imx8mqevk.conf +++ b/conf/machine/imx8mqevk.conf | |||
@@ -21,7 +21,6 @@ KERNEL_DEVICETREE += "freescale/fsl-imx8mq-evk-lcdif-adv7535.dtb" | |||
21 | KERNEL_DEVICETREE += "freescale/fsl-imx8mq-evk-m4.dtb freescale/fsl-imx8mq-evk-mipi-csi2.dtb" | 21 | KERNEL_DEVICETREE += "freescale/fsl-imx8mq-evk-m4.dtb freescale/fsl-imx8mq-evk-mipi-csi2.dtb" |
22 | KERNEL_DEVICETREE += "freescale/fsl-imx8mq-evk-pcie1-m2.dtb freescale/fsl-imx8mq-evk-pdm.dtb" | 22 | KERNEL_DEVICETREE += "freescale/fsl-imx8mq-evk-pcie1-m2.dtb freescale/fsl-imx8mq-evk-pdm.dtb" |
23 | 23 | ||
24 | IMAGE_BOOTFILES_DEPENDS += "imx-m4-demos:do_deploy" | ||
25 | IMAGE_BOOTFILES += "imx8mq_m4_TCM_hello_world.bin imx8mq_m4_TCM_rpmsg_lite_pingpong_rtos_linux_remote.bin imx8mq_m4_TCM_rpmsg_lite_str_echo_rtos.bin" | 24 | IMAGE_BOOTFILES += "imx8mq_m4_TCM_hello_world.bin imx8mq_m4_TCM_rpmsg_lite_pingpong_rtos_linux_remote.bin imx8mq_m4_TCM_rpmsg_lite_str_echo_rtos.bin" |
26 | 25 | ||
27 | UBOOT_CONFIG ??= "sd" | 26 | UBOOT_CONFIG ??= "sd" |
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc index ea7da2c2..cc420788 100644 --- a/conf/machine/include/imx-base.inc +++ b/conf/machine/include/imx-base.inc | |||
@@ -305,7 +305,7 @@ WKS_FILE_DEPENDS ?= " \ | |||
305 | WKS_FILE_DEPENDS_mx8 += "imx-boot" | 305 | WKS_FILE_DEPENDS_mx8 += "imx-boot" |
306 | 306 | ||
307 | SOC_DEFAULT_WKS_FILE ?= "imx-uboot-bootpart.wks" | 307 | SOC_DEFAULT_WKS_FILE ?= "imx-uboot-bootpart.wks" |
308 | SOC_DEFAULT_WKS_FILE_mx8 ?= "imx-imx-boot-bootpart.wks" | 308 | SOC_DEFAULT_WKS_FILE_mx8 ?= "imx-imx-boot-bootpart.wks.in" |
309 | SOC_DEFAULT_WKS_FILE_mxs ?= "imx-uboot-mxs-bootpart.wks.in" | 309 | SOC_DEFAULT_WKS_FILE_mxs ?= "imx-uboot-mxs-bootpart.wks.in" |
310 | 310 | ||
311 | WKS_FILE ?= "${SOC_DEFAULT_WKS_FILE}" | 311 | WKS_FILE ?= "${SOC_DEFAULT_WKS_FILE}" |
diff --git a/recipes-bsp/imx-mkimage/imx-boot_0.2.bb b/recipes-bsp/imx-mkimage/imx-boot_0.2.bb index b232ed52..68492a9b 100644 --- a/recipes-bsp/imx-mkimage/imx-boot_0.2.bb +++ b/recipes-bsp/imx-mkimage/imx-boot_0.2.bb | |||
@@ -23,15 +23,7 @@ PROVIDES = "${BOOT_NAME}" | |||
23 | inherit deploy | 23 | inherit deploy |
24 | 24 | ||
25 | # Add CFLAGS with native INCDIR & LIBDIR for imx-mkimage build | 25 | # Add CFLAGS with native INCDIR & LIBDIR for imx-mkimage build |
26 | CFLAGS = "-O2 -Wall -std=c99 -static -I ${STAGING_INCDIR_NATIVE} -L ${STAGING_LIBDIR_NATIVE}" | 26 | CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR_NATIVE} -L ${STAGING_LIBDIR_NATIVE}" |
27 | |||
28 | # For i.MX 8, this package aggregates the imx-m4-demos | ||
29 | # output. Note that this aggregation replaces the aggregation | ||
30 | # that would otherwise be done in the image build as controlled | ||
31 | # by IMAGE_BOOTFILES_DEPENDS and IMAGE_BOOTFILES in image_types_fsl.bbclass | ||
32 | IMX_M4_DEMOS = "" | ||
33 | IMX_M4_DEMOS_mx8qm = "imx-m4-demos:do_deploy" | ||
34 | IMX_M4_DEMOS_mx8qxp = "imx-m4-demos:do_deploy" | ||
35 | 27 | ||
36 | # This package aggregates output deployed by other packages, | 28 | # This package aggregates output deployed by other packages, |
37 | # so set the appropriate dependencies | 29 | # so set the appropriate dependencies |
@@ -39,7 +31,6 @@ do_compile[depends] += " \ | |||
39 | virtual/bootloader:do_deploy \ | 31 | virtual/bootloader:do_deploy \ |
40 | ${@' '.join('%s:do_deploy' % r for r in '${IMX_EXTRA_FIRMWARE}'.split() )} \ | 32 | ${@' '.join('%s:do_deploy' % r for r in '${IMX_EXTRA_FIRMWARE}'.split() )} \ |
41 | imx-atf:do_deploy \ | 33 | imx-atf:do_deploy \ |
42 | ${IMX_M4_DEMOS} \ | ||
43 | " | 34 | " |
44 | 35 | ||
45 | SC_FIRMWARE_NAME ?= "scfw_tcm.bin" | 36 | SC_FIRMWARE_NAME ?= "scfw_tcm.bin" |
@@ -69,15 +60,15 @@ SOC_TARGET_mx8mm = "iMX8MM" | |||
69 | IMXBOOT_TARGETS ?= \ | 60 | IMXBOOT_TARGETS ?= \ |
70 | "${@bb.utils.contains('UBOOT_CONFIG', 'fspi', 'flash_flexspi', \ | 61 | "${@bb.utils.contains('UBOOT_CONFIG', 'fspi', 'flash_flexspi', \ |
71 | bb.utils.contains('UBOOT_CONFIG', 'nand', 'flash_nand', \ | 62 | bb.utils.contains('UBOOT_CONFIG', 'nand', 'flash_nand', \ |
72 | 'flash_multi_cores flash flash_dcd', d), d)}" | 63 | 'flash flash_dcd', d), d)}" |
73 | IMXBOOT_TARGETS_mx8qxp = \ | 64 | IMXBOOT_TARGETS_mx8qxp = \ |
74 | "${@bb.utils.contains('UBOOT_CONFIG', 'fspi', 'flash_flexspi', \ | 65 | "${@bb.utils.contains('UBOOT_CONFIG', 'fspi', 'flash_flexspi', \ |
75 | bb.utils.contains('UBOOT_CONFIG', 'nand', 'flash_nand', \ | 66 | bb.utils.contains('UBOOT_CONFIG', 'nand', 'flash_nand', \ |
76 | 'flash_all flash', d), d)}" | 67 | 'flash', d), d)}" |
77 | IMXBOOT_TARGETS_mx8qxpa0 = \ | 68 | IMXBOOT_TARGETS_mx8qxpa0 = \ |
78 | "${@bb.utils.contains('UBOOT_CONFIG', 'fspi', 'flash_flexspi_a0', \ | 69 | "${@bb.utils.contains('UBOOT_CONFIG', 'fspi', 'flash_flexspi_a0', \ |
79 | bb.utils.contains('UBOOT_CONFIG', 'nand', 'flash_nand_a0', \ | 70 | bb.utils.contains('UBOOT_CONFIG', 'nand', 'flash_nand_a0', \ |
80 | 'flash_multi_cores_a0 flash_a0 flash_dcd_a0', d), d)}" | 71 | 'flash_a0 flash_dcd_a0', d), d)}" |
81 | 72 | ||
82 | BOOT_STAGING = "${S}/${SOC_TARGET}" | 73 | BOOT_STAGING = "${S}/${SOC_TARGET}" |
83 | BOOT_STAGING_mx8mm = "${S}/iMX8M" | 74 | BOOT_STAGING_mx8mm = "${S}/iMX8M" |
@@ -106,14 +97,10 @@ compile_mx8() { | |||
106 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/${SC_FIRMWARE_NAME} ${BOOT_STAGING}/scfw_tcm.bin | 97 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/${SC_FIRMWARE_NAME} ${BOOT_STAGING}/scfw_tcm.bin |
107 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/${ATF_MACHINE_NAME} ${BOOT_STAGING}/bl31.bin | 98 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/${ATF_MACHINE_NAME} ${BOOT_STAGING}/bl31.bin |
108 | cp ${DEPLOY_DIR_IMAGE}/${UBOOT_NAME} ${BOOT_STAGING}/u-boot.bin | 99 | cp ${DEPLOY_DIR_IMAGE}/${UBOOT_NAME} ${BOOT_STAGING}/u-boot.bin |
109 | cp ${DEPLOY_DIR_IMAGE}/imx8qm_m4_0_TCM_rpmsg_lite_pingpong_rtos_linux_remote.bin ${BOOT_STAGING}/m40_tcm.bin | ||
110 | cp ${DEPLOY_DIR_IMAGE}/imx8qm_m4_1_TCM_rpmsg_lite_pingpong_rtos_linux_remote.bin ${BOOT_STAGING}/m41_tcm.bin | ||
111 | cp ${DEPLOY_DIR_IMAGE}/mx8qm-ahab-container.img ${BOOT_STAGING} | 100 | cp ${DEPLOY_DIR_IMAGE}/mx8qm-ahab-container.img ${BOOT_STAGING} |
112 | } | 101 | } |
113 | compile_mx8x() { | 102 | compile_mx8x() { |
114 | bbnote 8QX boot binary build | 103 | bbnote 8QX boot binary build |
115 | cp ${DEPLOY_DIR_IMAGE}/imx8qx_m4_TCM_rpmsg_lite_pingpong_rtos_linux_remote.bin ${BOOT_STAGING}/m40_tcm.bin | ||
116 | cp ${DEPLOY_DIR_IMAGE}/imx8qx_m4_TCM_rpmsg_lite_pingpong_rtos_linux_remote.bin ${BOOT_STAGING}/CM4.bin | ||
117 | cp ${DEPLOY_DIR_IMAGE}/mx8qx-ahab-container.img ${BOOT_STAGING} | 104 | cp ${DEPLOY_DIR_IMAGE}/mx8qx-ahab-container.img ${BOOT_STAGING} |
118 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/${SC_FIRMWARE_NAME} ${BOOT_STAGING}/scfw_tcm.bin | 105 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/${SC_FIRMWARE_NAME} ${BOOT_STAGING}/scfw_tcm.bin |
119 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/${ATF_MACHINE_NAME} ${BOOT_STAGING}/bl31.bin | 106 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/${ATF_MACHINE_NAME} ${BOOT_STAGING}/bl31.bin |
@@ -160,8 +147,6 @@ deploy_mx8x() { | |||
160 | install -m 0644 ${BOOT_STAGING}/${DCD_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} | 147 | install -m 0644 ${BOOT_STAGING}/${DCD_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} |
161 | fi | 148 | fi |
162 | install -m 0644 ${BOOT_STAGING}/mx8qx-ahab-container.img ${DEPLOYDIR}/${BOOT_TOOLS} | 149 | install -m 0644 ${BOOT_STAGING}/mx8qx-ahab-container.img ${DEPLOYDIR}/${BOOT_TOOLS} |
163 | install -m 0644 ${BOOT_STAGING}/m40_tcm.bin ${DEPLOYDIR}/${BOOT_TOOLS} | ||
164 | install -m 0644 ${BOOT_STAGING}/CM4.bin ${DEPLOYDIR}/${BOOT_TOOLS} | ||
165 | install -m 0755 ${S}/${TOOLS_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} | 150 | install -m 0755 ${S}/${TOOLS_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} |
166 | } | 151 | } |
167 | do_deploy() { | 152 | do_deploy() { |
diff --git a/recipes-bsp/imx-mkimage/imx-mkimage_git.bb b/recipes-bsp/imx-mkimage/imx-mkimage_git.bb index b0a2719f..5304ebf9 100644 --- a/recipes-bsp/imx-mkimage/imx-mkimage_git.bb +++ b/recipes-bsp/imx-mkimage/imx-mkimage_git.bb | |||
@@ -10,7 +10,7 @@ SECTION = "BSP" | |||
10 | 10 | ||
11 | inherit native deploy | 11 | inherit native deploy |
12 | 12 | ||
13 | CFLAGS = "-O2 -Wall -std=c99 -static -I ${STAGING_INCDIR} -L ${STAGING_LIBDIR}" | 13 | CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR} -L ${STAGING_LIBDIR}" |
14 | 14 | ||
15 | do_compile () { | 15 | do_compile () { |
16 | cd ${S} | 16 | cd ${S} |
diff --git a/wic/imx-imx-boot-bootpart.wks b/wic/imx-imx-boot-bootpart.wks.in index 11b90492..601b9340 100644 --- a/wic/imx-imx-boot-bootpart.wks +++ b/wic/imx-imx-boot-bootpart.wks.in | |||
@@ -10,9 +10,10 @@ | |||
10 | # - ---------- -------------- -------------- | 10 | # - ---------- -------------- -------------- |
11 | # ^ ^ ^ ^ | 11 | # ^ ^ ^ ^ |
12 | # | | | | | 12 | # | | | | |
13 | # 0 33kiB 4MiB 16MiB + rootfs + IMAGE_EXTRA_SPACE (default 10MiB) | 13 | # 0 | 4MiB 16MiB + rootfs + IMAGE_EXTRA_SPACE (default 10MiB) |
14 | # ${IMX_BOOT_SEEK} 32 or 33kiB, see reference manual | ||
14 | # | 15 | # |
15 | part u-boot --source rawcopy --sourceparams="file=imx-boot" --ondisk mmcblk --no-table --align 33 | 16 | part u-boot --source rawcopy --sourceparams="file=imx-boot" --ondisk mmcblk --no-table --align ${IMX_BOOT_SEEK} |
16 | part /boot --source bootimg-partition --ondisk mmcblk --fstype=vfat --label boot --active --align 4096 --size 16 | 17 | part /boot --source bootimg-partition --ondisk mmcblk --fstype=vfat --label boot --active --align 4096 --size 16 |
17 | part / --source rootfs --ondisk mmcblk --fstype=ext4 --label root --align 4096 | 18 | part / --source rootfs --ondisk mmcblk --fstype=ext4 --label root --align 4096 |
18 | 19 | ||