diff options
-rw-r--r-- | recipes-kernel/linux/linux-imx-headers-4.9.123/0001-uapi-Install-custom-headers.patch | 40 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-imx-headers_4.9.123.bb | 49 |
2 files changed, 89 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx-headers-4.9.123/0001-uapi-Install-custom-headers.patch b/recipes-kernel/linux/linux-imx-headers-4.9.123/0001-uapi-Install-custom-headers.patch new file mode 100644 index 00000000..fd842bf1 --- /dev/null +++ b/recipes-kernel/linux/linux-imx-headers-4.9.123/0001-uapi-Install-custom-headers.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | From 33c85073a35e697e080583ca8edb31400b45de60 Mon Sep 17 00:00:00 2001 | ||
2 | From: Tom Hochstein <tom.hochstein@nxp.com> | ||
3 | Date: Wed, 3 Oct 2018 18:02:43 -0500 | ||
4 | Subject: [PATCH] uapi: Install custom headers | ||
5 | |||
6 | Upstream-Status: Inappropriate [i.MX specific] | ||
7 | |||
8 | Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> | ||
9 | --- | ||
10 | include/uapi/linux/Kbuild | 2 ++ | ||
11 | 1 file changed, 2 insertions(+) | ||
12 | |||
13 | Index: git/include/uapi/linux/Kbuild | ||
14 | =================================================================== | ||
15 | --- git.orig/include/uapi/linux/Kbuild | ||
16 | +++ git/include/uapi/linux/Kbuild | ||
17 | @@ -104,6 +104,7 @@ header-y += dlm_device.h | ||
18 | header-y += dlm.h | ||
19 | header-y += dlm_netlink.h | ||
20 | header-y += dlm_plock.h | ||
21 | +header-y += dma-buf.h | ||
22 | header-y += dm-ioctl.h | ||
23 | header-y += dm-log-userspace.h | ||
24 | header-y += dn.h | ||
25 | @@ -144,6 +145,7 @@ header-y += gigaset_dev.h | ||
26 | header-y += gpio.h | ||
27 | header-y += gsmmux.h | ||
28 | header-y += gtp.h | ||
29 | +header-y += hantrodec.h | ||
30 | header-y += hdlcdrv.h | ||
31 | header-y += hdlc.h | ||
32 | header-y += hdreg.h | ||
33 | @@ -152,6 +154,7 @@ header-y += hid.h | ||
34 | header-y += hidraw.h | ||
35 | header-y += hpet.h | ||
36 | header-y += hsr_netlink.h | ||
37 | +header-y += hx280enc.h | ||
38 | header-y += hyperv.h | ||
39 | header-y += hysdn_if.h | ||
40 | header-y += i2c-dev.h | ||
diff --git a/recipes-kernel/linux/linux-imx-headers_4.9.123.bb b/recipes-kernel/linux/linux-imx-headers_4.9.123.bb new file mode 100644 index 00000000..3a5e87e8 --- /dev/null +++ b/recipes-kernel/linux/linux-imx-headers_4.9.123.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | # Copyright 2017-2018 NXP | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | SUMMARY = "Installs i.MX-specific kernel headers" | ||
5 | DESCRIPTION = "Installs i.MX-specific kernel headers to userspace. \ | ||
6 | New headers are installed in ${includedir}/imx." | ||
7 | LICENSE = "GPLv2" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" | ||
9 | |||
10 | SRCBRANCH = "imx_4.9.123_imx8mm_ga" | ||
11 | LOCALVERSION = "-${SRCBRANCH}" | ||
12 | SRC_URI = "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https;branch=${SRCBRANCH} \ | ||
13 | file://0001-uapi-Install-custom-headers.patch" | ||
14 | SRCREV = "6a71cbc089755afd6a86c005c22a1af6eab24a70" | ||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | do_compile[noexec] = "1" | ||
18 | |||
19 | IMX_UAPI_HEADERS = " \ | ||
20 | dma-buf.h \ | ||
21 | hantrodec.h \ | ||
22 | hx280enc.h \ | ||
23 | ion.h \ | ||
24 | ipu.h \ | ||
25 | isl29023.h \ | ||
26 | mxc_asrc.h \ | ||
27 | mxc_dcic.h \ | ||
28 | mxc_mlb.h \ | ||
29 | mxc_sim_interface.h \ | ||
30 | mxc_v4l2.h \ | ||
31 | mxcfb.h \ | ||
32 | pxp_device.h \ | ||
33 | pxp_dma.h \ | ||
34 | version.h \ | ||
35 | videodev2.h \ | ||
36 | " | ||
37 | |||
38 | do_install() { | ||
39 | oe_runmake headers_install INSTALL_HDR_PATH=${B}${exec_prefix} | ||
40 | cp ${S}/drivers/staging/android/uapi/ion.h ${B}${includedir}/linux | ||
41 | src=${B}${includedir}/linux | ||
42 | dest=${D}${includedir}/imx/linux | ||
43 | install -d $dest | ||
44 | cd $src | ||
45 | install -m 0644 ${IMX_UAPI_HEADERS} $dest | ||
46 | cd - | ||
47 | } | ||
48 | |||
49 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | ||