summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/rcw/rcw_git.bb16
1 files changed, 11 insertions, 5 deletions
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
index 877822f2..9c2b156a 100644
--- a/recipes-bsp/rcw/rcw_git.bb
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -1,23 +1,29 @@
1SUMMARY = "Reset Configuration Word" 1SUMMARY = "Reset Configuration Word"
2DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets" 2DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets"
3LICENSE = "BSD" 3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://BSD-LICENSE;md5=627727dce58484c4bd5f9b19665d81b3" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=be7e0b2ce5a7a1f4f25a6d82cec1f47d"
5 5
6DEPENDS += "change-file-endianess-native tcl-native" 6DEPENDS += "change-file-endianess-native tcl-native"
7 7
8inherit deploy 8inherit deploy siteinfo
9 9
10SRC_URI = "git://github.com/qoriq-open-source/rcw.git;nobranch=1" 10SRC_URI = "git://github.com/qoriq-open-source/rcw.git;nobranch=1"
11SRCREV = "bfe8c5eb72cbae387af1c8662957caa801c2309f" 11SRCREV = "1a6236a34166219de324a105971eb9de05cde76e"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
15export PYTHON = "${USRBINPATH}/python2" 15export PYTHON = "${USRBINPATH}/python2"
16 16
17EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','').replace('-32b','')} DESTDIR=${D}/boot/rcw/" 17M="${@d.getVar('MACHINE', True).replace('-64b','').replace('-32b','').replace('-${SITEINFO_ENDIANNESS}','')}"
18 18
19do_install () { 19do_install () {
20 oe_runmake install 20 if [ -f ${S}/${M}/Makefile ]; then
21 oe_runmake BOARDS=${M} DESTDIR=${D}/boot/rcw/ install
22 else
23 install -d ${D}/boot/rcw
24 cp -a ${S}/${M} ${D}/boot/rcw/
25 chown -R root:root ${D}
26 fi
21 for f in `find ${D}/boot/rcw/ -name "*qspiboot*"`;do 27 for f in `find ${D}/boot/rcw/ -name "*qspiboot*"`;do
22 if echo $f |grep -q "qspiboot_sben"; then 28 if echo $f |grep -q "qspiboot_sben"; then
23 continue 29 continue