summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.1.bb14
1 files changed, 11 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_4.1.bb b/recipes-kernel/linux/linux-qoriq_4.1.bb
index c97104e9..587ecd9d 100644
--- a/recipes-kernel/linux/linux-qoriq_4.1.bb
+++ b/recipes-kernel/linux/linux-qoriq_4.1.bb
@@ -18,7 +18,7 @@ SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;nobranch=1 \
18 file://CVE-2016-2053.patch \ 18 file://CVE-2016-2053.patch \
19 file://CVE-2016-0758.patch \ 19 file://CVE-2016-0758.patch \
20" 20"
21SRCREV = "667e6ba9ca2150b3cabdd0c07b57d1b88ef3b86a" 21SRCREV = "4004071c129a776136e71f6a85383fea87f5db75"
22 22
23S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
24 24
@@ -36,8 +36,7 @@ ZIMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
36SCMVERSION ?= "y" 36SCMVERSION ?= "y"
37LOCALVERSION = "" 37LOCALVERSION = ""
38DELTA_KERNEL_DEFCONFIG ?= "" 38DELTA_KERNEL_DEFCONFIG ?= ""
39DELTA_KERNEL_DEFCONFIG_prepend_ls1043ardb = "freescale.config " 39DELTA_KERNEL_DEFCONFIG_prepend_qoriq-arm64 = "freescale.config "
40DELTA_KERNEL_DEFCONFIG_prepend_ls2080ardb = "freescale.config "
41 40
42do_merge_delta_config() { 41do_merge_delta_config() {
43 # copy desired defconfig so we pick it up for the real kernel_do_configure 42 # copy desired defconfig so we pick it up for the real kernel_do_configure
@@ -58,6 +57,15 @@ do_merge_delta_config() {
58} 57}
59addtask merge_delta_config before do_preconfigure after do_patch 58addtask merge_delta_config before do_preconfigure after do_patch
60 59
60# The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b)
61do_compile_prepend_fsl-lsch2-32b() {
62 ln -sfT ${STAGING_KERNEL_DIR}/arch/arm64/boot/dts/freescale ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale
63}
64
65do_install_prepend_fsl-lsch2-32b() {
66 rm -f ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale
67}
68
61do_install_append_qoriq-arm() { 69do_install_append_qoriq-arm() {
62 install -m 0644 arch/${ARCH}/boot/zImage ${D}/boot/zImage-${KERNEL_VERSION} 70 install -m 0644 arch/${ARCH}/boot/zImage ${D}/boot/zImage-${KERNEL_VERSION}
63 ln -sf zImage-${KERNEL_VERSION} ${D}/boot/zImage 71 ln -sf zImage-${KERNEL_VERSION} ${D}/boot/zImage