diff options
-rw-r--r-- | classes/use-imx-security-controller-firmware.bbclass | 1 | ||||
-rw-r--r-- | conf/machine/imx8ulp-lpddr4-evk.conf | 27 | ||||
-rw-r--r-- | conf/machine/include/imx-base.inc | 9 | ||||
-rw-r--r-- | conf/machine/include/imx8ulp-evk.inc | 44 | ||||
-rw-r--r-- | recipes-bsp/firmware-sentinel/firmware-sentinel_0.8.bb | 23 | ||||
-rw-r--r-- | recipes-bsp/firmware-upower/firmware-upower_1.1.0.bb | 31 | ||||
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-boot_1.0.bb | 28 |
7 files changed, 163 insertions, 0 deletions
diff --git a/classes/use-imx-security-controller-firmware.bbclass b/classes/use-imx-security-controller-firmware.bbclass index eb88fb99..603ea80d 100644 --- a/classes/use-imx-security-controller-firmware.bbclass +++ b/classes/use-imx-security-controller-firmware.bbclass | |||
@@ -23,6 +23,7 @@ SECO_FIRMWARE_NAME:mx8qxp-nxp-bsp = \ | |||
23 | 'mx8qxc0-ahab-container.img', d)}" | 23 | 'mx8qxc0-ahab-container.img', d)}" |
24 | SECO_FIRMWARE_NAME:mx8dx-nxp-bsp = "mx8qxc0-ahab-container.img" | 24 | SECO_FIRMWARE_NAME:mx8dx-nxp-bsp = "mx8qxc0-ahab-container.img" |
25 | SECO_FIRMWARE_NAME:mx8dxl-nxp-bsp = "mx8dxla1-ahab-container.img" | 25 | SECO_FIRMWARE_NAME:mx8dxl-nxp-bsp = "mx8dxla1-ahab-container.img" |
26 | SECO_FIRMWARE_NAME:mx8ulp-nxp-bsp = "mx8ulpa1-ahab-container.img" | ||
26 | 27 | ||
27 | python () { | 28 | python () { |
28 | if "mx8m-generic-bsp" in d.getVar('MACHINEOVERRIDES').split(":"): | 29 | if "mx8m-generic-bsp" in d.getVar('MACHINEOVERRIDES').split(":"): |
diff --git a/conf/machine/imx8ulp-lpddr4-evk.conf b/conf/machine/imx8ulp-lpddr4-evk.conf new file mode 100644 index 00000000..707597d2 --- /dev/null +++ b/conf/machine/imx8ulp-lpddr4-evk.conf | |||
@@ -0,0 +1,27 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: i.MX 8ULP EVK | ||
3 | #@SOC: i.MX8ULP | ||
4 | #@DESCRIPTION: Machine configuration for NXP i.MX 8ULP Evaluation Kit with LPDDR4 | ||
5 | #@MAINTAINER: Jun Zhu <junzhu@nxp.com> | ||
6 | |||
7 | require include/imx8ulp-evk.inc | ||
8 | |||
9 | KERNEL_DEVICETREE_BASENAME = "imx8ulp-evk" | ||
10 | |||
11 | KERNEL_DEVICETREE += " \ | ||
12 | freescale/${KERNEL_DEVICETREE_BASENAME}-epdc.dtb \ | ||
13 | freescale/${KERNEL_DEVICETREE_BASENAME}-flexio-i2c.dtb \ | ||
14 | freescale/${KERNEL_DEVICETREE_BASENAME}-i3c.dtb \ | ||
15 | freescale/${KERNEL_DEVICETREE_BASENAME}-lpa.dtb \ | ||
16 | freescale/${KERNEL_DEVICETREE_BASENAME}-lpspi-slave.dtb \ | ||
17 | freescale/${KERNEL_DEVICETREE_BASENAME}-nd.dtb \ | ||
18 | freescale/${KERNEL_DEVICETREE_BASENAME}-rk055hdmipi4m.dtb \ | ||
19 | freescale/${KERNEL_DEVICETREE_BASENAME}-rk055hdmipi4mv2.dtb \ | ||
20 | freescale/${KERNEL_DEVICETREE_BASENAME}-sof-btsco.dtb \ | ||
21 | " | ||
22 | |||
23 | UBOOT_CONFIG_BASENAME = "imx8ulp_evk" | ||
24 | |||
25 | MACHINE_FEATURES += "soc-reva1" | ||
26 | UPOWER_FIRMWARE_NAME = "upower_a1.bin" | ||
27 | IMX_DEFAULT_BSP = "nxp" | ||
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc index 3106d637..7639f6e7 100644 --- a/conf/machine/include/imx-base.inc +++ b/conf/machine/include/imx-base.inc | |||
@@ -163,6 +163,7 @@ DEFAULTTUNE:vf-generic-bsp ?= "cortexa5thf-neon" | |||
163 | DEFAULTTUNE:mx8m-generic-bsp ?= "cortexa53-crypto" | 163 | DEFAULTTUNE:mx8m-generic-bsp ?= "cortexa53-crypto" |
164 | DEFAULTTUNE:mx8qm-generic-bsp ?= "cortexa72-cortexa53-crypto" | 164 | DEFAULTTUNE:mx8qm-generic-bsp ?= "cortexa72-cortexa53-crypto" |
165 | DEFAULTTUNE:mx8x-generic-bsp ?= "cortexa35-crypto" | 165 | DEFAULTTUNE:mx8x-generic-bsp ?= "cortexa35-crypto" |
166 | DEFAULTTUNE:mx8ulp-generic-bsp ?= "cortexa35-crypto" | ||
166 | 167 | ||
167 | INHERIT += "machine-overrides-extender" | 168 | INHERIT += "machine-overrides-extender" |
168 | 169 | ||
@@ -198,6 +199,8 @@ MACHINEOVERRIDES_EXTENDER:mx8qxp:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxd | |||
198 | MACHINEOVERRIDES_EXTENDER:mx8dx:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxdpu:imxgpu:imxgpu2d:imxgpu3d:imxvulkan:mx8-generic-bsp:mx8-nxp-bsp:mx8x-generic-bsp:mx8x-nxp-bsp:mx8dx-generic-bsp:mx8dx-nxp-bsp" | 199 | MACHINEOVERRIDES_EXTENDER:mx8dx:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxdpu:imxgpu:imxgpu2d:imxgpu3d:imxvulkan:mx8-generic-bsp:mx8-nxp-bsp:mx8x-generic-bsp:mx8x-nxp-bsp:mx8dx-generic-bsp:mx8dx-nxp-bsp" |
199 | MACHINEOVERRIDES_EXTENDER:mx8dxl:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxfbdev:mx8dxl-generic-bsp:mx8-generic-bsp:mx8-nxp-bsp:mx8x-generic-bsp:mx8x-nxp-bsp:mx8dxl-nxp-bsp" | 200 | MACHINEOVERRIDES_EXTENDER:mx8dxl:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxfbdev:mx8dxl-generic-bsp:mx8-generic-bsp:mx8-nxp-bsp:mx8x-generic-bsp:mx8x-nxp-bsp:mx8dxl-nxp-bsp" |
200 | 201 | ||
202 | MACHINEOVERRIDES_EXTENDER:mx8ulp:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:mx8-generic-bsp:mx8-nxp-bsp:mx8ulp-generic-bsp:mx8ulp-nxp-bsp" | ||
203 | |||
201 | ####### | 204 | ####### |
202 | ### Mainline BSP specific overrides | 205 | ### Mainline BSP specific overrides |
203 | ####### | 206 | ####### |
@@ -238,6 +241,8 @@ MACHINEOVERRIDES_EXTENDER:mx8qxp:use-mainline-bsp = "imx-generic-bsp:imx-mainlin | |||
238 | MACHINEOVERRIDES_EXTENDER:mx8dx:use-mainline-bsp = "imx-generic-bsp:imx-mainline-bsp:mx8-generic-bsp:mx8-mainline-bsp:mx8x-generic-bsp:mx8x-mainline-bsp:mx8dx-generic-bsp:mx8dx-mainline-bsp" | 241 | MACHINEOVERRIDES_EXTENDER:mx8dx:use-mainline-bsp = "imx-generic-bsp:imx-mainline-bsp:mx8-generic-bsp:mx8-mainline-bsp:mx8x-generic-bsp:mx8x-mainline-bsp:mx8dx-generic-bsp:mx8dx-mainline-bsp" |
239 | MACHINEOVERRIDES_EXTENDER:mx8dxl:use-mainline-bsp = "imx-generic-bsp:imx-mainline-bsp:mx8-generic-bsp:mx8-mainline-bsp:mx8x-generic-bsp:mx8x-mainline-bsp:mx8dxl-generic-bsp:mx8dxl-mainline-bsp" | 242 | MACHINEOVERRIDES_EXTENDER:mx8dxl:use-mainline-bsp = "imx-generic-bsp:imx-mainline-bsp:mx8-generic-bsp:mx8-mainline-bsp:mx8x-generic-bsp:mx8x-mainline-bsp:mx8dxl-generic-bsp:mx8dxl-mainline-bsp" |
240 | 243 | ||
244 | MACHINEOVERRIDES_EXTENDER:mx8ulp:use-mainline-bsp = "imx-generic-bsp:imx-mainline-bsp:mx8-generic-bsp:mx8-mainline-bsp:mx8ulp-generic-bsp:mx8ulp-mainline-bsp" | ||
245 | |||
241 | MACHINEOVERRIDES_EXTENDER_FILTER_OUT = " \ | 246 | MACHINEOVERRIDES_EXTENDER_FILTER_OUT = " \ |
242 | mx6 \ | 247 | mx6 \ |
243 | mx6q \ | 248 | mx6q \ |
@@ -265,6 +270,7 @@ MACHINEOVERRIDES_EXTENDER_FILTER_OUT = " \ | |||
265 | mx8qxp \ | 270 | mx8qxp \ |
266 | mx8dx \ | 271 | mx8dx \ |
267 | mx8dxl \ | 272 | mx8dxl \ |
273 | mx8ulp \ | ||
268 | " | 274 | " |
269 | 275 | ||
270 | MACHINEOVERRIDES_FILTERED_OUT_QA_ERROR = "%s overrides cannot be used and need conversion to use the new BSP-specific overrides. Check 'meta-freescale/scripts/convert-bsp-specific-overrides'." | 276 | MACHINEOVERRIDES_FILTERED_OUT_QA_ERROR = "%s overrides cannot be used and need conversion to use the new BSP-specific overrides. Check 'meta-freescale/scripts/convert-bsp-specific-overrides'." |
@@ -290,6 +296,7 @@ MACHINE_SOCARCH_SUFFIX:mx8mq-nxp-bsp = "-mx8m" | |||
290 | MACHINE_SOCARCH_SUFFIX:mx8qxp-nxp-bsp = "-mx8" | 296 | MACHINE_SOCARCH_SUFFIX:mx8qxp-nxp-bsp = "-mx8" |
291 | MACHINE_SOCARCH_SUFFIX:mx8dx-nxp-bsp = "-mx8" | 297 | MACHINE_SOCARCH_SUFFIX:mx8dx-nxp-bsp = "-mx8" |
292 | MACHINE_SOCARCH_SUFFIX:mx8dxl-nxp-bsp = "-mx8xl" | 298 | MACHINE_SOCARCH_SUFFIX:mx8dxl-nxp-bsp = "-mx8xl" |
299 | MACHINE_SOCARCH_SUFFIX:mx8ulp-nxp-bsp = "-mx8ulp" | ||
293 | 300 | ||
294 | # For Mainline we use a single SoC suffix as we don't have different build options | 301 | # For Mainline we use a single SoC suffix as we don't have different build options |
295 | MACHINE_SOCARCH_SUFFIX:imx-mainline-bsp = "-imx" | 302 | MACHINE_SOCARCH_SUFFIX:imx-mainline-bsp = "-imx" |
@@ -364,6 +371,7 @@ IMX_EXTRA_FIRMWARE ?= "" | |||
364 | IMX_EXTRA_FIRMWARE:mx8-generic-bsp = "firmware-imx-8 imx-sc-firmware imx-seco" | 371 | IMX_EXTRA_FIRMWARE:mx8-generic-bsp = "firmware-imx-8 imx-sc-firmware imx-seco" |
365 | IMX_EXTRA_FIRMWARE:mx8m-generic-bsp = "firmware-imx-8m" | 372 | IMX_EXTRA_FIRMWARE:mx8m-generic-bsp = "firmware-imx-8m" |
366 | IMX_EXTRA_FIRMWARE:mx8x-generic-bsp = "imx-sc-firmware imx-seco" | 373 | IMX_EXTRA_FIRMWARE:mx8x-generic-bsp = "imx-sc-firmware imx-seco" |
374 | IMX_EXTRA_FIRMWARE:mx8ulp-generic-bsp = "firmware-upower firmware-sentinel" | ||
367 | 375 | ||
368 | # Firmware | 376 | # Firmware |
369 | MACHINE_FIRMWARE ?= "" | 377 | MACHINE_FIRMWARE ?= "" |
@@ -449,6 +457,7 @@ MACHINE_GSTREAMER_1_0_PLUGIN:mx8mq-nxp-bsp ?= "gstreamer1.0-plugins-imx-meta" | |||
449 | MACHINE_GSTREAMER_1_0_PLUGIN:mx8qm-nxp-bsp ?= "imx-gst1.0-plugin" | 457 | MACHINE_GSTREAMER_1_0_PLUGIN:mx8qm-nxp-bsp ?= "imx-gst1.0-plugin" |
450 | MACHINE_GSTREAMER_1_0_PLUGIN:mx8qxp-nxp-bsp ?= "imx-gst1.0-plugin" | 458 | MACHINE_GSTREAMER_1_0_PLUGIN:mx8qxp-nxp-bsp ?= "imx-gst1.0-plugin" |
451 | MACHINE_GSTREAMER_1_0_PLUGIN:mx8dx-nxp-bsp ?= "imx-gst1.0-plugin" | 459 | MACHINE_GSTREAMER_1_0_PLUGIN:mx8dx-nxp-bsp ?= "imx-gst1.0-plugin" |
460 | MACHINE_GSTREAMER_1_0_PLUGIN:mx8ulp-nxp-bsp ?= "imx-gst1.0-plugin" | ||
452 | 461 | ||
453 | PREFERRED_VERSION_gstreamer1.0:mx8-nxp-bsp ??= "1.20.3.imx" | 462 | PREFERRED_VERSION_gstreamer1.0:mx8-nxp-bsp ??= "1.20.3.imx" |
454 | PREFERRED_VERSION_gstreamer1.0-plugins-base:mx8-nxp-bsp ??= "1.20.3.imx" | 463 | PREFERRED_VERSION_gstreamer1.0-plugins-base:mx8-nxp-bsp ??= "1.20.3.imx" |
diff --git a/conf/machine/include/imx8ulp-evk.inc b/conf/machine/include/imx8ulp-evk.inc new file mode 100644 index 00000000..23269530 --- /dev/null +++ b/conf/machine/include/imx8ulp-evk.inc | |||
@@ -0,0 +1,44 @@ | |||
1 | MACHINEOVERRIDES =. "mx8:mx8ulp:" | ||
2 | |||
3 | require conf/machine/include/imx-base.inc | ||
4 | require conf/machine/include/arm/armv8a/tune-cortexa35.inc | ||
5 | |||
6 | MACHINE_FEATURES += "pci wifi bluetooth optee jailhouse" | ||
7 | |||
8 | KERNEL_DEVICETREE = " \ | ||
9 | freescale/${KERNEL_DEVICETREE_BASENAME}.dtb \ | ||
10 | " | ||
11 | |||
12 | IMX_DEFAULT_BOOTLOADER:use-nxp-bsp = "u-boot-imx" | ||
13 | IMX_DEFAULT_BOOTLOADER:use-mainline-bsp = "u-boot-fslc" | ||
14 | |||
15 | LOADADDR = "" | ||
16 | UBOOT_SUFFIX = "bin" | ||
17 | UBOOT_MAKE_TARGET = "" | ||
18 | |||
19 | SPL_BINARY = "spl/u-boot-spl.bin" | ||
20 | |||
21 | UBOOT_CONFIG ??= "sd" | ||
22 | UBOOT_CONFIG[sd] = "${UBOOT_CONFIG_BASENAME}_defconfig,sdcard" | ||
23 | UBOOT_CONFIG[fspi] = "${UBOOT_CONFIG_BASENAME}_defconfig" | ||
24 | UBOOT_CONFIG[nd] = "${UBOOT_CONFIG_BASENAME}_nd_defconfig" | ||
25 | |||
26 | # Set ATF platform name | ||
27 | ATF_PLATFORM = "imx8ulp" | ||
28 | |||
29 | IMXBOOT_TARGETS_SD = "flash_singleboot flash_dualboot" | ||
30 | IMXBOOT_TARGETS_FSPI = "flash_dualboot_flexspi" | ||
31 | IMXBOOT_TARGETS_ND = "" | ||
32 | |||
33 | IMXBOOT_TARGETS = "${@bb.utils.contains('UBOOT_CONFIG', 'sd', '${IMXBOOT_TARGETS_SD}', \ | ||
34 | bb.utils.contains('UBOOT_CONFIG', 'fspi', '${IMXBOOT_TARGETS_FSPI}', \ | ||
35 | '${IMXBOOT_TARGETS_ND}', d), d)}" | ||
36 | |||
37 | IMX_BOOT_SOC_TARGET = "iMX8ULP" | ||
38 | IMX_BOOT_SEEK = "32" | ||
39 | |||
40 | # We have to disable SERIAL_CONSOLE due to auto-serial-console | ||
41 | SERIAL_CONSOLES = "115200;ttyLP1" | ||
42 | |||
43 | # Add additional firmware | ||
44 | MACHINE_FIRMWARE:append = " firmware-imx-epdc" | ||
diff --git a/recipes-bsp/firmware-sentinel/firmware-sentinel_0.8.bb b/recipes-bsp/firmware-sentinel/firmware-sentinel_0.8.bb new file mode 100644 index 00000000..0ea56f98 --- /dev/null +++ b/recipes-bsp/firmware-sentinel/firmware-sentinel_0.8.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | # Copyright 2021-2022 NXP | ||
2 | SUMMARY = "NXP i.MX Sentinel firmware" | ||
3 | DESCRIPTION = "Firmware for i.MX Sentinel Security Controller" | ||
4 | SECTION = "base" | ||
5 | LICENSE = "Proprietary" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe" | ||
7 | |||
8 | inherit fsl-eula-unpack use-imx-security-controller-firmware deploy nopackages | ||
9 | |||
10 | SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true" | ||
11 | SRC_URI[md5sum] = "be47a5e59c1192ee36246af97d5d1532" | ||
12 | SRC_URI[sha256sum] = "1003d4c6773c153ea341911a74e25c249423644f70f3d8f8d085599e00770b3f" | ||
13 | |||
14 | do_compile[noexec] = "1" | ||
15 | do_install[noexec] = "1" | ||
16 | |||
17 | do_deploy () { | ||
18 | # Deploy the related firmware to be package by imx-boot | ||
19 | install -m 0644 ${S}/${SECO_FIRMWARE_NAME} ${DEPLOYDIR} | ||
20 | } | ||
21 | addtask deploy after do_install before do_build | ||
22 | |||
23 | COMPATIBLE_MACHINE = "(mx8ulp-nxp-bsp)" | ||
diff --git a/recipes-bsp/firmware-upower/firmware-upower_1.1.0.bb b/recipes-bsp/firmware-upower/firmware-upower_1.1.0.bb new file mode 100644 index 00000000..f21de75a --- /dev/null +++ b/recipes-bsp/firmware-upower/firmware-upower_1.1.0.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | # Copyright 2021-2022 NXP | ||
2 | DESCRIPTION = "NXP i.MX uPower firmware" | ||
3 | LICENSE = "Proprietary" | ||
4 | SECTION = "BSP" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe" | ||
6 | |||
7 | SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true" | ||
8 | |||
9 | S = "${WORKDIR}/${PN}-${PV}" | ||
10 | |||
11 | inherit fsl-eula-unpack pkgconfig deploy | ||
12 | |||
13 | SRC_URI[md5sum] = "d2cbe8d2f8fa170e5d48c599c4caac5e" | ||
14 | SRC_URI[sha256sum] = "c02595917744769abe810107a08506e4055b8077b5fc4ed17c353b833756c8b0" | ||
15 | |||
16 | do_configure[noexec] = "1" | ||
17 | |||
18 | do_compile[noexec] = "1" | ||
19 | |||
20 | do_install[noexec] = "1" | ||
21 | |||
22 | BOOT_TOOLS = "imx-boot-tools" | ||
23 | |||
24 | do_deploy () { | ||
25 | # Deploy the related firmware to be package by imx-boot | ||
26 | install -d ${DEPLOYDIR}/${BOOT_TOOLS} | ||
27 | install -m 0644 ${S}/${UPOWER_FIRMWARE_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}/upower.bin | ||
28 | } | ||
29 | addtask deploy after do_install before do_build | ||
30 | |||
31 | COMPATIBLE_MACHINE = "(mx8ulp-nxp-bsp)" | ||
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb index 5c20fac8..71f8b25d 100644 --- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb +++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb | |||
@@ -65,12 +65,16 @@ SOC_FAMILY = "INVALID" | |||
65 | SOC_FAMILY:mx8-generic-bsp = "mx8" | 65 | SOC_FAMILY:mx8-generic-bsp = "mx8" |
66 | SOC_FAMILY:mx8m-generic-bsp = "mx8m" | 66 | SOC_FAMILY:mx8m-generic-bsp = "mx8m" |
67 | SOC_FAMILY:mx8x-generic-bsp = "mx8x" | 67 | SOC_FAMILY:mx8x-generic-bsp = "mx8x" |
68 | SOC_FAMILY:mx8ulp-nxp-bsp = "mx8ulp" | ||
68 | 69 | ||
69 | REV_OPTION ?= "" | 70 | REV_OPTION ?= "" |
70 | REV_OPTION:mx8qxp-generic-bsp = \ | 71 | REV_OPTION:mx8qxp-generic-bsp = \ |
71 | "${@bb.utils.contains('MACHINE_FEATURES', 'soc-revb0', '', \ | 72 | "${@bb.utils.contains('MACHINE_FEATURES', 'soc-revb0', '', \ |
72 | 'REV=C0', d)}" | 73 | 'REV=C0', d)}" |
73 | REV_OPTION:mx8dx-generic-bsp = "REV=C0" | 74 | REV_OPTION:mx8dx-generic-bsp = "REV=C0" |
75 | REV_OPTION:mx8ulp-generic-bsp = \ | ||
76 | "${@bb.utils.contains('MACHINE_FEATURES', 'soc-reva0', '', \ | ||
77 | 'REV=A1', d)}" | ||
74 | 78 | ||
75 | do_uboot_assemble_fitimage:prepend:imx-generic-bsp() { | 79 | do_uboot_assemble_fitimage:prepend:imx-generic-bsp() { |
76 | for config in ${UBOOT_MACHINE}; do | 80 | for config in ${UBOOT_MACHINE}; do |
@@ -121,6 +125,19 @@ compile_mx8x() { | |||
121 | ${BOOT_STAGING}/u-boot-spl.bin | 125 | ${BOOT_STAGING}/u-boot-spl.bin |
122 | fi | 126 | fi |
123 | } | 127 | } |
128 | |||
129 | compile_mx8ulp() { | ||
130 | bbnote 8ULP boot binary build | ||
131 | cp ${DEPLOY_DIR_IMAGE}/${SECO_FIRMWARE_NAME} ${BOOT_STAGING}/ | ||
132 | cp ${DEPLOY_DIR_IMAGE}/${ATF_MACHINE_NAME} ${BOOT_STAGING}/bl31.bin | ||
133 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/upower.bin ${BOOT_STAGING}/upower.bin | ||
134 | cp ${DEPLOY_DIR_IMAGE}/${UBOOT_NAME} ${BOOT_STAGING}/u-boot.bin | ||
135 | if [ -e ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG} ] ; then | ||
136 | cp ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG} \ | ||
137 | ${BOOT_STAGING}/u-boot-spl.bin | ||
138 | fi | ||
139 | } | ||
140 | |||
124 | do_compile() { | 141 | do_compile() { |
125 | # mkimage for i.MX8 | 142 | # mkimage for i.MX8 |
126 | # Copy TEE binary to SoC target folder to mkimage | 143 | # Copy TEE binary to SoC target folder to mkimage |
@@ -180,6 +197,17 @@ deploy_mx8x() { | |||
180 | ${DEPLOYDIR}/${BOOT_TOOLS} | 197 | ${DEPLOYDIR}/${BOOT_TOOLS} |
181 | fi | 198 | fi |
182 | } | 199 | } |
200 | |||
201 | deploy_mx8ulp() { | ||
202 | install -d ${DEPLOYDIR}/${BOOT_TOOLS} | ||
203 | install -m 0644 ${BOOT_STAGING}/${SECO_FIRMWARE_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} | ||
204 | install -m 0755 ${S}/${TOOLS_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} | ||
205 | if [ -e ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG} ] ; then | ||
206 | install -m 0644 ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG} \ | ||
207 | ${DEPLOYDIR}/${BOOT_TOOLS} | ||
208 | fi | ||
209 | } | ||
210 | |||
183 | do_deploy() { | 211 | do_deploy() { |
184 | deploy_${SOC_FAMILY} | 212 | deploy_${SOC_FAMILY} |
185 | # copy the sc fw, dcd and uboot to deploy path | 213 | # copy the sc fw, dcd and uboot to deploy path |