diff options
-rw-r--r-- | conf/layer.conf | 2 | ||||
-rw-r--r-- | recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc | 9 | ||||
-rw-r--r-- | recipes-graphics/wayland/weston_10.0.0.imx.bb | 3 |
3 files changed, 11 insertions, 3 deletions
diff --git a/conf/layer.conf b/conf/layer.conf index a3c8af2c..e57c3b59 100644 --- a/conf/layer.conf +++ b/conf/layer.conf | |||
@@ -8,7 +8,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \ | |||
8 | BBFILE_COLLECTIONS += "freescale-layer" | 8 | BBFILE_COLLECTIONS += "freescale-layer" |
9 | BBFILE_PATTERN_freescale-layer := "^${LAYERDIR}/" | 9 | BBFILE_PATTERN_freescale-layer := "^${LAYERDIR}/" |
10 | BBFILE_PRIORITY_freescale-layer = "5" | 10 | BBFILE_PRIORITY_freescale-layer = "5" |
11 | LAYERSERIES_COMPAT_freescale-layer = "kirkstone" | 11 | LAYERSERIES_COMPAT_freescale-layer = "kirkstone langdale" |
12 | 12 | ||
13 | # Add the Freescale-specific licenses into the metadata | 13 | # Add the Freescale-specific licenses into the metadata |
14 | LICENSE_PATH += "${LAYERDIR}/custom-licenses" | 14 | LICENSE_PATH += "${LAYERDIR}/custom-licenses" |
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc index 474ddf35..0702600c 100644 --- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc +++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc | |||
@@ -96,7 +96,6 @@ PACKAGES_GBM:mx8-nxp-bsp = "libgbm-imx libgbm-imx-dev" | |||
96 | 96 | ||
97 | PACKAGES_OPENCL = "libopencl-imx libopencl-imx-dev libclc-imx libclc-imx-dev" | 97 | PACKAGES_OPENCL = "libopencl-imx libopencl-imx-dev libclc-imx libclc-imx-dev" |
98 | PACKAGES_OPENCL:mx7-nxp-bsp = "" | 98 | PACKAGES_OPENCL:mx7-nxp-bsp = "" |
99 | PACKAGES_OPENCL:mx8mm-nxp-bsp = "" | ||
100 | 99 | ||
101 | PACKAGES_OPENVX = "" | 100 | PACKAGES_OPENVX = "" |
102 | PACKAGES_OPENVX:mx8qm-nxp-bsp = "libopenvx-imx libopenvx-imx-dev" | 101 | PACKAGES_OPENVX:mx8qm-nxp-bsp = "libopenvx-imx libopenvx-imx-dev" |
@@ -214,7 +213,9 @@ do_install () { | |||
214 | # Framebuffer backend for i.MX 8 and beyond | 213 | # Framebuffer backend for i.MX 8 and beyond |
215 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/egl.pc ${D}${libdir}/pkgconfig/egl.pc | 214 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/egl.pc ${D}${libdir}/pkgconfig/egl.pc |
216 | cp -r ${S}/gpu-core/usr/lib/wayland/* ${D}${libdir} | 215 | cp -r ${S}/gpu-core/usr/lib/wayland/* ${D}${libdir} |
216 | set -f | ||
217 | for f in ${FILES:libvdk-imx} ${FILES:libvdk-imx-dev}; do | 217 | for f in ${FILES:libvdk-imx} ${FILES:libvdk-imx-dev}; do |
218 | set +f | ||
218 | rm -rf ${D}/$f | 219 | rm -rf ${D}/$f |
219 | done | 220 | done |
220 | rm -rf \ | 221 | rm -rf \ |
@@ -228,7 +229,9 @@ do_install () { | |||
228 | fi | 229 | fi |
229 | 230 | ||
230 | if [ -z "${PACKAGES_OPENCL}" ]; then | 231 | if [ -z "${PACKAGES_OPENCL}" ]; then |
232 | set -f | ||
231 | for f in ${FILES:libopencl-imx} ${FILES:libopencl-imx-dev} ${FILES:libclc-imx} ${FILES:libclc-imx-dev}; do | 233 | for f in ${FILES:libopencl-imx} ${FILES:libopencl-imx-dev} ${FILES:libclc-imx} ${FILES:libclc-imx-dev}; do |
234 | set +f | ||
232 | rm -rf ${D}$f | 235 | rm -rf ${D}$f |
233 | done | 236 | done |
234 | rm -rf ${D}/opt/viv_samples/cl11 | 237 | rm -rf ${D}/opt/viv_samples/cl11 |
@@ -239,7 +242,9 @@ do_install () { | |||
239 | fi | 242 | fi |
240 | 243 | ||
241 | if [ -z "${PACKAGES_OPENVX}" ]; then | 244 | if [ -z "${PACKAGES_OPENVX}" ]; then |
245 | set -f | ||
242 | for f in ${FILES:libopenvx-imx} ${FILES:libopenvx-imx-dev}; do | 246 | for f in ${FILES:libopenvx-imx} ${FILES:libopenvx-imx-dev}; do |
247 | set +f | ||
243 | rm -rf ${D}$f | 248 | rm -rf ${D}$f |
244 | done | 249 | done |
245 | fi | 250 | fi |
@@ -255,7 +260,9 @@ do_install () { | |||
255 | ln -s libvulkan_VSI.so.$FULL ${D}${libdir}/libvulkan_VSI.so.$MAJOR | 260 | ln -s libvulkan_VSI.so.$FULL ${D}${libdir}/libvulkan_VSI.so.$MAJOR |
256 | ln -s libvulkan_VSI.so.$FULL ${D}${libdir}/libvulkan_VSI.so | 261 | ln -s libvulkan_VSI.so.$FULL ${D}${libdir}/libvulkan_VSI.so |
257 | if [ -z "${PACKAGES_VULKAN}" ]; then | 262 | if [ -z "${PACKAGES_VULKAN}" ]; then |
263 | set -f | ||
258 | for f in ${FILES:libvulkan-imx} ${FILES:libvulkan-imx-dev}; do | 264 | for f in ${FILES:libvulkan-imx} ${FILES:libvulkan-imx-dev}; do |
265 | set +f | ||
259 | rm -rf ${D}$f | 266 | rm -rf ${D}$f |
260 | done | 267 | done |
261 | fi | 268 | fi |
diff --git a/recipes-graphics/wayland/weston_10.0.0.imx.bb b/recipes-graphics/wayland/weston_10.0.0.imx.bb index 676c19e6..cc60b4d7 100644 --- a/recipes-graphics/wayland/weston_10.0.0.imx.bb +++ b/recipes-graphics/wayland/weston_10.0.0.imx.bb | |||
@@ -34,6 +34,7 @@ require ${THISDIR}/required-distro-features.inc | |||
34 | 34 | ||
35 | DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0" | 35 | DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0" |
36 | DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native" | 36 | DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native" |
37 | DEPENDS:append:imxfbdev = " libdrm" | ||
37 | 38 | ||
38 | LDFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'lto', '-Wl,-z,undefs', '', d)}" | 39 | LDFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'lto', '-Wl,-z,undefs', '', d)}" |
39 | 40 | ||
@@ -177,7 +178,7 @@ PACKAGECONFIG_OPENGL:imxgpu2d = "" | |||
177 | PACKAGECONFIG_OPENGL:imxgpu3d = "opengl" | 178 | PACKAGECONFIG_OPENGL:imxgpu3d = "opengl" |
178 | 179 | ||
179 | PACKAGECONFIG:remove = "wayland x11" | 180 | PACKAGECONFIG:remove = "wayland x11" |
180 | PACKAGECONFIG:append = "${@bb.utils.filter('DISTRO_FEATURES', '${PACKAGECONFIG_OPENGL}', d)}" | 181 | PACKAGECONFIG:append = " ${@bb.utils.filter('DISTRO_FEATURES', '${PACKAGECONFIG_OPENGL}', d)}" |
181 | 182 | ||
182 | PACKAGECONFIG:remove:imxfbdev = "kms" | 183 | PACKAGECONFIG:remove:imxfbdev = "kms" |
183 | PACKAGECONFIG:append:imxfbdev = " fbdev clients" | 184 | PACKAGECONFIG:append:imxfbdev = " fbdev clients" |