diff options
-rw-r--r-- | classes/fsl-dynamic-packagearch.bbclass | 11 | ||||
-rw-r--r-- | conf/layer.conf | 2 | ||||
-rw-r--r-- | conf/machine/include/imx-base.inc | 12 | ||||
-rw-r--r-- | recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc | 23 | ||||
-rw-r--r-- | recipes-graphics/vulkan/vulkan-loader_%.bbappend | 2 | ||||
-rw-r--r-- | recipes-graphics/wayland/weston_10.0.0.imx.bb | 3 |
6 files changed, 39 insertions, 14 deletions
diff --git a/classes/fsl-dynamic-packagearch.bbclass b/classes/fsl-dynamic-packagearch.bbclass index 9fcf37be..6cb0c0a9 100644 --- a/classes/fsl-dynamic-packagearch.bbclass +++ b/classes/fsl-dynamic-packagearch.bbclass | |||
@@ -54,6 +54,17 @@ python __anonymous () { | |||
54 | if not machine_socarch in cur_package_archs: | 54 | if not machine_socarch in cur_package_archs: |
55 | d.appendVar("PACKAGE_EXTRA_ARCHS", " %s" % machine_socarch) | 55 | d.appendVar("PACKAGE_EXTRA_ARCHS", " %s" % machine_socarch) |
56 | 56 | ||
57 | multilib_variants = (d.getVar("MULTILIB_VARIANTS") or "").split() | ||
58 | for variant in multilib_variants: | ||
59 | defaulttune = d.getVar("DEFAULTTUNE:virtclass-multilib-" + variant) | ||
60 | if defaulttune: | ||
61 | package_extra_archs_tune_archs = (d.getVar("PACKAGE_EXTRA_ARCHS:tune-" + defaulttune) or "").split() | ||
62 | arch_suffix = d.getVar("MACHINE_SOCARCH_SUFFIX") | ||
63 | for arch in package_extra_archs_tune_archs: | ||
64 | socarch = arch + arch_suffix | ||
65 | if not socarch in cur_package_archs: | ||
66 | d.appendVar("PACKAGE_EXTRA_ARCHS", " %s" % socarch ) | ||
67 | |||
57 | if d.getVar("TUNE_ARCH") == "arm": | 68 | if d.getVar("TUNE_ARCH") == "arm": |
58 | # For ARM we have two possible machine_socarch values, one for the arm and one for the thumb instruction set | 69 | # For ARM we have two possible machine_socarch values, one for the arm and one for the thumb instruction set |
59 | # add the other value to extra archs also, so that a image recipe searches both for packages. | 70 | # add the other value to extra archs also, so that a image recipe searches both for packages. |
diff --git a/conf/layer.conf b/conf/layer.conf index a3c8af2c..e57c3b59 100644 --- a/conf/layer.conf +++ b/conf/layer.conf | |||
@@ -8,7 +8,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \ | |||
8 | BBFILE_COLLECTIONS += "freescale-layer" | 8 | BBFILE_COLLECTIONS += "freescale-layer" |
9 | BBFILE_PATTERN_freescale-layer := "^${LAYERDIR}/" | 9 | BBFILE_PATTERN_freescale-layer := "^${LAYERDIR}/" |
10 | BBFILE_PRIORITY_freescale-layer = "5" | 10 | BBFILE_PRIORITY_freescale-layer = "5" |
11 | LAYERSERIES_COMPAT_freescale-layer = "kirkstone" | 11 | LAYERSERIES_COMPAT_freescale-layer = "kirkstone langdale" |
12 | 12 | ||
13 | # Add the Freescale-specific licenses into the metadata | 13 | # Add the Freescale-specific licenses into the metadata |
14 | LICENSE_PATH += "${LAYERDIR}/custom-licenses" | 14 | LICENSE_PATH += "${LAYERDIR}/custom-licenses" |
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc index f1257c24..a0d6be13 100644 --- a/conf/machine/include/imx-base.inc +++ b/conf/machine/include/imx-base.inc | |||
@@ -187,15 +187,15 @@ MACHINEOVERRIDES_EXTENDER:mx7ulp:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxf | |||
187 | 187 | ||
188 | MACHINEOVERRIDES_EXTENDER:vf:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:vf-generic-bsp:vf-nxp-bsp" | 188 | MACHINEOVERRIDES_EXTENDER:vf:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:vf-generic-bsp:vf-nxp-bsp" |
189 | 189 | ||
190 | MACHINEOVERRIDES_EXTENDER:mx8qm:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxdpu:imxgpu:imxgpu2d:imxgpu3d:mx8-generic-bsp:mx8-nxp-bsp:mx8qm-generic-bsp:mx8qm-nxp-bsp" | 190 | MACHINEOVERRIDES_EXTENDER:mx8qm:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxdpu:imxgpu:imxgpu2d:imxgpu3d:imxvulkan:mx8-generic-bsp:mx8-nxp-bsp:mx8qm-generic-bsp:mx8qm-nxp-bsp" |
191 | 191 | ||
192 | MACHINEOVERRIDES_EXTENDER:mx8mm:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxvpu:imxgpu:imxgpu2d:imxgpu3d:mx8-generic-bsp:mx8-nxp-bsp:mx8m-generic-bsp:mx8m-nxp-bsp:mx8mm-generic-bsp:mx8mm-nxp-bsp" | 192 | MACHINEOVERRIDES_EXTENDER:mx8mm:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxvpu:imxgpu:imxgpu2d:imxgpu3d:mx8-generic-bsp:mx8-nxp-bsp:mx8m-generic-bsp:mx8m-nxp-bsp:mx8mm-generic-bsp:mx8mm-nxp-bsp" |
193 | MACHINEOVERRIDES_EXTENDER:mx8mn:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxgpu:imxgpu3d:mx8-generic-bsp:mx8-nxp-bsp:mx8m-generic-bsp:mx8m-nxp-bsp:mx8mn-generic-bsp:mx8mn-nxp-bsp" | 193 | MACHINEOVERRIDES_EXTENDER:mx8mn:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxgpu:imxgpu3d:imxvulkan:mx8-generic-bsp:mx8-nxp-bsp:mx8m-generic-bsp:mx8m-nxp-bsp:mx8mn-generic-bsp:mx8mn-nxp-bsp" |
194 | MACHINEOVERRIDES_EXTENDER:mx8mp:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxvpu:imxgpu:imxgpu2d:imxgpu3d:mx8-generic-bsp:mx8-nxp-bsp:mx8m-generic-bsp:mx8m-nxp-bsp:mx8mp-generic-bsp:mx8mp-nxp-bsp" | 194 | MACHINEOVERRIDES_EXTENDER:mx8mp:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxvpu:imxgpu:imxgpu2d:imxgpu3d:imxvulkan:mx8-generic-bsp:mx8-nxp-bsp:mx8m-generic-bsp:mx8m-nxp-bsp:mx8mp-generic-bsp:mx8mp-nxp-bsp" |
195 | MACHINEOVERRIDES_EXTENDER:mx8mq:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxvpu:imxgpu:imxgpu3d:mx8-generic-bsp:mx8-nxp-bsp:mx8m-generic-bsp:mx8m-nxp-bsp:mx8mq-generic-bsp:mx8mq-nxp-bsp" | 195 | MACHINEOVERRIDES_EXTENDER:mx8mq:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxvpu:imxgpu:imxgpu3d:imxvulkan:mx8-generic-bsp:mx8-nxp-bsp:mx8m-generic-bsp:mx8m-nxp-bsp:mx8mq-generic-bsp:mx8mq-nxp-bsp" |
196 | 196 | ||
197 | MACHINEOVERRIDES_EXTENDER:mx8qxp:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxdpu:imxgpu:imxgpu2d:imxgpu3d:mx8-generic-bsp:mx8-nxp-bsp:mx8x-generic-bsp:mx8x-nxp-bsp:mx8qxp-generic-bsp:mx8qxp-nxp-bsp" | 197 | MACHINEOVERRIDES_EXTENDER:mx8qxp:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxdpu:imxgpu:imxgpu2d:imxgpu3d:imxvulkan:mx8-generic-bsp:mx8-nxp-bsp:mx8x-generic-bsp:mx8x-nxp-bsp:mx8qxp-generic-bsp:mx8qxp-nxp-bsp" |
198 | MACHINEOVERRIDES_EXTENDER:mx8dx:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxdpu:imxgpu:imxgpu2d:imxgpu3d:mx8-generic-bsp:mx8-nxp-bsp:mx8x-generic-bsp:mx8x-nxp-bsp:mx8dx-generic-bsp:mx8dx-nxp-bsp" | 198 | MACHINEOVERRIDES_EXTENDER:mx8dx:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxdrm:imxdpu:imxgpu:imxgpu2d:imxgpu3d:imxvulkan:mx8-generic-bsp:mx8-nxp-bsp:mx8x-generic-bsp:mx8x-nxp-bsp:mx8dx-generic-bsp:mx8dx-nxp-bsp" |
199 | MACHINEOVERRIDES_EXTENDER:mx8dxl:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxfbdev:mx8dxl-generic-bsp:mx8-generic-bsp:mx8-nxp-bsp:mx8x-generic-bsp:mx8x-nxp-bsp:mx8dxl-nxp-bsp" | 199 | MACHINEOVERRIDES_EXTENDER:mx8dxl:use-nxp-bsp = "imx-generic-bsp:imx-nxp-bsp:imxfbdev:mx8dxl-generic-bsp:mx8-generic-bsp:mx8-nxp-bsp:mx8x-generic-bsp:mx8x-nxp-bsp:mx8dxl-nxp-bsp" |
200 | 200 | ||
201 | ####### | 201 | ####### |
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc index 474ddf35..4cbb7ba6 100644 --- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc +++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc | |||
@@ -50,9 +50,14 @@ EXTRA_PROVIDES:append:imxgpu3d = " \ | |||
50 | EXTRA_PROVIDES:append:mx8-nxp-bsp = " \ | 50 | EXTRA_PROVIDES:append:mx8-nxp-bsp = " \ |
51 | virtual/libgbm \ | 51 | virtual/libgbm \ |
52 | " | 52 | " |
53 | |||
53 | PROVIDES_OPENGLES3 = "" | 54 | PROVIDES_OPENGLES3 = "" |
54 | PROVIDES_OPENGLES3:mx8-nxp-bsp = "virtual/libgles3" | 55 | PROVIDES_OPENGLES3:mx8-nxp-bsp = "virtual/libgles3" |
55 | PROVIDES_OPENGLES3:mx8mm-nxp-bsp = "" | 56 | PROVIDES_OPENGLES3:mx8mm-nxp-bsp = "" |
57 | |||
58 | # Note: OpenVX is fully supported on i.MX 8 QuadMax and 8 QuadPlus. | ||
59 | # However, only limited support is provided on other i.MX 8 machines | ||
60 | # as needed for i.MX machine learning packages. | ||
56 | PROVIDES_OPENVX = "" | 61 | PROVIDES_OPENVX = "" |
57 | PROVIDES_OPENVX:mx8-nxp-bsp = "virtual/libopenvx" | 62 | PROVIDES_OPENVX:mx8-nxp-bsp = "virtual/libopenvx" |
58 | PROVIDES_OPENVX:mx8mm-nxp-bsp = "" | 63 | PROVIDES_OPENVX:mx8mm-nxp-bsp = "" |
@@ -96,14 +101,14 @@ PACKAGES_GBM:mx8-nxp-bsp = "libgbm-imx libgbm-imx-dev" | |||
96 | 101 | ||
97 | PACKAGES_OPENCL = "libopencl-imx libopencl-imx-dev libclc-imx libclc-imx-dev" | 102 | PACKAGES_OPENCL = "libopencl-imx libopencl-imx-dev libclc-imx libclc-imx-dev" |
98 | PACKAGES_OPENCL:mx7-nxp-bsp = "" | 103 | PACKAGES_OPENCL:mx7-nxp-bsp = "" |
99 | PACKAGES_OPENCL:mx8mm-nxp-bsp = "" | ||
100 | 104 | ||
101 | PACKAGES_OPENVX = "" | 105 | PACKAGES_OPENVX = \ |
102 | PACKAGES_OPENVX:mx8qm-nxp-bsp = "libopenvx-imx libopenvx-imx-dev" | 106 | "${@bb.utils.contains("PROVIDES_OPENVX", "virtual/libopenvx", \ |
107 | "libopenvx-imx libopenvx-imx-dev", "", d)}" | ||
103 | 108 | ||
104 | PACKAGES_VULKAN = "" | 109 | PACKAGES_VULKAN = "" |
105 | PACKAGES_VULKAN:aarch64 = "libvulkan-imx libvulkan-imx-dev" | 110 | PACKAGES_VULKAN:imxvulkan = "libvulkan-imx libvulkan-imx-dev" |
106 | PACKAGES_VULKAN:mx8mm-nxp-bsp = "" | 111 | |
107 | python __anonymous () { | 112 | python __anonymous () { |
108 | has_vivante_kernel_driver_support = (d.getVar('MACHINE_HAS_VIVANTE_KERNEL_DRIVER_SUPPORT') or '0') | 113 | has_vivante_kernel_driver_support = (d.getVar('MACHINE_HAS_VIVANTE_KERNEL_DRIVER_SUPPORT') or '0') |
109 | if has_vivante_kernel_driver_support != '1': | 114 | if has_vivante_kernel_driver_support != '1': |
@@ -214,7 +219,9 @@ do_install () { | |||
214 | # Framebuffer backend for i.MX 8 and beyond | 219 | # Framebuffer backend for i.MX 8 and beyond |
215 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/egl.pc ${D}${libdir}/pkgconfig/egl.pc | 220 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/egl.pc ${D}${libdir}/pkgconfig/egl.pc |
216 | cp -r ${S}/gpu-core/usr/lib/wayland/* ${D}${libdir} | 221 | cp -r ${S}/gpu-core/usr/lib/wayland/* ${D}${libdir} |
222 | set -f | ||
217 | for f in ${FILES:libvdk-imx} ${FILES:libvdk-imx-dev}; do | 223 | for f in ${FILES:libvdk-imx} ${FILES:libvdk-imx-dev}; do |
224 | set +f | ||
218 | rm -rf ${D}/$f | 225 | rm -rf ${D}/$f |
219 | done | 226 | done |
220 | rm -rf \ | 227 | rm -rf \ |
@@ -228,7 +235,9 @@ do_install () { | |||
228 | fi | 235 | fi |
229 | 236 | ||
230 | if [ -z "${PACKAGES_OPENCL}" ]; then | 237 | if [ -z "${PACKAGES_OPENCL}" ]; then |
238 | set -f | ||
231 | for f in ${FILES:libopencl-imx} ${FILES:libopencl-imx-dev} ${FILES:libclc-imx} ${FILES:libclc-imx-dev}; do | 239 | for f in ${FILES:libopencl-imx} ${FILES:libopencl-imx-dev} ${FILES:libclc-imx} ${FILES:libclc-imx-dev}; do |
240 | set +f | ||
232 | rm -rf ${D}$f | 241 | rm -rf ${D}$f |
233 | done | 242 | done |
234 | rm -rf ${D}/opt/viv_samples/cl11 | 243 | rm -rf ${D}/opt/viv_samples/cl11 |
@@ -239,7 +248,9 @@ do_install () { | |||
239 | fi | 248 | fi |
240 | 249 | ||
241 | if [ -z "${PACKAGES_OPENVX}" ]; then | 250 | if [ -z "${PACKAGES_OPENVX}" ]; then |
251 | set -f | ||
242 | for f in ${FILES:libopenvx-imx} ${FILES:libopenvx-imx-dev}; do | 252 | for f in ${FILES:libopenvx-imx} ${FILES:libopenvx-imx-dev}; do |
253 | set +f | ||
243 | rm -rf ${D}$f | 254 | rm -rf ${D}$f |
244 | done | 255 | done |
245 | fi | 256 | fi |
@@ -255,7 +266,9 @@ do_install () { | |||
255 | ln -s libvulkan_VSI.so.$FULL ${D}${libdir}/libvulkan_VSI.so.$MAJOR | 266 | ln -s libvulkan_VSI.so.$FULL ${D}${libdir}/libvulkan_VSI.so.$MAJOR |
256 | ln -s libvulkan_VSI.so.$FULL ${D}${libdir}/libvulkan_VSI.so | 267 | ln -s libvulkan_VSI.so.$FULL ${D}${libdir}/libvulkan_VSI.so |
257 | if [ -z "${PACKAGES_VULKAN}" ]; then | 268 | if [ -z "${PACKAGES_VULKAN}" ]; then |
269 | set -f | ||
258 | for f in ${FILES:libvulkan-imx} ${FILES:libvulkan-imx-dev}; do | 270 | for f in ${FILES:libvulkan-imx} ${FILES:libvulkan-imx-dev}; do |
271 | set +f | ||
259 | rm -rf ${D}$f | 272 | rm -rf ${D}$f |
260 | done | 273 | done |
261 | fi | 274 | fi |
diff --git a/recipes-graphics/vulkan/vulkan-loader_%.bbappend b/recipes-graphics/vulkan/vulkan-loader_%.bbappend index 90776168..722896ff 100644 --- a/recipes-graphics/vulkan/vulkan-loader_%.bbappend +++ b/recipes-graphics/vulkan/vulkan-loader_%.bbappend | |||
@@ -1,3 +1,3 @@ | |||
1 | # The i.MX implementation is dynamically loaded, so it requires an | 1 | # The i.MX implementation is dynamically loaded, so it requires an |
2 | # explicit runtime dependency. | 2 | # explicit runtime dependency. |
3 | RRECOMMENDS:${PN}:append:imxgpu = " libvulkan-imx" | 3 | RRECOMMENDS:${PN}:append:imxvulkan = " libvulkan-imx" |
diff --git a/recipes-graphics/wayland/weston_10.0.0.imx.bb b/recipes-graphics/wayland/weston_10.0.0.imx.bb index 676c19e6..cc60b4d7 100644 --- a/recipes-graphics/wayland/weston_10.0.0.imx.bb +++ b/recipes-graphics/wayland/weston_10.0.0.imx.bb | |||
@@ -34,6 +34,7 @@ require ${THISDIR}/required-distro-features.inc | |||
34 | 34 | ||
35 | DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0" | 35 | DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0" |
36 | DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native" | 36 | DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native" |
37 | DEPENDS:append:imxfbdev = " libdrm" | ||
37 | 38 | ||
38 | LDFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'lto', '-Wl,-z,undefs', '', d)}" | 39 | LDFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'lto', '-Wl,-z,undefs', '', d)}" |
39 | 40 | ||
@@ -177,7 +178,7 @@ PACKAGECONFIG_OPENGL:imxgpu2d = "" | |||
177 | PACKAGECONFIG_OPENGL:imxgpu3d = "opengl" | 178 | PACKAGECONFIG_OPENGL:imxgpu3d = "opengl" |
178 | 179 | ||
179 | PACKAGECONFIG:remove = "wayland x11" | 180 | PACKAGECONFIG:remove = "wayland x11" |
180 | PACKAGECONFIG:append = "${@bb.utils.filter('DISTRO_FEATURES', '${PACKAGECONFIG_OPENGL}', d)}" | 181 | PACKAGECONFIG:append = " ${@bb.utils.filter('DISTRO_FEATURES', '${PACKAGECONFIG_OPENGL}', d)}" |
181 | 182 | ||
182 | PACKAGECONFIG:remove:imxfbdev = "kms" | 183 | PACKAGECONFIG:remove:imxfbdev = "kms" |
183 | PACKAGECONFIG:append:imxfbdev = " fbdev clients" | 184 | PACKAGECONFIG:append:imxfbdev = " fbdev clients" |