diff options
4 files changed, 80 insertions, 3 deletions
diff --git a/recipes-bsp/imx-secure-enclave/imx-secure-enclave_git.bb b/recipes-bsp/imx-secure-enclave/imx-secure-enclave_git.bb new file mode 100644 index 00000000..b065fc55 --- /dev/null +++ b/recipes-bsp/imx-secure-enclave/imx-secure-enclave_git.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | SUMMARY = "NXP i.MX Secure Enclave Userspace Library" | ||
2 | DESCRIPTION = "NXP i.MX Secure Enclave Userspace Library" | ||
3 | SECTION = "base" | ||
4 | |||
5 | LICENSE = "BSD-3-Clause" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8636bd68fc00cc6a3809b7b58b45f982" | ||
7 | |||
8 | DEPENDS = "openssl" | ||
9 | |||
10 | inherit systemd | ||
11 | |||
12 | SRC_URI = "git://github.com/NXP/imx-secure-enclave.git;protocol=https;branch=lf-6.6.3_1.0.0" | ||
13 | SRCREV = "964affa2cb3f9f7fc85a6a18db60f9213f744495" | ||
14 | |||
15 | PV = "lf-6.6.3_1.0.0" | ||
16 | |||
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | EXTRA_OEMAKE += "PLAT=ele" | ||
20 | |||
21 | TARGET_CC_ARCH += "${LDFLAGS}" | ||
22 | |||
23 | do_install () { | ||
24 | oe_runmake DESTDIR=${D} install | ||
25 | rm -rf ${D}/usr/share | ||
26 | } | ||
27 | |||
28 | SYSTEMD_AUTO_ENABLE = "disable" | ||
29 | SYSTEMD_SERVICE:${PN} = "nvm_daemon.service" | ||
30 | |||
31 | COMPATIBLE_MACHINE = "(mx8ulp-nxp-bsp|mx9-nxp-bsp)" | ||
diff --git a/recipes-graphics/wayland/weston/0001-libweston-tools-Include-libgen.h-for-basename-signat.patch b/recipes-graphics/wayland/weston/0001-libweston-tools-Include-libgen.h-for-basename-signat.patch new file mode 100644 index 00000000..3f0b8ee0 --- /dev/null +++ b/recipes-graphics/wayland/weston/0001-libweston-tools-Include-libgen.h-for-basename-signat.patch | |||
@@ -0,0 +1,45 @@ | |||
1 | From 2a7c1797dd65467b7a0be63aa598307b92fb83b5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 14 Dec 2023 09:13:54 -0800 | ||
4 | Subject: [PATCH] libweston,tools: Include libgen.h for basename signature | ||
5 | |||
6 | Latest musl has removed the declaration from string.h [1] as it only | ||
7 | implements POSIX version alone and string.h in glibc implements GNU | ||
8 | version of basename. This now results in compile errors on musl. | ||
9 | |||
10 | This might be a warning with older compilers but it is error with | ||
11 | Clang-17+ as it treats -Wimplicit-function-declaration as error | ||
12 | |||
13 | [1] https://git.musl-libc.org/cgit/musl/commit/?id=725e17ed6dff4d0cd22487bb64470881e86a92e7 | ||
14 | |||
15 | Upstream-Status: Submitted [https://gitlab.freedesktop.org/wayland/weston/-/merge_requests/1420] | ||
16 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
17 | --- | ||
18 | libweston/backend-drm/libbacklight.c | 1 + | ||
19 | tools/zunitc/src/zunitc_impl.c | 1 + | ||
20 | 2 files changed, 2 insertions(+) | ||
21 | |||
22 | diff --git a/libweston/backend-drm/libbacklight.c b/libweston/backend-drm/libbacklight.c | ||
23 | index ca7f2d68..74690fa7 100644 | ||
24 | --- a/libweston/backend-drm/libbacklight.c | ||
25 | +++ b/libweston/backend-drm/libbacklight.c | ||
26 | @@ -41,6 +41,7 @@ | ||
27 | #include <drm.h> | ||
28 | #include <fcntl.h> | ||
29 | #include <malloc.h> | ||
30 | +#include <libgen.h> | ||
31 | #include <string.h> | ||
32 | #include <errno.h> | ||
33 | |||
34 | diff --git a/tools/zunitc/src/zunitc_impl.c b/tools/zunitc/src/zunitc_impl.c | ||
35 | index 18f03015..9b460fa0 100644 | ||
36 | --- a/tools/zunitc/src/zunitc_impl.c | ||
37 | +++ b/tools/zunitc/src/zunitc_impl.c | ||
38 | @@ -27,6 +27,7 @@ | ||
39 | |||
40 | #include <errno.h> | ||
41 | #include <fcntl.h> | ||
42 | +#include <libgen.h> | ||
43 | #include <stdarg.h> | ||
44 | #include <stdbool.h> | ||
45 | #include <stdio.h> | ||
diff --git a/recipes-graphics/wayland/weston_12.0.4.imx.bb b/recipes-graphics/wayland/weston_12.0.4.imx.bb index db0bfc4e..87593e4b 100644 --- a/recipes-graphics/wayland/weston_12.0.4.imx.bb +++ b/recipes-graphics/wayland/weston_12.0.4.imx.bb | |||
@@ -18,6 +18,7 @@ SRC_URI = "https://gitlab.freedesktop.org/wayland/weston/-/releases/${PV}/downlo | |||
18 | file://weston.desktop \ | 18 | file://weston.desktop \ |
19 | file://xwayland.weston-start \ | 19 | file://xwayland.weston-start \ |
20 | file://systemd-notify.weston-start \ | 20 | file://systemd-notify.weston-start \ |
21 | file://0001-libweston-tools-Include-libgen.h-for-basename-signat.patch \ | ||
21 | " | 22 | " |
22 | 23 | ||
23 | SRC_URI[sha256sum] = "eb686a7cf00992a23b17f192fca9a887313e92c346ee35d8575196983d656b4a" | 24 | SRC_URI[sha256sum] = "eb686a7cf00992a23b17f192fca9a887313e92c346ee35d8575196983d656b4a" |
diff --git a/recipes-security/optee-imx/optee-client-fslc.inc b/recipes-security/optee-imx/optee-client-fslc.inc index 132d594d..f55f0ab2 100644 --- a/recipes-security/optee-imx/optee-client-fslc.inc +++ b/recipes-security/optee-imx/optee-client-fslc.inc | |||
@@ -25,9 +25,9 @@ EXTRA_OEMAKE = " \ | |||
25 | do_install () { | 25 | do_install () { |
26 | oe_runmake -C ${S} install | 26 | oe_runmake -C ${S} install |
27 | 27 | ||
28 | install -D -p -m0644 ${B}/export/usr/lib/libteec.so.1.0.0 ${D}${libdir}/libteec.so.1.0.0 | 28 | install -D -p -m0644 ${B}/export/usr/lib/libteec.so.2.0.0 ${D}${libdir}/libteec.so.2.0.0 |
29 | ln -sf libteec.so.1.0.0 ${D}${libdir}/libteec.so.1 | 29 | ln -sf libteec.so.2.0.0 ${D}${libdir}/libteec.so.2 |
30 | ln -sf libteec.so.1.0.0 ${D}${libdir}/libteec.so | 30 | ln -sf libteec.so.2.0.0 ${D}${libdir}/libteec.so |
31 | 31 | ||
32 | install -D -p -m0644 ${B}/export/usr/lib/libckteec.so.0.1.0 ${D}${libdir}/libckteec.so.0.1.0 | 32 | install -D -p -m0644 ${B}/export/usr/lib/libckteec.so.0.1.0 ${D}${libdir}/libckteec.so.0.1.0 |
33 | ln -sf libckteec.so.0.1.0 ${D}${libdir}/libckteec.so.0 | 33 | ln -sf libckteec.so.0.1.0 ${D}${libdir}/libckteec.so.0 |