diff options
7 files changed, 234 insertions, 3 deletions
diff --git a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc/0001-base_type.h-make-header-compatible-with-c23.patch b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc/0001-base_type.h-make-header-compatible-with-c23.patch new file mode 100644 index 00000000..8d017ab7 --- /dev/null +++ b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc/0001-base_type.h-make-header-compatible-with-c23.patch | |||
@@ -0,0 +1,39 @@ | |||
1 | From e7f6097c9e7cb30f130502cc4804e1a1b01342de Mon Sep 17 00:00:00 2001 | ||
2 | From: Max Krummenacher <max.krummenacher@toradex.com> | ||
3 | Date: Wed, 7 May 2025 16:13:38 +0000 | ||
4 | Subject: [PATCH] base_type.h: make header compatible with c23 | ||
5 | |||
6 | With C23 bool, true and false are built in keywords and cannot be | ||
7 | redefined. | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> | ||
11 | --- | ||
12 | usr/include/hantro_VC8000E_enc/base_type.h | 4 ++++ | ||
13 | 1 file changed, 4 insertions(+) | ||
14 | |||
15 | diff --git a/usr/include/hantro_VC8000E_enc/base_type.h b/usr/include/hantro_VC8000E_enc/base_type.h | ||
16 | index 282fc81b8eba..af4212eed2bd 100755 | ||
17 | --- a/usr/include/hantro_VC8000E_enc/base_type.h | ||
18 | +++ b/usr/include/hantro_VC8000E_enc/base_type.h | ||
19 | @@ -67,6 +67,9 @@ typedef unsigned int UInt; | ||
20 | #define HANTRO_FALSE 0 | ||
21 | #define HANTRO_TRUE 1 | ||
22 | |||
23 | +#if defined __STDC_VERSION__ && __STDC_VERSION__ > 201710L | ||
24 | +/* bool, true and false are keywords. */ | ||
25 | +#else | ||
26 | #ifndef bool | ||
27 | typedef enum | ||
28 | { | ||
29 | @@ -74,6 +77,7 @@ typedef enum | ||
30 | true = HANTRO_TRUE | ||
31 | } bool; | ||
32 | #endif | ||
33 | +#endif | ||
34 | |||
35 | enum | ||
36 | { | ||
37 | -- | ||
38 | 2.42.0 | ||
39 | |||
diff --git a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.10.1.bb b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.10.1.bb index 2e4718c9..5aaf92c5 100644 --- a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.10.1.bb +++ b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.10.1.bb | |||
@@ -6,7 +6,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ca53281cc0caa7e320d4945a896fb837" | |||
6 | 6 | ||
7 | inherit fsl-eula-unpack | 7 | inherit fsl-eula-unpack |
8 | 8 | ||
9 | SRC_URI = "${FSL_MIRROR}/${BP}-${IMX_SRCREV_ABBREV}.bin;fsl-eula=true" | 9 | SRC_URI = " \ |
10 | ${FSL_MIRROR}/${BP}-${IMX_SRCREV_ABBREV}.bin;fsl-eula=true \ | ||
11 | file://0001-base_type.h-make-header-compatible-with-c23.patch \ | ||
12 | " | ||
10 | IMX_SRCREV_ABBREV = "c0244a1" | 13 | IMX_SRCREV_ABBREV = "c0244a1" |
11 | 14 | ||
12 | SRC_URI[sha256sum] = "713ba375f25490727fcc62bab5d5508f74de03204b4c153464b696b652c5c7df" | 15 | SRC_URI[sha256sum] = "713ba375f25490727fcc62bab5d5508f74de03204b4c153464b696b652c5c7df" |
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-basetype.h-make-header-compatible-with-c23.patch b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-basetype.h-make-header-compatible-with-c23.patch new file mode 100644 index 00000000..bbfec172 --- /dev/null +++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-basetype.h-make-header-compatible-with-c23.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From e39a6602817e4221ae09ac3d520ca6a0d94814dc Mon Sep 17 00:00:00 2001 | ||
2 | From: Max Krummenacher <max.krummenacher@toradex.com> | ||
3 | Date: Wed, 7 May 2025 16:13:38 +0000 | ||
4 | Subject: [PATCH] basetype.h: make header compatible with c23 | ||
5 | |||
6 | With C23 bool, true and false are built in keywords and cannot be | ||
7 | redefined. | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> | ||
11 | --- | ||
12 | h1_encoder/software/inc/basetype.h | 4 ++++ | ||
13 | 1 file changed, 4 insertions(+) | ||
14 | |||
15 | diff --git a/h1_encoder/software/inc/basetype.h b/h1_encoder/software/inc/basetype.h | ||
16 | index 55e46a195b3b..6655ec54481b 100755 | ||
17 | --- a/h1_encoder/software/inc/basetype.h | ||
18 | +++ b/h1_encoder/software/inc/basetype.h | ||
19 | @@ -66,12 +66,16 @@ typedef size_t ptr_t; | ||
20 | #define PRT_PTR "x" | ||
21 | #endif | ||
22 | |||
23 | +#if defined __STDC_VERSION__ && __STDC_VERSION__ > 201710L | ||
24 | +/* bool, true and false are keywords. */ | ||
25 | +#else | ||
26 | #ifndef __cplusplus | ||
27 | typedef enum { | ||
28 | false = 0, | ||
29 | true = 1 | ||
30 | } bool; | ||
31 | #endif | ||
32 | +#endif | ||
33 | |||
34 | #else /* __symbian__ or __win__ or whatever, customize it to suit well */ | ||
35 | |||
36 | -- | ||
37 | 2.42.0 | ||
38 | |||
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-test-md5-convert-to-ansi-c.patch b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-test-md5-convert-to-ansi-c.patch new file mode 100644 index 00000000..da1af2b9 --- /dev/null +++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-test-md5-convert-to-ansi-c.patch | |||
@@ -0,0 +1,90 @@ | |||
1 | From 0c5bdd12a6f3ba73e605656828bf429966a997ef Mon Sep 17 00:00:00 2001 | ||
2 | From: Max Krummenacher <max.krummenacher@toradex.com> | ||
3 | Date: Wed, 7 May 2025 13:25:26 +0000 | ||
4 | Subject: [PATCH] test: md5: convert to ansi c | ||
5 | |||
6 | GCC 15 no longer likes this K&R style function declarations. | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> | ||
10 | --- | ||
11 | decoder_sw/software/test/common/swhw/md5.c | 15 +++++---------- | ||
12 | decoder_sw/software/test/common/swhw/md5.h | 8 ++++---- | ||
13 | 2 files changed, 9 insertions(+), 14 deletions(-) | ||
14 | |||
15 | diff --git a/decoder_sw/software/test/common/swhw/md5.c b/decoder_sw/software/test/common/swhw/md5.c | ||
16 | index c3334bf751fd..20014fbdf268 100755 | ||
17 | --- a/decoder_sw/software/test/common/swhw/md5.c | ||
18 | +++ b/decoder_sw/software/test/common/swhw/md5.c | ||
19 | @@ -42,8 +42,7 @@ | ||
20 | /* | ||
21 | * Note: this code is harmless on little-endian machines. | ||
22 | */ | ||
23 | -void ByteReverse(buf, longs) unsigned char *buf; | ||
24 | -unsigned longs; | ||
25 | +void ByteReverse(unsigned char *buf, unsigned longs) | ||
26 | { | ||
27 | uint32 t; | ||
28 | do { | ||
29 | @@ -59,7 +58,7 @@ unsigned longs; | ||
30 | * Start MD5 accumulation. Set bit count to 0 and buffer to mysterious | ||
31 | * initialization constants. | ||
32 | */ | ||
33 | -void MD5Init(ctx) struct MD5Context *ctx; | ||
34 | +void MD5Init(struct MD5Context *ctx) | ||
35 | { | ||
36 | ctx->buf[0] = 0x67452301; | ||
37 | ctx->buf[1] = 0xefcdab89; | ||
38 | @@ -74,9 +73,7 @@ void MD5Init(ctx) struct MD5Context *ctx; | ||
39 | * Update context to reflect the concatenation of another buffer full | ||
40 | * of bytes. | ||
41 | */ | ||
42 | -void MD5Update(ctx, buf, len) struct MD5Context *ctx; | ||
43 | -unsigned char *buf; | ||
44 | -unsigned len; | ||
45 | +void MD5Update(struct MD5Context *ctx, unsigned char *buf, unsigned len) | ||
46 | { | ||
47 | uint32 t; | ||
48 | |||
49 | @@ -124,8 +121,7 @@ unsigned len; | ||
50 | * Final wrapup - pad to 64-byte boundary with the bit pattern | ||
51 | * 1 0* (64-bit count of bits processed, MSB-first) | ||
52 | */ | ||
53 | -void MD5Final(digest, ctx) unsigned char digest[16]; | ||
54 | -struct MD5Context *ctx; | ||
55 | +void MD5Final(unsigned char digest[16], struct MD5Context *ctx) | ||
56 | { | ||
57 | unsigned count; | ||
58 | unsigned char *p; | ||
59 | @@ -186,8 +182,7 @@ struct MD5Context *ctx; | ||
60 | * reflect the addition of 16 longwords of new data. MD5Update blocks | ||
61 | * the data and converts bytes into longwords for this routine. | ||
62 | */ | ||
63 | -void MD5Transform(buf, in) uint32 buf[4]; | ||
64 | -uint32 in[16]; | ||
65 | +void MD5Transform(uint32 buf[4], uint32 in[16]) | ||
66 | { | ||
67 | register uint32 a, b, c, d; | ||
68 | |||
69 | diff --git a/decoder_sw/software/test/common/swhw/md5.h b/decoder_sw/software/test/common/swhw/md5.h | ||
70 | index 516400236606..c1d773093b66 100755 | ||
71 | --- a/decoder_sw/software/test/common/swhw/md5.h | ||
72 | +++ b/decoder_sw/software/test/common/swhw/md5.h | ||
73 | @@ -76,10 +76,10 @@ struct MD5Context { | ||
74 | unsigned char in[64]; | ||
75 | }; | ||
76 | |||
77 | -extern void MD5Init(); | ||
78 | -extern void MD5Update(); | ||
79 | -extern void MD5Final(); | ||
80 | -extern void MD5Transform(); | ||
81 | +extern void MD5Init(struct MD5Context *ctx); | ||
82 | +extern void MD5Update(struct MD5Context *ctx, unsigned char *buf, unsigned len); | ||
83 | +extern void MD5Final(unsigned char digest[16], struct MD5Context *ctx); | ||
84 | +extern void MD5Transform(uint32 buf[4], uint32 in[16]); | ||
85 | |||
86 | /* | ||
87 | * This is needed to make RSAREF happy on some MS-DOS compilers. | ||
88 | -- | ||
89 | 2.42.0 | ||
90 | |||
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.36.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.36.0.bb index 645d2554..3a171942 100644 --- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.36.0.bb +++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.36.0.bb | |||
@@ -6,7 +6,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c0fb372b5d7f12181de23ef480f225f3" | |||
6 | 6 | ||
7 | PROVIDES = "virtual/imxvpu" | 7 | PROVIDES = "virtual/imxvpu" |
8 | 8 | ||
9 | SRC_URI = "${FSL_MIRROR}/${BP}-${IMX_SRCREV_ABBREV}.bin;fsl-eula=true" | 9 | SRC_URI = " \ |
10 | ${FSL_MIRROR}/${BP}-${IMX_SRCREV_ABBREV}.bin;fsl-eula=true \ | ||
11 | file://0001-test-md5-convert-to-ansi-c.patch \ | ||
12 | file://0001-basetype.h-make-header-compatible-with-c23.patch \ | ||
13 | " | ||
10 | IMX_SRCREV_ABBREV = "194a305" | 14 | IMX_SRCREV_ABBREV = "194a305" |
11 | 15 | ||
12 | SRC_URI[sha256sum] = "0ef1fb5c6653c08f2d2812c72dedf3e8beb091dd5b3d70d6e26f41bac4ebffa7" | 16 | SRC_URI[sha256sum] = "0ef1fb5c6653c08f2d2812c72dedf3e8beb091dd5b3d70d6e26f41bac4ebffa7" |
diff --git a/recipes-kernel/linux/linux-imx-headers/0001-video-fbdev-mxc-make-uapi-ipu.h-pxp_dma.h-compatible.patch b/recipes-kernel/linux/linux-imx-headers/0001-video-fbdev-mxc-make-uapi-ipu.h-pxp_dma.h-compatible.patch new file mode 100644 index 00000000..1750d624 --- /dev/null +++ b/recipes-kernel/linux/linux-imx-headers/0001-video-fbdev-mxc-make-uapi-ipu.h-pxp_dma.h-compatible.patch | |||
@@ -0,0 +1,54 @@ | |||
1 | From a5bcb18b42cfc0485397da9f48be6a73de86dfac Mon Sep 17 00:00:00 2001 | ||
2 | From: Max Krummenacher <max.krummenacher@toradex.com> | ||
3 | Date: Sat, 10 May 2025 14:21:35 +0200 | ||
4 | Subject: [PATCH] video: fbdev: mxc: make uapi ipu.h, pxp_dma.h compatible with | ||
5 | c23 standard | ||
6 | |||
7 | In C23 standard bool, false, true are reserved keywords. | ||
8 | Make ipu.h, pxp_dma.h uapi include file compatible with C23 standard. | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> | ||
12 | --- | ||
13 | include/uapi/linux/ipu.h | 4 ++++ | ||
14 | include/uapi/linux/pxp_dma.h | 4 ++++ | ||
15 | 2 files changed, 8 insertions(+) | ||
16 | |||
17 | diff --git a/include/uapi/linux/ipu.h b/include/uapi/linux/ipu.h | ||
18 | index c92f292bcc9d..a7b60730bbd4 100644 | ||
19 | --- a/include/uapi/linux/ipu.h | ||
20 | +++ b/include/uapi/linux/ipu.h | ||
21 | @@ -29,9 +29,13 @@ | ||
22 | #include <linux/videodev2.h> | ||
23 | |||
24 | #ifndef __KERNEL__ | ||
25 | +#if defined __STDC_VERSION__ && __STDC_VERSION__ > 201710L | ||
26 | +/* bool, true and false are keywords. */ | ||
27 | +#else | ||
28 | #ifndef __cplusplus | ||
29 | typedef unsigned char bool; | ||
30 | #endif | ||
31 | +#endif | ||
32 | #define irqreturn_t int | ||
33 | #define dma_addr_t int | ||
34 | #define uint32_t unsigned int | ||
35 | diff --git a/include/uapi/linux/pxp_dma.h b/include/uapi/linux/pxp_dma.h | ||
36 | index 9b5228504095..e2deff07516d 100644 | ||
37 | --- a/include/uapi/linux/pxp_dma.h | ||
38 | +++ b/include/uapi/linux/pxp_dma.h | ||
39 | @@ -25,8 +25,12 @@ | ||
40 | |||
41 | #ifndef __KERNEL__ | ||
42 | typedef unsigned long dma_addr_t; | ||
43 | +#if defined __STDC_VERSION__ && __STDC_VERSION__ > 201710L | ||
44 | +/* bool, true and false are keywords. */ | ||
45 | +#else | ||
46 | typedef unsigned char bool; | ||
47 | #endif | ||
48 | +#endif | ||
49 | |||
50 | /* PXP Pixel format definitions */ | ||
51 | /* Four-character-code (FOURCC) */ | ||
52 | -- | ||
53 | 2.42.0 | ||
54 | |||
diff --git a/recipes-kernel/linux/linux-imx-headers_6.6.bb b/recipes-kernel/linux/linux-imx-headers_6.6.bb index dbf4442c..41c337c4 100644 --- a/recipes-kernel/linux/linux-imx-headers_6.6.bb +++ b/recipes-kernel/linux/linux-imx-headers_6.6.bb | |||
@@ -7,7 +7,10 @@ New headers are installed in ${includedir}/imx." | |||
7 | LICENSE = "GPL-2.0-only" | 7 | LICENSE = "GPL-2.0-only" |
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" |
9 | 9 | ||
10 | SRC_URI = "git://github.com/nxp-imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}" | 10 | SRC_URI = " \ |
11 | git://github.com/nxp-imx/linux-imx.git;protocol=https;branch=${SRCBRANCH} \ | ||
12 | file://0001-video-fbdev-mxc-make-uapi-ipu.h-pxp_dma.h-compatible.patch \ | ||
13 | " | ||
11 | SRCBRANCH = "lf-6.6.y" | 14 | SRCBRANCH = "lf-6.6.y" |
12 | LOCALVERSION = "-6.6.52-2.2.0" | 15 | LOCALVERSION = "-6.6.52-2.2.0" |
13 | SRCREV = "e0f9e2afd4cff3f02d71891244b4aa5899dfc786" | 16 | SRCREV = "e0f9e2afd4cff3f02d71891244b4aa5899dfc786" |