summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-mkimage/imx-boot_1.0.bb')
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_1.0.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
index bdbb97c9..eae1778c 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
+++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
@@ -44,6 +44,8 @@ OEI_NAME ?= "oei-${OEI_CORE}-*.bin"
44ATF_MACHINE_NAME ?= "bl31-${ATF_PLATFORM}.bin" 44ATF_MACHINE_NAME ?= "bl31-${ATF_PLATFORM}.bin"
45ATF_MACHINE_NAME:append = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', '-optee', '', d)}" 45ATF_MACHINE_NAME:append = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', '-optee', '', d)}"
46 46
47BOOT_VARIANT ?= ""
48
47TOOLS_NAME ?= "mkimage_imx8" 49TOOLS_NAME ?= "mkimage_imx8"
48 50
49IMX_BOOT_SOC_TARGET ?= "INVALID" 51IMX_BOOT_SOC_TARGET ?= "INVALID"
@@ -222,7 +224,7 @@ do_compile() {
222 UBOOT_DTB_NAME_EXTRA="${dtb_name}" 224 UBOOT_DTB_NAME_EXTRA="${dtb_name}"
223 fi 225 fi
224 UBOOT_NAME_EXTRA="u-boot-${MACHINE}.bin-${UBOOT_CONFIG_EXTRA}" 226 UBOOT_NAME_EXTRA="u-boot-${MACHINE}.bin-${UBOOT_CONFIG_EXTRA}"
225 BOOT_CONFIG_MACHINE_EXTRA="imx-boot-${MACHINE}-${UBOOT_CONFIG_EXTRA}.bin" 227 BOOT_CONFIG_MACHINE_EXTRA="imx-boot${BOOT_VARIANT}-${MACHINE}-${UBOOT_CONFIG_EXTRA}.bin"
226 228
227 for target in ${IMXBOOT_TARGETS}; do 229 for target in ${IMXBOOT_TARGETS}; do
228 compile_${SOC_FAMILY} 230 compile_${SOC_FAMILY}
@@ -273,7 +275,7 @@ do_install () {
273 bbnote "UBOOT_CONFIG = $type" 275 bbnote "UBOOT_CONFIG = $type"
274 276
275 UBOOT_CONFIG_EXTRA="$type" 277 UBOOT_CONFIG_EXTRA="$type"
276 BOOT_CONFIG_MACHINE_EXTRA="imx-boot-${MACHINE}-${UBOOT_CONFIG_EXTRA}.bin" 278 BOOT_CONFIG_MACHINE_EXTRA="imx-boot${BOOT_VARIANT}-${MACHINE}-${UBOOT_CONFIG_EXTRA}.bin"
277 279
278 for target in ${IMXBOOT_TARGETS}; do 280 for target in ${IMXBOOT_TARGETS}; do
279 install -m 0644 ${S}/${BOOT_CONFIG_MACHINE_EXTRA}-${target} ${D}/boot/ 281 install -m 0644 ${S}/${BOOT_CONFIG_MACHINE_EXTRA}-${target} ${D}/boot/
@@ -380,7 +382,7 @@ do_deploy() {
380 for type in ${UBOOT_CONFIG}; do 382 for type in ${UBOOT_CONFIG}; do
381 UBOOT_CONFIG_EXTRA="$type" 383 UBOOT_CONFIG_EXTRA="$type"
382 UBOOT_NAME_EXTRA="u-boot-${MACHINE}.bin-${UBOOT_CONFIG_EXTRA}" 384 UBOOT_NAME_EXTRA="u-boot-${MACHINE}.bin-${UBOOT_CONFIG_EXTRA}"
383 BOOT_CONFIG_MACHINE_EXTRA="imx-boot-${MACHINE}-${UBOOT_CONFIG_EXTRA}.bin" 385 BOOT_CONFIG_MACHINE_EXTRA="imx-boot${BOOT_VARIANT}-${MACHINE}-${UBOOT_CONFIG_EXTRA}.bin"
384 386
385 if [ -e ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG_EXTRA} ] ; then 387 if [ -e ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG_EXTRA} ] ; then
386 install -m 0644 ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG_EXTRA} \ 388 install -m 0644 ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG_EXTRA} \