diff options
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-decoder_sw-resolve-compilation-error-with-fcommon.patch | 54 | ||||
-rw-r--r-- | recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.18.0.bb | 1 |
2 files changed, 55 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-decoder_sw-resolve-compilation-error-with-fcommon.patch b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-decoder_sw-resolve-compilation-error-with-fcommon.patch new file mode 100644 index 00000000..8d9610d5 --- /dev/null +++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-decoder_sw-resolve-compilation-error-with-fcommon.patch | |||
@@ -0,0 +1,54 @@ | |||
1 | From 5bfb24738c47003fd04a86bfd5a49f8c6354ed23 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | ||
3 | Date: Fri, 28 Aug 2020 07:46:35 +0000 | ||
4 | Subject: [PATCH] decoder_sw: resolve compilation error with -fcommon | ||
5 | |||
6 | -fcommon is enabled by default in gcc10 compiler, which results in | ||
7 | following build errors: | ||
8 | |||
9 | decoder_sw/software/source/inc/decapicommon.h:272: multiple definition | ||
10 | of `DecPicCodingType'; decoder_sw/software/linux/dwl/dwl_linux.o: | ||
11 | decoder_sw/software/source/inc/decapicommon.h:272: first defined here | ||
12 | |||
13 | decoder_sw/software/source/inc/dwl.h:94: multiple definition of | ||
14 | `DWLInitParam'; decoder_sw/software/linux/dwl/dwl_linux.o: | ||
15 | decoder_sw/software/source/inc/dwl.h:94: first defined here | ||
16 | |||
17 | Drop multiple enum name definitions, which solves above compilation | ||
18 | issues. | ||
19 | |||
20 | Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | ||
21 | --- | ||
22 | decoder_sw/software/source/inc/decapicommon.h | 2 +- | ||
23 | decoder_sw/software/source/inc/dwl.h | 2 +- | ||
24 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
25 | |||
26 | diff --git a/decoder_sw/software/source/inc/decapicommon.h b/decoder_sw/software/source/inc/decapicommon.h | ||
27 | index 0f02092..fc8cccf 100755 | ||
28 | --- a/decoder_sw/software/source/inc/decapicommon.h | ||
29 | +++ b/decoder_sw/software/source/inc/decapicommon.h | ||
30 | @@ -269,7 +269,7 @@ enum DecPicCodingType { | ||
31 | DEC_PIC_TYPE_D = 3, | ||
32 | DEC_PIC_TYPE_FI = 4, | ||
33 | DEC_PIC_TYPE_BI = 5 | ||
34 | -} DecPicCodingType; | ||
35 | +}; | ||
36 | |||
37 | /* Output picture pixel format types for raster scan or down scale output */ | ||
38 | enum DecPicturePixelFormat { | ||
39 | diff --git a/decoder_sw/software/source/inc/dwl.h b/decoder_sw/software/source/inc/dwl.h | ||
40 | index 6991f03..fd357b3 100755 | ||
41 | --- a/decoder_sw/software/source/inc/dwl.h | ||
42 | +++ b/decoder_sw/software/source/inc/dwl.h | ||
43 | @@ -91,7 +91,7 @@ struct DWLLinearMem { | ||
44 | /* DWLInitParam is used to pass parameters when initializing the DWL */ | ||
45 | struct DWLInitParam { | ||
46 | u32 client_type; | ||
47 | -} DWLInitParam; | ||
48 | +}; | ||
49 | |||
50 | /* Hardware configuration description, same as in top API */ | ||
51 | typedef struct DecHwConfig DWLHwConfig; | ||
52 | -- | ||
53 | 2.17.1 | ||
54 | |||
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.18.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.18.0.bb index 93206263..a950f548 100644 --- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.18.0.bb +++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.18.0.bb | |||
@@ -8,6 +8,7 @@ PROVIDES = "virtual/imxvpu" | |||
8 | 8 | ||
9 | SRC_URI = " \ | 9 | SRC_URI = " \ |
10 | ${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true \ | 10 | ${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true \ |
11 | file://0001-decoder_sw-resolve-compilation-error-with-fcommon.patch \ | ||
11 | " | 12 | " |
12 | SRC_URI[md5sum] = "78034de7ed74363eb793d29894bba5e3" | 13 | SRC_URI[md5sum] = "78034de7ed74363eb793d29894bba5e3" |
13 | SRC_URI[sha256sum] = "bebd82649d00d6dd8236b77b8677b1cc6ac46dc474200502df7797a75dc8f568" | 14 | SRC_URI[sha256sum] = "bebd82649d00d6dd8236b77b8677b1cc6ac46dc474200502df7797a75dc8f568" |