summaryrefslogtreecommitdiffstats
path: root/recipes-extended/secure-obj/secure-obj_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/secure-obj/secure-obj_git.bb')
-rw-r--r--recipes-extended/secure-obj/secure-obj_git.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/recipes-extended/secure-obj/secure-obj_git.bb b/recipes-extended/secure-obj/secure-obj_git.bb
index 84ecea1e..64f59f47 100644
--- a/recipes-extended/secure-obj/secure-obj_git.bb
+++ b/recipes-extended/secure-obj/secure-obj_git.bb
@@ -1,9 +1,11 @@
1require secure-obj.inc 1require secure-obj.inc
2 2
3LIC_FILES_CHKSUM = "file://README;md5=82b72e88f23cded9dd23f0fb1790b8d2" 3LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
4 4
5S = "${WORKDIR}/git" 5S = "${WORKDIR}/git"
6 6
7DEPENDS:remove = " python3-pycryptodomex-native"
8DEPENDS:append = " python3-cryptography-native optee-os-qoriq-tadevkit"
7RDEPENDS:{PN} += "secure-obj-module" 9RDEPENDS:{PN} += "secure-obj-module"
8 10
9WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" 11WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
@@ -17,14 +19,15 @@ CFLAGS += "${TOOLCHAIN_OPTIONS}"
17 19
18do_compile() { 20do_compile() {
19 unset LDFLAGS 21 unset LDFLAGS
20 export TA_DEV_KIT_DIR="${RECIPE_SYSROOT}/usr/include/optee/export-user_ta" 22 export TA_DEV_KIT_DIR=${STAGING_INCDIR}/optee/export-user_ta/
21 export CROSS_COMPILE="${WRAP_TARGET_PREFIX}" 23 export CROSS_COMPILE="${WRAP_TARGET_PREFIX}"
22 export OPENSSL_PATH="${RECIPE_SYSROOT}/usr" 24 export OPENSSL_PATH="${RECIPE_SYSROOT}/usr"
23 for APP in secure_storage_ta securekey_lib secure_obj-openssl-engine; do 25 export OPENSSL_MODULES=${STAGING_LIBDIR_NATIVE}/ossl-modules
26 for APP in secure_storage_ta securekey_lib secure_obj-openssl-engine; do
24 cd ${APP} 27 cd ${APP}
25 oe_runmake 28 oe_runmake
26 cd .. 29 cd ..
27 done 30 done
28} 31}
29 32
30do_install() { 33do_install() {