diff options
Diffstat (limited to 'recipes-extended/secure-obj')
-rw-r--r-- | recipes-extended/secure-obj/secure-obj.inc | 6 | ||||
-rw-r--r-- | recipes-extended/secure-obj/secure-obj_git.bb | 12 |
2 files changed, 9 insertions, 9 deletions
diff --git a/recipes-extended/secure-obj/secure-obj.inc b/recipes-extended/secure-obj/secure-obj.inc index 8a62d9cb..55f20ed5 100644 --- a/recipes-extended/secure-obj/secure-obj.inc +++ b/recipes-extended/secure-obj/secure-obj.inc | |||
@@ -2,7 +2,7 @@ DESCRIPTION = "Secure Object" | |||
2 | LICENSE = "BSD" | 2 | LICENSE = "BSD" |
3 | 3 | ||
4 | DEPENDS = "openssl optee-os-qoriq optee-client-qoriq" | 4 | DEPENDS = "openssl optee-os-qoriq optee-client-qoriq" |
5 | RDEPENDS_${PN} = "bash libcrypto libssl" | 5 | RDEPENDS:${PN} = "bash libcrypto libssl" |
6 | 6 | ||
7 | DEPENDS += "python3-pycryptodomex-native" | 7 | DEPENDS += "python3-pycryptodomex-native" |
8 | 8 | ||
@@ -20,9 +20,9 @@ export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr" | |||
20 | 20 | ||
21 | EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}"' | 21 | EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}"' |
22 | 22 | ||
23 | ALLOW_EMPTY_${PN} = "1" | 23 | ALLOW_EMPTY:${PN} = "1" |
24 | INHIBIT_PACKAGE_STRIP = "1" | 24 | INHIBIT_PACKAGE_STRIP = "1" |
25 | PARALLEL_MAKE = "" | 25 | PARALLEL_MAKE = "" |
26 | INSANE_SKIP_${PN} = "ldflags" | 26 | INSANE_SKIP:${PN} = "ldflags" |
27 | COMPATIBLE_MACHINE = "(qoriq-arm64)" | 27 | COMPATIBLE_MACHINE = "(qoriq-arm64)" |
28 | DEBUG_BUILD = "1" | 28 | DEBUG_BUILD = "1" |
diff --git a/recipes-extended/secure-obj/secure-obj_git.bb b/recipes-extended/secure-obj/secure-obj_git.bb index 2d723738..1fd1fea3 100644 --- a/recipes-extended/secure-obj/secure-obj_git.bb +++ b/recipes-extended/secure-obj/secure-obj_git.bb | |||
@@ -4,15 +4,15 @@ LIC_FILES_CHKSUM = "file://README;md5=82b72e88f23cded9dd23f0fb1790b8d2" | |||
4 | 4 | ||
5 | S = "${WORKDIR}/git" | 5 | S = "${WORKDIR}/git" |
6 | 6 | ||
7 | RDEPENDS_{PN} += "secure-obj-module" | 7 | RDEPENDS:{PN} += "secure-obj-module" |
8 | 8 | ||
9 | WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" | 9 | WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" |
10 | export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/" | 10 | export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/" |
11 | export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr" | 11 | export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr" |
12 | export CROSS_COMPILE_HOST = "${CROSS_COMPILE}" | 12 | export CROSS_COMPILE_HOST = "${CROSS_COMPILE}" |
13 | export CROSS_COMPILE_TA = "${CROSS_COMPILE}" | 13 | export CROSS_COMPILE_TA = "${CROSS_COMPILE}" |
14 | ARCH_qoriq-arm64 = "aarch64" | 14 | ARCH:qoriq-arm64 = "aarch64" |
15 | ARCH_qoriq-arm = "arm" | 15 | ARCH:qoriq-arm = "arm" |
16 | 16 | ||
17 | do_compile() { | 17 | do_compile() { |
18 | unset LDFLAGS | 18 | unset LDFLAGS |
@@ -41,6 +41,6 @@ do_install() { | |||
41 | rm -rf ${D}${bindir}/test | 41 | rm -rf ${D}${bindir}/test |
42 | } | 42 | } |
43 | 43 | ||
44 | FILES_${PN} += "${base_libdir}/optee_armtz ${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines" | 44 | FILES:${PN} += "${base_libdir}/optee_armtz ${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines" |
45 | INSANE_SKIP_${PN} = "dev-deps ldflags" | 45 | INSANE_SKIP:${PN} = "dev-deps ldflags" |
46 | INSANE_SKIP_${PN}-dev = "ldflags dev-elf" | 46 | INSANE_SKIP:${PN}-dev = "ldflags dev-elf" |