diff options
Diffstat (limited to 'recipes-multimedia/imx-parser/imx-parser_4.4.2.bb')
-rw-r--r-- | recipes-multimedia/imx-parser/imx-parser_4.4.2.bb | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-parser/imx-parser_4.4.2.bb b/recipes-multimedia/imx-parser/imx-parser_4.4.2.bb new file mode 100644 index 00000000..492ab893 --- /dev/null +++ b/recipes-multimedia/imx-parser/imx-parser_4.4.2.bb | |||
@@ -0,0 +1,46 @@ | |||
1 | # Copyright (C) 2012-2018 O.S. Systems Software LTDA. | ||
2 | # Copyright (C) 2012-2016 Freescale Semiconductor | ||
3 | # Copyright 2017 NXP | ||
4 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
5 | DESCRIPTION = "Freescale Multimedia parser libs" | ||
6 | LICENSE = "Proprietary" | ||
7 | SECTION = "multimedia" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=5ab1a30d0cd181e3408077727ea5a2db" | ||
9 | |||
10 | # For backwards compatibility | ||
11 | PROVIDES += "libfslparser" | ||
12 | RREPLACES_${PN} = "libfslparser" | ||
13 | RPROVIDES_${PN} = "libfslparser" | ||
14 | RCONFLICTS_${PN} = "libfslparser" | ||
15 | |||
16 | SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true" | ||
17 | SRC_URI[md5sum] = "0e425e143900f980c6fe7f735a679829" | ||
18 | SRC_URI[sha256sum] = "21d1066dcdc6f0eb7efc56910ee9b116883456a013837506a0632153baedcbf3" | ||
19 | |||
20 | inherit fsl-eula-unpack autotools pkgconfig | ||
21 | |||
22 | # Choose between 32-bit and 64-bit binaries and between Soft Float-Point and Hard Float-Point | ||
23 | EXTRA_OECONF = "${@bb.utils.contains('TUNE_FEATURES', 'aarch64', '--enable-armv8', \ | ||
24 | bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--enable-fhw', '--enable-fsw', d), d)}" | ||
25 | |||
26 | INHIBIT_PACKAGE_STRIP = "1" | ||
27 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
28 | |||
29 | python __set_insane_skip() { | ||
30 | # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have | ||
31 | # the source we cannot fix it. Disable the insane check for now. | ||
32 | # FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those | ||
33 | for p in d.getVar('PACKAGES', True).split(): | ||
34 | d.setVar("INSANE_SKIP_%s" % p, "ldflags dev-so textrel") | ||
35 | } | ||
36 | |||
37 | do_package_qa[prefuncs] += "__set_insane_skip" | ||
38 | |||
39 | # FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those | ||
40 | FILES_${PN} += "${libdir}/imx-mm/*/*${SOLIBS} ${libdir}/imx-mm/*/*${SOLIBSDEV}" | ||
41 | |||
42 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
43 | |||
44 | INHIBIT_SYSROOT_STRIP = "1" | ||
45 | |||
46 | COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" | ||