diff options
Diffstat (limited to 'recipes-multimedia/libfslparser')
-rw-r--r-- | recipes-multimedia/libfslparser/libfslparser.inc | 33 | ||||
-rw-r--r-- | recipes-multimedia/libfslparser/libfslparser_4.0.3.bb | 10 |
2 files changed, 43 insertions, 0 deletions
diff --git a/recipes-multimedia/libfslparser/libfslparser.inc b/recipes-multimedia/libfslparser/libfslparser.inc new file mode 100644 index 00000000..d46330e4 --- /dev/null +++ b/recipes-multimedia/libfslparser/libfslparser.inc | |||
@@ -0,0 +1,33 @@ | |||
1 | # Copyright (C) 2012-2014 O.S. Systems Software LTDA. | ||
2 | # Copyright (C) 2012-2013 Freescale Semiconductor | ||
3 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
4 | DESCRIPTION = "Freescale Multimedia parser libs" | ||
5 | LICENSE = "Proprietary" | ||
6 | SECTION = "multimedia" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=acdb807ac7275fe32f9f64992e111241" | ||
8 | |||
9 | inherit fsl-eula-unpack autotools pkgconfig | ||
10 | |||
11 | SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true" | ||
12 | |||
13 | # Choose between Soft Float-Point and Hard Float-Point | ||
14 | EXTRA_OECONF = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--enable-fhw', '--enable-fsw', d)}" | ||
15 | |||
16 | INHIBIT_PACKAGE_STRIP = "1" | ||
17 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
18 | |||
19 | python __set_insane_skip() { | ||
20 | # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have | ||
21 | # the source we cannot fix it. Disable the insane check for now. | ||
22 | # FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those | ||
23 | for p in d.getVar('PACKAGES', True).split(): | ||
24 | d.setVar("INSANE_SKIP_%s" % p, "ldflags dev-so textrel") | ||
25 | } | ||
26 | |||
27 | do_package_qa[prefuncs] += "__set_insane_skip" | ||
28 | |||
29 | # FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those | ||
30 | FILES_${PN} += "${libdir}/imx-mm/*/*${SOLIBS} ${libdir}/imx-mm/*/*${SOLIBSDEV}" | ||
31 | |||
32 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
33 | |||
diff --git a/recipes-multimedia/libfslparser/libfslparser_4.0.3.bb b/recipes-multimedia/libfslparser/libfslparser_4.0.3.bb new file mode 100644 index 00000000..790cb952 --- /dev/null +++ b/recipes-multimedia/libfslparser/libfslparser_4.0.3.bb | |||
@@ -0,0 +1,10 @@ | |||
1 | # Copyright (C) 2013-2015 Freescale Semiconductor | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | require recipes-multimedia/libfslparser/libfslparser.inc | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=acdb807ac7275fe32f9f64992e111241" | ||
6 | |||
7 | SRC_URI[md5sum] = "a0b0779edc543536de71898657072275" | ||
8 | SRC_URI[sha256sum] = "9db10ca6a61c8fdbe91b55b65d084dcbb5f9cfb58b088996c7dd2d6dc8385730" | ||
9 | |||
10 | COMPATIBLE_MACHINE = "(mx6)" | ||