diff options
Diffstat (limited to 'recipes-virtualization/hypervisor/files')
-rw-r--r-- | recipes-virtualization/hypervisor/files/0001-fix-build-error-gcc7.patch | 40 |
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-virtualization/hypervisor/files/0001-fix-build-error-gcc7.patch b/recipes-virtualization/hypervisor/files/0001-fix-build-error-gcc7.patch new file mode 100644 index 00000000..1100ab6e --- /dev/null +++ b/recipes-virtualization/hypervisor/files/0001-fix-build-error-gcc7.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | From 51f545b9c16f6a371c129bd0fbb9c7f7ae339df3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Chunrong Guo <chunrong.guo@nxp.com> | ||
3 | Date: Thu, 13 Jul 2017 13:59:28 +0800 | ||
4 | Subject: [PATCH] fix build error gcc7 | ||
5 | |||
6 | |||
7 | Upstream-Status: Pending | ||
8 | |||
9 | --- | ||
10 | Makefile.build | 7 ++++--- | ||
11 | 1 file changed, 4 insertions(+), 3 deletions(-) | ||
12 | |||
13 | diff --git a/Makefile.build b/Makefile.build | ||
14 | index e93cc9a..f6028fe 100644 | ||
15 | --- a/Makefile.build | ||
16 | +++ b/Makefile.build | ||
17 | @@ -35,7 +35,8 @@ GENASSYM=$(libos)lib/genassym.sh | ||
18 | |||
19 | export libos := $(src)libos/ | ||
20 | |||
21 | -export CC=$(CROSS_COMPILE)gcc | ||
22 | + | ||
23 | + | ||
24 | |||
25 | export GCCINCDIR := $(shell $(CC) -print-file-name=include) | ||
26 | CC_OPTS=-Wa,-m$(CONFIG_GCC_CPU_FLAG) -nostdinc -I $(GCCINCDIR) -I $(GCCINCDIR)-fixed \ | ||
27 | @@ -46,8 +47,8 @@ CC_OPTS=-Wa,-m$(CONFIG_GCC_CPU_FLAG) -nostdinc -I $(GCCINCDIR) -I $(GCCINCDIR)-f | ||
28 | export CC_OPTS_NODEP := -include include/config/autoconf.h | ||
29 | |||
30 | export WARNINGS := -Wwrite-strings -Wmissing-prototypes \ | ||
31 | - -Wstrict-prototypes -Wold-style-definition \ | ||
32 | - -Wmissing-declarations | ||
33 | + -Wstrict-prototypes -Wold-style-definition -Wno-format-truncation \ | ||
34 | + -Wmissing-declarations | ||
35 | |||
36 | # Our code should build without any of these warnings, but some | ||
37 | # external code may be excluded. | ||
38 | -- | ||
39 | 2.7.4 | ||
40 | |||